For some years, I have questioned whether the built-in USB ports on my MacPro3,1 may not be functioning quite properly. This has extended through several updates and reinstallations of MacOS, leaving me to suspect the hardware itself, rather than the software (unless, of course, the USB software through all those updates remains unchanged). Sometimes, inconsistently and intermittently, the USB ports seem to not respond quite right. Switching ports, or unplugging and re-plugging, or rebooting, generally fixes the problem, yet it continues, in its vague manner. Historically, the only USB devices used were mice, keyboards, and compact flash card readers.

Recently, I have tried to get a flight simulator for radio controlled aircraft to run on my MacPro. An actual radio control transponder is linked to the software via a USB dongle. This dongle accepts the radio signals from the transponder’s two joysticks, and converts them into game controller signals at the Mac. The software then is supposed to respond to these game controller signals.

Having tried two different transponders and two different dongles, I’ve been unable to get the sim to work on my MacPro. Yesterday, for the first time, I installed the sim on my MacBook Pro for the first time. It worked immediately, no problem, with some of the same hardware that would not work on the MacPro! This suggested to me that, perhaps, the MacPro’s USB hardware were at fault.

One combination of dongle and transponder worked once on the MacPro, but no longer responds. The (different) combination that works on the MacBook Pro was strange on the MacPro; sometimes, the left joystick could be calibrated, but never the right; other times, not even the left would respond.

Could the MacPro's USB ports be at fault? Might they work well enough to run simple devices, such as mice and keyboards, yet fail when trying to use a dongle to funnel data from two joysticks and, potentially, many buttons? Is it possible that “simple” USB devices may run well enough, with occasional glitches; yet, more “complex” devices may not run at all?


If it is plausible that the MacPro3,1’s on-board USB hardware is failing, might the problem be fixed by installing a new USB card into one of the Mac’s empty PCIe slots, and never again plugging any USB devices into the on-board USB? If so, which USB card is appropriate for the MacPro3,1? The computer is running El Capitan, so I see there would be no 3.1 drivers available. Would it still run fine for USB 1 and 2? I’m guessing that this old beast would be best served with two Type A connectors:


I don’t know that it should be necessary to see the specific devices being discussed in the attempt to run the simulator, but here are the links:

neXt CGM-RC-Heli-Simulator

Spektrum DX8 Transmitter

RC Ware RX2SIM Dongle

OrangeRx DSMX/DSM2 Compatible USB Dongle for Flight Simulator