Results 1 to 3 of 3

Thread: New SSD in 2010 MBP

  1. #1
    Join Date
    May 2015

    Confused New SSD in 2010 MBP

    Hi there,

    I recently bought a new 500gb Samsung 850 EVO to put in my 15" 2010 i5 MacBook Pro and it's not been smooth sailing. I am running OS 10.6.8.

    I have tried cloning my old drive using carbon cloner and super duper and both times having mounted internally although my programmes are running quickly enough I am getting periodic freezes with the spinning beach ball, very slow start up times and occasional crashes (Gray screen, please power off etc).

    Does anyone have any ideas why this is happening?

    I do not get the same problems when I swap the old internal drive back in. I also swapped in some more RAM so I'm up to 8gb but this hasn't a negative effect on the running of the computer with the internal drive.

    Thanks for you time, it's vvv frustrating and confusing for me!


  2. #2
    Join Date
    Aug 2001
    Grangeville, ID USA


    Sorry to say I don't know the Samsung SSDs very well. I have been carrying Crucial and have a great relationship with their engineering guys. With Crucial you need to run the right firmware revision if you are going to boot them in a Mac, so we bring them in and update the firmware when it is going to be a Mac boot drive. I cannot tell you if you need do the same with a Samsung since I haven't spent any time on those.

    molṑn labe'
    "I am a mortal enemy to arbitrary government and unlimited power. I am naturally very jealous for the rights and liberties of my country, and the least encroachment of those invaluable privileges is apt to make my blood boil."
--Ben Franklin

  3. #3
    Join Date
    Feb 2001
    on the landline, Mr. Smith


    Troubleshooting SSDs can be challenging.

    I would consider doing a clean install of the OS, and see if you can get it to hiccup:

    If it does not hiccup - could be cloning is the issue. Have seen this before a few years back on OCZ SSDs. Never figured out why cloning tools that always worked (CCC, Superduper, etc.) did not work. As I recall, had to install OS, and then migrate to get around it. Long shot, but possible.

    If it does hiccup - even with a clean, virgin install, then I would suspect the SSD is bad. It happens. Out of about 100 SSDs installed over the last few years, have seen a couple that were just plain bad right out of the box. Got them replaced, and the problems (freezes, lags, failed boots) went away.
    "Imagine if every Thursday your shoes exploded if you tied them the usual way. This happens to us all the time with computers, and nobody thinks of complaining." -- Jef Raskin

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts