Results 1 to 2 of 2

Thread: G4 PowerBook won't start up properly

  1. #1
    Join Date
    Dec 2009

    Default G4 PowerBook won't start up properly

    I've had my 15" G4 PowerBook for around 5 or 6 years, and it's had a few problems, but now it is no longer starting up properly (does not get past blue/grey apple screen) and was wondering if anyone could enlighten me as to what the problem might be and what can be done about it.

    Firstly, it did need a complete hard drive replacement within it's first year, and it also had a failure of one of the RAM slots a few years ago (which I solved by moving the card to the other slot). And I had noticed over the last few months that it wasn't taking much for the fan(s) to come on, suggesting that it was overheating for some reason.

    That said, here is the problem:

    I was simply web-browsing whilst adding some files to itunes (this caused the fan to activate) when the computer completely froze and made a prolonged glitchy noise. After several minutes I forced a restart with the main power button, and it seemed to start ok (power-on chime) until it got the grey/blue screen with the apple logo, where it just hung, occasionally making clicking noises. After several restarts the kernal thing did appear and it finally got to a black screen with white script in the top left corner which read something like this:

    can't boot in single user mode
    disk 0s3 Input/Output error
    localhost:/I have no name!#

    However this is the only time out of many restarts and much waiting that it has managed to get past the grey/blue apple screen.

    My next step was to try and boot from the OSX 10.4.6 start-up disc using the Utility function. This worked until I selected the HD to repair and was told it could not perform the function because the HD could not be 'unmounted'. On a second attempt it seemed to have been 'unmounted' and started a repair but then stopped, saying something like:

    Rebuilding catalog B-tree
    Invalid node structure
    Error: the underlying task reported failure on exit.

    On further attempts to use the OSX disc, it no longer seems to be able to recognize the hard drive, with 'HD' being written in grey as opposed to black with the rest of the script. It's status is 'unmounted', whatever that means. Also, when selecting to install OSX, there is no 'HD' drive in the options to select for installation.

    So I'm guessing this might well be a write-off, but my questions are:

    1) As far as the machine is concerned, what exactly has happened here, what does it mean and what can I do about it?

    2) As far as data on the hard drive is concerned, will any data salvaging disks such as DiskWarrior etc be able to work if the OSX start-up disk is unable to find/recognize the HD?

    Thanks for reading, any help/advice/comments would be much appreciated.

    Thanks again in advance!

  2. #2
    Join Date
    Feb 2001
    on the landline, Mr. Smith


    Sounds like a hard drive failure. 2 to 4 years in a laptop is not uncommon.

    The easiest way to be sure everything else is OK would be to boot to and run from a firewire drive. If you have one. If it runs fine from the FW drive, then you have the option of replacing the internal drive if you want to stretch some more life out of it. If it is not stable from a known good external drive.....might be time to hunt up a new(er) Mac.

    As for data, unless the drive will mount, it is likely not easily retrievable. Some software tools such as Data Rescue II (and now DR 3) are quite good, but cannot overcome a hardware failure. The strange noises are usually a bad sign that there is a physical failure. If so, you would have to shell out $$$ to a data recovery service such as Drive Savers. Or hopefully.....get all the important stuff from your trusty backup!!
    "Imagine if every Thursday your shoes exploded if you tied them the usual way. This happens to us all the time with computers, and nobody thinks of complaining." -- Jef Raskin

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts