Results 1 to 3 of 3

Thread: upgrade sata card, now cursor won't drag and drop

  1. #1
    Join Date
    Apr 2006

    Default upgrade sata card, now cursor won't drag and drop

    I updated the sonnet xp4 pci-x card because I couldn't use newer bigger drives with my 5 port burly enclosure. After upgrade my cursor has lost the ability to drag files and folders. it will open with a click and it will resize a window, but it won't drag a selection. I tried both the usb mouse and my wacom pad, both do it. I ran disk utility, reset the pram. help.

    I am using osx 10.5.6 on a g5 dual 2.0 tower.


  2. #2
    Join Date
    Aug 2001
    Grangeville, ID USA



    Thanks for writing. First thing, there is never a limit to drive size on any SATA host card. Updates to firmware account for bugs and operating system issues that develop as Apple recreates Mac OSX in all its glory each time it releases an OS updater. When you do updates to SATA host cards those updates are intended to maintain compatibility and functionality for later OS revisions.

    If I was running a X4P on a G5 I would be using ROM Revision 2.1.3 or 2.1.4. There have been some reported issues with revision 2.1.7. The method to down revving the firmware is to toss out the SonnetSATA Receipt from the /Library/Receipts folder and then installing the 2.1.3 or 2.1.4 firmware. You may have to get that from Sonnet at if they don't have it on their download page.

    molṑn labe'
    "I am a mortal enemy to arbitrary government and unlimited power. I am naturally very jealous for the rights and liberties of my country, and the least encroachment of those invaluable privileges is apt to make my blood boil."
--Ben Franklin

  3. #3
    Join Date
    Mar 2009


    Did you repair disk permission on your main HD after installation?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts