Results 1 to 3 of 3

Thread: Striped RAID won't boot, but can access...???

  1. #1
    Join Date
    Oct 2008
    Posts
    2

    Default Striped RAID won't boot, but can access...???

    Hi,

    I purchased a couple of Gurus WD 500 drives and tossed them in my MacPro and set them up with the Apple utility as a striped RAID.

    Everything was fine until I decided to shut down the computer over night (I usually leave it on). Next morning, no boot. Just hangs with the apple and the little swirling-line circle.

    If I boot off the original drive I can access the RAID so I don't know what's going on. Also, when I run the Techtool Deluxe from AppleCare the drive physical attributes fails... but everything else checks out.

    Any ideas?

    Thanks in advance.

    Cameron

  2. #2
    Join Date
    Aug 2001
    Location
    Grangeville, ID USA
    Posts
    9,124

    Default

    Cameron,

    I haven't booted from a striped RAID in years, not even in testing, so I am not all that useful answering your questions here. My apologies. I have always thought that adding complexity to the boot drive is not a big benefit. Typically RAID0 arrays accelerate data access not typified by an OS and application drive. Too many little accesses going on there to get much benefit from a stripe. Stripes work really well with data files like photo libraries or video. The RAID gets watered down too much on an OS drive to be of much real benefit. Seems to me the only benefit is it boots faster - but at the cost of higher likelihood of a problem based on the added complexity. I tend to prefer to split data up onto multiple drive instead.

    Seeing as how you have your boot volume on a RAID though, you need to work on getting it fixed. You might try holding the Option key during startup. See if the RAID is identified there. You can then try and select it at a point where it is already mounted.

    Sounds like the problem is some sort of corruption though. The giveaway is that the system tries to boot to it and hangs instead of ignoring it or moving on to looking for another bootable volume.

    You might download the latest Combo Updater and then apply it to the RAID volume from the backup single drive. That often can fix OS issues.

    Rick
    molṑn labe'
    "I am a mortal enemy to arbitrary government and unlimited power. I am naturally very jealous for the rights and liberties of my country, and the least encroachment of those invaluable privileges is apt to make my blood boil."
--Ben Franklin

  3. #3
    Join Date
    Feb 2001
    Location
    on the landline, Mr. Smith
    Posts
    7,787

    Default

    And if that doesn't help, you can try an Archive and Install from your OS 10 media, which will give you a fresh OS without having to rebuild users or reinstall anything, plus leave the Previous System intact so you can dig through it for anything that might be missing or you want to confirm.
    "Imagine if every Thursday your shoes exploded if you tied them the usual way. This happens to us all the time with computers, and nobody thinks of complaining." -- Jef Raskin

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •