I ran in to a snag setting up a Linksys PSUS4 usb print sever.
My Brother in law has a 1.33 G4 iBook running Panther that he wants
to remotely connect to a Epson Stylus C86. Panther did not incl
drivers for the C86 so after installing those from the epson site I
had no problems printing through the USB port. set up a no brainer
the Mac just found every thing it needed. Connecting via the Print
server a different story. The PSUS4 is a 4port switch with a usb
output to the printer. The setup disk provided is for windoz only so
it was of no use. Pressing the reset button print the server
info and holding the reset for 30sec will set an ip address then
print info. So with Ip address I figured it would be easy to configure.
Here is the server info.
Hardware ID: 04D0558C28
Firmware Version: 6033
Protocol ID: 006E
MAC Address: 00F667ED1CA

AppleTalk Info:
Printer Type:

TCP/IP Info:
IP Address
Subnet Mask
Gateway Address
Email Server IP Address
Printing Account Name: N/A
Redirect Account Name :N/A

SMB Info:
Domain Name: domain

After connecting the the iBook via ethernet cable to one port on the
server and the USB to the printer
During printer setup as an IP printer and keying in the Ip address
the browser found no compatible drivers the generic postscript driver
did not work. trying to set the driver manually there was no C86
driver in the epson list nor could I find a PPD file for the C86 even
though I found the downloaded driver file for the C86 and some Unix
exe files it would let me select but they did not work.

browsing under Appletalk, I got the server to show but again no
compatible driver found using one of the color laserwriter driver got
the printer to respond but but it just printed pages of instruction
code and a list of unix commands like /sc/setcolor etc etc

so I tried my TiG4 running 10.4, I had C86 cups -gimpprint drivers in
my lists but non would work either a an IP or apple talk printer ??

I have tried the hole sequence using both a std and crossover cable
to no avail
the Epson AppleTalk or Epson TCP/IP selection give me nothing.

I just trying to get the print server to work connected directly to
the computer before going any further.
Any advice, what combo am I missing, Tried so many I can't even recall.
Thanks Bob