Results 1 to 3 of 3

Thread: HDD failing, Tiger "8GB" Custom Cloning Help Needed

  1. #1
    Join Date
    Mar 2001
    Location
    Keats, KS USA
    Posts
    435

    Confused HDD failing, Tiger "8GB" Custom Cloning Help Needed

    Hey all,
    I have a (Apple ROM maybe??? as there's the Apple top) WD 20GB drive that's on it's last leg that's serving as the system drive of my Frankenmac (Digital Audio 533MHz, with 512RAM, SIIG/ACard ATA Card- 6880M).

    I've used "ditto" (via Bombich's excellent Read ME file with CCC) and cloned everything to a folder on my Seagate 80GB drive.

    Incidentily, it serves as my current and future /Users folder/drive, which is weekly backed-up to another Seagate 80GB (via a x86 Fedora machine which then goes to old-a$$ Exabyte and/or DVD).

    After checking, verifying and archiving the data, I decided to use a 40gig drive in my Frankenmac.

    Remember, at the beginning I wonder whether the WD is Apple ROM'ed, well, trying to install on the 40Gig, I found that whether on the ACard or Macs' Internal bus, I can't install to this drive unless I create a >8GB partition.

    So, after reading this Partitioned OS X installation with seperate swap partition..... article, I thought that this is what I wanna do.

    Only difference is that I already have my "/Users" taken care of on the Seagate (which will be nice and tidy after figuring this all out and moving my backed-up OLD system off of it).
    However, I'm getting a bizarro feeling that it's not as Black and White as it seems (are things ever?? LOL).

    According to the fstab part (of the above linked-article), this is what constitutes my fstab.hd file:

    billbo:~ billbo$ more /etc/fstab.hd
    IGNORE THIS FILE.
    This file does nothing, contains no useful data, and might go away in
    future releases. Do not depend on this file or its contents.
    billbo:~ billbo$


    ... and that is why I need help. I don't mind tinkering at this point, as I don't even really care about a new install, as I have things the way I want them from 10.4.3 backup. However, I want to be able to test out on the new install, before going ahead and modding the needed mod's on my backed up files.

    So In terms of what I'd like my final Partition Scheme (for a 40GB drive) to be is this:

    1= 1GB UFS swap partition
    2= 7GB HFS+ Journaled System/Library/BSD(should I or should I not go with Case Sensitive??)
    3= Rest of Drive HFS+ Journaled w/OS 9 drivers for Applications and Classic

    ... and after knowing exactly what to change, I will change what needs changing in my backups, restart from the Tiger DVD and ditto everything back, with all your help of course!!!

    Or, someone might know the "8GB" workaround or fix, because as it is, a full Carbon Copy Cloner to the 40GB drive WOULD NOT work (for those wondering at the beginning of all this why I didn't use CCC )

    TIA,
    -Billbo
    Last edited by TZ; 03-31-2006 at 09:36 AM.
    Bill

    "I made a conscience decision in a semi-conscious state"

  2. #2
    Join Date
    Jan 2001
    Location
    Mobius Strip
    Posts
    13,045

    Lightbulb

    8GB 'rule' applies to Beige G3 and earlier. Not to any supported NewWorld Mac.

    I would avoid using a swap partition, and UFS, but if you want to tinker, feel free. More RAM (512MB is minimal for Tiger, 1GB+?), and faster boot drive (Maxtor 200GB ATA w/ 16MB cache, or SATA Raptor if you go SATA route).

    I use CCC, not ditto; or Apple Disk Utility Restore to move systems around.

    Also, there is some discussion that suggests 1GB for swap is too small. OS X can 'allocate' more than it needs or ever uses.

    Did you ever erase or repartition the 20GB? personally, I'd guess it is too old and slow to be worth using. That when you tried to CCC at first that you missed something.

    Things like "ignore ownership" and "make bootable" or not.

  3. #3
    Join Date
    Feb 2001
    Location
    on the landline, Mr. Smith
    Posts
    7,787

    Default

    I agree with TZ.

    I would retire the 20G Apple drive. Old and slow. No special firmware on any of those that I am aware of. Have used old Apple branded drives in many different boxes without issue. Just used one on a old Apple branded Maxtor 20G in a home built AMD box to install Solaris 10 on for testing. No issues with the drive.

    And for anybody playing along at home: Beige G3s *and* slot loader imacs are the last Macs that follow the 8 Gig rule. Just being nitpicky.
    "Imagine if every Thursday your shoes exploded if you tied them the usual way. This happens to us all the time with computers, and nobody thinks of complaining." -- Jef Raskin

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •