Results 1 to 2 of 2

Thread: Please help, somethings just not working for me

  1. #1
    Join Date
    Feb 2006
    Posts
    1

    Default Please help, somethings just not working for me

    I've got this original imac, its a green tray loading one, and the hard drive went bad on it. It was giving me that classic cachunk cachunk of a crashed hard drive and i was getting the question mark folder when i tried to boot from it. So i figured, hey, i can replace this.

    A little internet research led me to believe that i could use any 5400 rpm ata hard drive, so i bought one on the cheap that is 13 gb, which is still larger than the 4 gb that came in it.

    The drive is a quantum fireball ex, and i set it to master and put it in the imac, and when i try and boot from the system discs, it wont boot, it gets to the welcome screen an the progress meter moves about a centimeter and then freezes. It becomes completely un responsive to the power button as well so i always end up having to unplug it.

    Then i read some more and realized i didnt partition the thing at all, so i went and put it into my PC to try and partition it there. I made the first partition under 8 gb, i actually made it around 6, and then i made another partition for the rest of it. I left the partitions unformatted, and put the drive back in the imac, but it didnt change anything, still wont boot the software cd, stops at the exact same place.

    Now, the only thing i think i could be doing wrong is the partitioning, i mean, its probably painfully obvious that i'm pretty much a pc guy, but above all im hardware guy. Cracking the imac open and installing the drive was easy as pie, but i've never formatted or partitioned a drive for a mac before... if you have any advice i'd be so grateful, i know it seems silly to waste effort on such an old machine, but its sentimental to my sister who im trying to fix it for.

    okay, sorry for rambling, again, thanks in advance

  2. #2
    Join Date
    Feb 2001
    Location
    on the landline, Mr. Smith
    Posts
    7,784

    Default

    Hi and welcome to MacGurus.

    Let me ramble a bit too.....

    Any ATA drive should be fine. 7200 8MB cache is best performance as you would expect. Some folks worry about heat, but IMHO all newish drives run cooler than what came in the imac way back when. Cooler is always better though, with the limited ventilation.

    Jumping to Master is correct. No need to fiddle with anything else.

    You do need to partition the drive with the first partition being less than 8G. 7.9 works just fine.....for any flavor of OS 10. OS 9 and older does not need to be partitioned. To be bootable, OS X must be installed on this first limited partition. You can use the rest of the drive however you like with ans many or few partitions as you like.

    Before you install any flavor of OS 10 on an early imac, there a couple firmware updates that need to be done first, and have to be done while booted to OS 9 from the HD. I can dig up links for info if/when you get to that point.

    You need to format the drive with Mac tools. Depends on which OS you are installings as to what, where, and how. If you pull the drive out again erase the drive in your PC, and start over with the Mac tools

    The imac should boot to the CD regardless of the condition of the HD, even without an HD. If it will not boot to the CD, then either the CD is wrong for the imac, it is damaged, or the optical drive is not working right. You need to boot to the CD to format the HD to be able to reinstall an OS. Just in case you missed it somewhere, you should always be able to boot to the CD by inserting it, restarting while holding down the "C" key.
    "Imagine if every Thursday your shoes exploded if you tied them the usual way. This happens to us all the time with computers, and nobody thinks of complaining." -- Jef Raskin

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •