Results 1 to 5 of 5

Thread: G4 17" imac won't boot up.....

  1. #1
    Join Date
    Jul 2001
    Location
    England
    Posts
    178

    Default G4 17" imac won't boot up.....

    Odd one this. 17" flat panel iMac, press the start button, fan goes round a couple of times and then stops. Press button again, same thing happens. Nothing else doing, no chimes, no hard drive, just a quick whirr and then nothing.
    I have reset motherboard, removed PRAM battery to reset mobo as well and all that happens is that the red light on the u/s of the mobo flicks on and then goes off again.
    Clearly power going through the PSU but nowhere else.
    Any suggestions?

  2. #2
    Join Date
    Jan 2001
    Location
    Mobius Strip
    Posts
    13,045

    Default

    There is a need for an iMac Troubleshooting page, forum section. This sounds similar to other stories in the last year. Unfortunately my 'luck' with the search button is less than acceptable let alone stellar. MacIntouch iMac reader report? Google? (Is this site under Google's watchful eye even?)

    I'm a big believer in the power of a UPS! We got hit nearby - just one big loud nasty BOOM! as a tree got hit on the next block.

    Power Supply? The Open Firmware reset would be one option. Unplugging things is work (disk drive, Cd, RAM, video). There is a little red light on my MDD l/b and I even found a TIL on it once. Maybe I can find the URL or article number - it wasn't an easy one to find (stumbled on it on another forum).

  3. #3
    Join Date
    Jul 2001
    Location
    England
    Posts
    178

    Default

    No chance of doing an OF reset, it has to boot to do that.
    The red light is normally on when a mac boots, but this just flicks once.
    Hasn't been hit by lightning or trees either. Probably just needs a new power supply which means sending it to Apple - which is what I am trying to avoid!

  4. #4
    Join Date
    Feb 2001
    Location
    on the landline, Mr. Smith
    Posts
    7,787

    Default

    Wish I could help....most of the imac woes that I try to keep up on are from G3 CRTs.

    The G4 LCD imacs have nothing in common with their CRT namesakes, save for the name, and being an all-in-one. Heck, the emacs have more in common with the CRT imacs than the new LCD imacs do.

    You have done everything I would suggest or try... Have not cracked one of these open, but I know it is not for the meek, and as I recall reading somewhere there is some foil tape that has to be disconnected, and then reconnected. If not done right, you risk overheating it.

    Had some links to pics of a take-apart somewhere....

    Not sure what you would do once apart...maybe try the fabled voodoo reset (unplug everything and let it sit overnight)?

    There have been a couple threads with folks having similar issues with G4 towers...

    Shall we assume the imac is out of warranty? If it is less than 1 year old, head in to your local Mac service shop quick!
    "Imagine if every Thursday your shoes exploded if you tied them the usual way. This happens to us all the time with computers, and nobody thinks of complaining." -- Jef Raskin

  5. #5
    Join Date
    Jul 2001
    Location
    England
    Posts
    178

    Default

    It is indeed out of warranty, otherwise Apple would have had it back by now.
    I have already stripped it down - I had to do that to get the hard drive out to get the data off.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •