Any help would much be appreciated on this one:

iBook dual USB, 500mhz factory hard drive OS9.2.2 formatted.

1. Flashing Question Mark on start up.

2. OS9 CD booted ok but cannot find hard drive using a) Apple System Profiler, b) Disk First Aid, c) Drive Setup. Of course, drive icon does not show up on desktop.

3. Norton Utilities 6 failed to boot.

4. Apple Hardware Test found no problems. I cannot see the size of the hard drive in the report though, all I see is that mass storage passed.

5. When I boot the machine and listen carefully, I cannot hear the hard drive spin at all.

6. Already resetted PRAM and Energy Manager settings.

7. Tried running Disk Warrior 2.1 off a network drive using the iBook and it cannot locate the iBook internal hard drive either.

8. Even tried firewire target mode but the host machine doesn't see the target iBook. By pressing and holding the t during the startup, iBook goes bank turning itself off.

9. At this stage we're only interested in recovering the missing data. Should we send it off to data recovery specialists right away or could a drive power cable be loose?

Thanks again for any feedback in advance, it's much appreciated.