My PowerBook G3 (Lombard) seems to be dead as a doornail. It won't start up when it's plugged in, or when just running from the battery. No lights come on, there's no sound coming from the computer, nothing. I tried pulling out the battery & pushing the reset button on the back, and then putting the battery back in with the power cable connected, but it seems to be hopeless.

So what could be the likely diagnosis here? Serious problems seemed to arise after I tried to install a Firewire/USB 2.0 combo PCMCIA card. First of all, after I installed the software off a CD that it came with, I was no longer able to boot into OS 10.2.8. When I tried, all I got was a 'null' sign, a circle with a diagonal line across it. Then I tried booting into OS 9.2.2 with the card plugged in, all I got was a black screen. After ejecting the card, I tried restarting but it was still black, although the power LED was on. So I then unplugged the power cable & pulled out the battery. It shut down & that was the last time I've seen any kind life coming from the PowerBook.

Could the motherboard have been fried, or perhaps the Power Manager Unit has finally bit the dust? I tried resetting it several times, leaving it unplugged for long stretches of time with the battery out between tests. Or perhaps this is the universe's subtle way of telling me that I should bit the bullet & go with my fantasy of getting a new 15" PowerBook G4 by the time the next MacWorld comes along?