Hope someone can advise...posting from my iBook right now as I've screwed up my PMG4....

Anyway, had the bright idea to install Linux on my G4. So thinking that I could avoid any problems by installing Linux on a separate drive. So I bought a WD 120GB drive and partitioned it into 2, about half for Linux and half for OSX. I made this the Master drive and changed my old Maxtor 120 GB the Slave.

I installed YellowDogLinux 3 on the first partition of the new drive. Install went OK and then I booted into YDL3 OK. Worked great!

However, when I rebooted to get back into OSX, no go. I got the gray apple at startup but that turned into circle with slash through it.

Found out there's a partition map bug in YDL3 about this. However, there's a fix, but couldn't get it to work for me..

So rebooted and held down option key and I can see my OSX Partition, my OS9 partition,and the Linux partition. When I boot into OS9 it boots up OK but then the only thing I can do is move the cursor around, buttons on my trackball don't work.

So I removed new drive and changed old drive back to Master. Still same thing....

I've tried Apple Drive Utility on Jaguar disk but it only sees my drive not the partitions.

Tried Drive10 but same thing and therefore has no available options for repairs.

Tried DiskWarrior (old version) but wouldn't boot!

Tried TechToolPro v3.07. It boots into OS9 but with same trackball problems...

Tried starting in single-user mode so that I could try fsck -y command. But didn't get to prompt...went through most of startup stuff onscreen then I got a line saying 'still waiting for root device'. After a few minutes it repeated that line again. And again......

Anyone got any suggestions besides reformatting hard drive?