Results 1 to 6 of 6

Thread: USB Keyboard random doubling on Blue & WHITE

  1. #1
    Join Date
    Sep 2000
    Location
    Lagunitas CA USA
    Posts
    46

    Default

    Rev 1 Blue & White. I posted this on Apple's Board, too, but it is growing cobwebs:

    Don't tell me to trash the keyboard preferences, repair permissions, run a disk utility, reinstall the OS, or try another keyboard. Been there, done that. This is a hardware problem related to the Mac itself. I would really like to get this solved.

    No matter which OS I run (8.5 to 10.2.4), or which keyboard (4 USB keyboards, including Apple Pro) I install, I get semi-random doubling & tripling of keyboard characters, altho not all of them. The bottom 2 rows, (z-/ and a-,) double the most. I have never seen a number double. What could cause this???

    BTW-I attached an old ADB keyboard, and it NEVER doubles! I have posted this problem before, but never got any useful replies, or even any examples of another person having the same trouble. This makes typing an incredible waste of time, because nearly every other word needs correction. The only way I could put up with this for 4 years without going nuts is I don't type a lot. I use the computer mostly for Photoshop & Internet. I heard there were some strange USB bugs in the first USB Macs, so I installed a cheap CompUSA USB PCI card, just to test things. The problem wasn't fixed.

    That just about leaves the motherboard, wouldn't you say? Should I try to find a Rev 2 mobo & swap it out?

  2. #2
    Join Date
    Jan 2001
    Location
    Mobius Strip
    Posts
    13,045

    Default

    How about resetting open firmware and zap PRAM?

    Command Option O + F

    reset-nvram
    set-defaults
    reset-all

    replace battery but you've lived with this for 4 yrs? While it was new? I had an SE/30 with one key that would act up and never ever went away, which only ended when I bought another computer... it was one of the very first ones made, too.

  3. #3
    Join Date
    Sep 2000
    Location
    Lagunitas CA USA
    Posts
    46

    Default

    Yes, Gregory, my B & W was one of the very first ever made. I bought it at MacWorld SF 1999, where they were released!

    It is true that 4 years is old for a PRAM battery, but I have no other symptoms, and this has been going on for at least a couple of years. Good question - it didn't have this problem when new. I have never messed with open firmware. I'll see if I can figure out your instructions. Perhaps Apple has a KB article about this.

  4. #4
    Join Date
    Jan 2001
    Location
    Mobius Strip
    Posts
    13,045

    Default

    Gary,

    there have been a lot of notes on xlr8yourmac, macfixit etc on using the Open Firmware reset to solve Jaguar problems on systems, it was mentioned on www.osxfaq.com a long while back, too. Open Firmware is a mystery but essential part of startup and operation, controlling hardware settings. It seems something is whacky, but not fried totally.

    A PRAM battery might last five years but I usually replace them before that. ADB was sensitive to voltage and could get damaged, and this winter I built up some static electric and fried a USB port on a startup switich from Dr. Bott.

    Do printers etc work fine off both USB ports? I think there is just one controller though.

    - G.

  5. #5
    Join Date
    Sep 2000
    Location
    Lagunitas CA USA
    Posts
    46

    Default

    I have reset PRAM many times over the years. It seems that PRAM & Open Firmware are related but different? I just finished resetting open firmware, & am testing the keyboard as I type this post. To answer your other question, the printer works fine off both ports. I will take your advice, and replace the battery before it dies. I am beginning to suspect that the problem is fixed! Usually, there would have been half a dozen doubled characters by now, and there is not a one. Thank you very much! This could be the answer to a worse mystery which has been bugging me & OWC Larry - a mysterious PRAM corruption caused by booting back & forth between OS X & OS 9 with my PowerLogix G4 ZIF upgrade. I have seen a couple of doubled characters now, but way, way less, and I'm such a lousy typist that the results are inconclusive. I will post a followup when I am sure.

  6. #6
    Join Date
    Jan 2001
    Location
    Mobius Strip
    Posts
    13,045

    Default

    Good luck. Let's hope it fixed both problems. You might want to investigate Sonnet's Tune-Up 1.2.6 (free) if you need to manage L2 cache. And make sure you use Startup Disk cp 9.2.5.

    - G.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •