Results 1 to 4 of 4

Thread: Powerbook battery doesn't charge

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1
    Join Date
    Jan 2001
    Location
    Westerly, RI, USA
    Posts
    132

    Default

    Here I am with another one I can't solve. (Gregory, this time I *do* have it plugged in! )
    I have a Pismo 'book, pretty stock (400 G3/384 ram/6 gig drive)running 10.2.4. The original battery is working fine. I picked up a battery that was said to be working. When I slip it in to the book OSX sees it. When I press the button on the battery to check the charge level I get one flashing green light. I looked all over Apple's site and found the battery reset/recondition stuff but it all seems to be for an older book. When I run the battery reset app I am told that the book doesn't need it.

    Thankfully, I did not pay much for this battery, but I would like to get it to work if I can.

    The battery is M7318.

    Thanks for any help

    [This message has been edited by greg_w (edited 12 March 2003).]

  2. #2
    tachyon Guest

    Default

    Battery reset only works if you put the battery into a SCSI model bronze keyboard. Then you can run the software and reset the battery!

    If it still doesn't work, have it refurbished somewhere. Whatever you do, don't throw it away, it's got toxic chemicals in it!

  3. #3
    Join Date
    Jan 2001
    Location
    Westerly, RI, USA
    Posts
    132

    Default

    tachyon,

    Thanks for the tip, that sounds reasonable. As a matter of fact my brother-in-law has a Lombard P'book. I am going to give that one a try.

  4. #4
    Join Date
    Aug 2000
    Location
    miami, fl, usa
    Posts
    545

    Default

    Yea, battery reset is not for the pismo model. 'fraid your battery is just worn out. I have two that have lived their lives pretty much all the way now and the only thing left is to recycle them. seems that the more you run them down and charge them up the sooner they wear out, and no memory effect like the older powerbooks, which is what the battery reset fixed - i think.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •