Results 1 to 4 of 4

Thread: non working ATTO

  1. #1
    Join Date
    Oct 2001
    Location
    Peoria, IL 61614
    Posts
    2

    Default

    Okay, this is a strange problem that noone has been albe to solve... so I post it here.

    I have a G4 Server with 1 harddisk, an ATTO driven Ultra160 Segate Cheeta. Basically the BTO AppleStore option. I have installed no new software/hardware for months.

    I had the computer for a few months prior to the first strange happenings. In around mid-july the computer started "losing" the boot disk (the SCSI disk). It would boot up to the ?-mark folder icon. To solve it I would just switch the card to another slot and force the hardware to rescan the bus to find the card and validate it. Worked every time. Didn't happen much though.

    Last week I experienced a crash and it booted to the ?-mark folder so I did the same fix. Upon booting up again it couldn't load the extensions (it would crash) because the Quicktime extension couldn't be read fully. Booting w/ extensions off it wouldn't boot all the way b/c a system file couldn't be read properly. Upon booting from the CD it LOOKED as if everything was in its right place on my 4 partitions but on every one of them random files couldn't be moved or copied because of a disk error. SO... I tried reinstalling the OS and about 15% of the way through it would crash b/c it "couldn't write to the system folder, move to another folder and try again". Tried again... no luck.

    I put the card in a G3 Yosemite. Again, everything LOOKED fine but when I tried copying as much over as I could (from that SCSI to the ATA in the G3)... some files just wouldn't copy.

    I figured there was something wrong low level... so I formatted the SCSI drive(much to my dismay). Attempted to reinstall the OS on a single partition. Same error as before. "error writing to system folder, move to another folder and try again."

    Here's what I've done/what I know

    -Low level format/zero format on Segate SCSI drive
    -Disk Tools says the disk is okay.
    -Tried NEW IBM Ultrastar SCSI Ultra160 drive. Again, formatting worked fine but upon trying to install the OS, no good.
    -Tried switching PCI slots on the ATTO card
    -Tried different computer on the ATTO card
    -Same ribbon cable but tried different connectors.

    Haven't been albe to try the external connector b/c I have no adapter for it.

    Okay, I'm going to recieve an Adaptec 29160 in the mail but I'd much rather get this ATTO card working b/c its duel channel, I wouldn't have to buy a new card, I've been happy w/ the performance and because I've heard bad things about Adaptec and OS X.

    Ohhh and if I do have to use this adaptec card... its bootable, right?

    Thanks so much for your time,
    David Schmudde
    davidschmudde@hotmail.com

  2. #2
    Join Date
    Aug 2000
    Location
    Concord, CA
    Posts
    7,056

    Default

    Hard to know for sure, but it sounds as if either the ATTO card or the LVD cable (FOXCON?) or the LVD terminator on the end is bad or intermittent. Since the Ultrastar exhibits the same problems as the Cheetah, I think the Cheetah is OK.

    I would remove the cable and terminator and inspect the pins closely to see if any are bent over onto another pin. Remove the terminator from the cable and inspect those pins also. I use a flashlight and magnifying glass. Also inspect the cable itself, particularly the outside wires on each side. BTW, most LVD internal cables do not like to be sharply folded over. Dressed cables look nice but with LVD, ugly is better.

    If all looks OK, then it appears your problem is with the ATTO card. I have no experience with Adaptec cards, so no advice there. Is the ATTO still under warranty? k

  3. #3
    Join Date
    Oct 2001
    Location
    Peoria, IL 61614
    Posts
    2

    Default

    Well, it just got more interesting. I got the new card/cable. Now the computer is in the original state to where it occasionally loses the hard disk. Note, I have tried different PCI slots and the ATTO card in a different computer (G3 B& W not the G4). Somehow the ATTO got ruined. Its a UL2D so methinks its a bit too old to be under warrenty, plus I got it used.. so it wouldn't help my case.

    Anyways, I have found one pattern. Since I got the new cable/card I've been reinstalling so software... which requires the occasional reboot. Well, its lost the hard drive twice in one hour on reboot, both on hard crashes. Tried zapping the PRAM (two gongs, not just one)... nothing. And then I aggressivly just yanked the power chord out of the back of the G4 and both times its boot strapped fine after a little sit. I guess these crashes are just clobbering an important piece of RAM (but not the PRAM!) and thus losing the hard disk? I don't know... things have been so strange lately that these might just be a coencidence.

    Anyways, thanks for your help. ANY more advice would be much appriciated. I'll make sure my LVD cable isn't at any sharp, neat folds. OHH and BTW --- I tried the new cable with the ATTO card and got the same errors, so I guess the ATTO is trash... I just don't know how this could have happened. One day, the mac crashed, reboot to the lost hard disk and the next day its just not reading right. I'm hoping my "fixes" aren't damagine my PCI cards.

    Thanks again,
    dave

  4. #4
    Join Date
    Jan 2001
    Location
    Mobius Strip
    Posts
    13,045

    Default

    I don't know about the UL2D but there is a firmware issue with 9.2.1 and ATTO UL3's on the B/W G3.

    Have you ever tried using Disk Warrior?
    Reset Open Firmware defaults?
    Tried using Startup Disk cp 9.2.3?

    The "?" can be from corrupted PRAM, boot block, not being able to find the self-loader bootstrap, even a bad system file.

    I'd also just do an update of the driver.

    Moving PCI cards around can cause confusion and trouble not to mention potential for something going wrong. It may act as if or seem like it 'fixes' a problem but only because it causes the system to refresh the Device Registry and scan for a valid system (actually the ".tbxi" code).

    Disk Tools? Disk First Aid? I actually prefer to use Drive Setup's Test routine in favor of a low level which will reassign bad blocks if found.

    Being a little hard perhaps on the hard-ware? Ouch! Yanking and pulling and moving cards. Sorry but I just think that type of voodoo is bad voodoo. I'd get a good troubleshooting guide book. Not trying to be hard and it sounds like you know your way around, enough to know that things like even zapping PRAM the usual recommendation is three (3) or even five at times to clear it, not just once or twice. And to drop into Open Firmware is similar only uses the "command + optioni + o + f" there you can reset-defaults OR type in the boot-device path to the boot-loader file.

    Also, could it be the IDE drive? That's been my experience and why i no longer even put an IDE in my B/W rev 2 (I have three on the shelf waiting for a good Oxford 911 FireWire case that will work in X.1). Mac OS 9.2.1? It has problems with IDE drives, usually when partitioned.

    setenv boot-device ultra0:,\\:tbxi

    Will look for the default bus, drive, whether scsi or ide, starting at 0 and look for a boot loader.

    The normal, long form for the master IDE drive would look like this:

    # ATA Bus 1, ID 0, partition 7
    boot-device /pci@80000000/pci-bridge@d/pci-ata@1/ata-4@0/@0:7,\\:tbxi
    boot-file
    boot-args
    boot-command mac-boot

    - Gregory

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •