PDA

View Full Version : Trying to boot MacPro 8-core (SL) into 64-bit mode



doctormelodious
12-13-2013, 11:12 PM
[EDIT: Not sure if this is what made the difference, but when I tried it again using the 6 and 4 keys above the QWERTY keys (rather than the ones on the numeric keypad) it worked!]

Greetings,

See my sig below for machine details. I am attempting to boot into 64-bit mode by holding down the 6 and 4 keys during boot. However, here's what I'm seeing after I do so.

In System Profiler:


System Software Overview:

System Version: Mac OS X 10.6.8 (10K549)
Kernel Version: Darwin 10.8.0
Boot Volume: Mac Pro
Boot Mode: Normal
Computer Name: Mac Pro
User Name: xxxxx
Secure Virtual Memory: Not Enabled
64-bit Kernel and Extensions: NoIn Terminal:


Mac-Pro:~ xxxxx$ ioreg -l -p IODeviceTree | grep firmware-abi
| | "firmware-abi" = <"EFI64">

Mac-Pro:~ xxxxx$ uname -a
Darwin Mac-Pro.local 10.8.0 Darwin Kernel Version 10.8.0: Tue Jun 7 16:33:36 PDT 2011; root:xnu-1504.15.3~1/RELEASE_I386 i386
From what I've researched, I understand that the "EFI64" value for "firmware-abi" means that I should be able to boot into 64-bit mode, but the other two pieces of info above (in bold) do not reflect this.

Any ideas??

Thanks!
DM

Damien
12-14-2013, 07:25 AM
Try This (https://www.macupdate.com/app/mac/32252/32--or-64-bit-kernel-startup-mode-selector) it will tell you exactly what your machine is capable of and let you choose which (32 or 64) you want to be the default startup mode

doctormelodious
12-14-2013, 09:50 AM
Thanks for the link, Damien. I knew that my Mac qualified, and was puzzled as to why it wasn't cooperating -- until it dawned on me to try the main numeric 4 and 6 keys instead of the number pad keys, as per the edit at the top of my OP.

Of course, this happened right after I had posted, and there doesn't seem to be a way to delete a post on here. But hey, maybe my "discovery" will help someone else, eh? :)

Regards,
DM