PDA

View Full Version : iPhoto "strange prompts"



rwm
07-30-2011, 03:28 PM
On this G4 I've been working on with 10.5.8 and iPhoto 09'...

Every time you open the application iPhoto you get a prompt. It's always the same prompt saying that there are two photos that have been found in the iPhoto library that were not imported. With an option of yes or no as to import them. You must eventually say yes and when you do it creates a file that contains two locked UNIX files that the “get info” says are terminal applications. I have unlocked them, throw them away but each time it returns. After a while you have several files each containing two of these UNIX files.

I cannot find them. I just want to get rid of them. If need be I can totally toss iPhoto and reinstall it. I have worked on this two or three times. Once a few months back but did not have much time to put into it. Then just recently and I can't find a solution. I don't believe the files are of anything needed.

I can unlock and throw them away but every time you open iPhoto it says there are two files not imported!

This is had me baffled. Look through the images below and if you have any comments or suggestions please post them. It is kind of a PIA and definitely not delay should work.

Thanks a lot
Randy

Damien
07-30-2011, 06:05 PM
I remember that issue as being nothing important but yes a PITA. Don't remember a fix though

It this G4 and iPhoto as updated as they can be? PRAM, NVRAM, permissions repaired etc? I assume you have tried these things already but maybe you forgot one or something.

rwm
07-30-2011, 06:51 PM
I've done it all - seems so. Even found the damn files. It still pulls 2 in each time. Except... in one search I see a folder identified as: path:PREVIEW_IPHOTO_??? no user/xxxx/whatever/a file --> I can't find that folder but it appeared to have unix files once. I see where the kids must have tried installing .exe, intel, etc. and other non working items.

It's maxed, tweaked and really works good. Before I tried a PRAM or NVRAM I wanted to make sure it don't mess with the Giga processor upgrade. I sort of remember something about that... anyone remember?

rwm
07-30-2011, 07:04 PM
Reinstalling iLife won't help - right? Could it hurt anything?

ricks
07-30-2011, 11:18 PM
Problem with iLife is that it converts the iPhoto database to an iLife version and you cannot take it back to a non iLife version. Just something to be aware of.

Rick

rwm
07-31-2011, 10:16 AM
Rick, I remember that now thanks. iPhoto got onto the computer via iLife 09' and I assuming that if I reinstall iLife ... it's not going to say "hey toss the Unix crap" ... :rolleyes:

Last night in bed I had two good thought I thunk...

When I unlock and double click on the "Unix files" a terminal window opens I wonder if I can do anything from there? Get Info say to use terminal to open them. I have changed those to several apps... same thing. I could post a pic

I might have it narrowed down to about 8 photos. Need to try that...

Thoughts on the PRAM, NVRAM with the Giga. I am not pulling a processor. :mad: Everything is working fine. It's just a PITA and might stay that way.

rwm
07-31-2011, 11:00 AM
We've got so much on the site here but does this old post help anyone remember... Bottom line is I am not pulling the Giga out. Can I zap PRAM and/or NVRAM without pulling the processor? Then install it. There is no OS 9 needed. This is a DA.

I can have it booted to my iMac if that helps. Sorry for the "easy" question really. I've been congested up -lungs- and not 100 percent. Having a heck of time thinking, focusing

My thoughts - untested... If it's booted to my iMac I could zap PRAM/NVRAM but the iMac won't read the Giga installer to reinstall needed patch.


Originally Posted by eric
The single OS X Giga application I used when I updated my Cube actually did / does two things:

1. Upgrade / modify the firmware (so these particular G4 CPU can be seen)

2. Modify the PRAM for startup in 9.x.

These as Rick mentioned are two separate things. When installing the Giga upgrade for the very time, for OS X (only), one only needs to do (1). But to actually boot 9.x you would need to do (1) and (2) -- again when you first installed the Giga. Once you perform (1), there's no need to do that again -- for 9.x or X.

Now as indicated by Rich, (2) is a patch in PRAM, so when you zap the PRAM the modificaiton goes way. So you need to run the Giga OS X application have have redo the PRAM patch / mod if you want to startup in 9.x. It's called "Native Mac OS 9 Booting Support". See p.2 of Firmware Upgrade Installation Guide here. You need to activate that.

You only need to do the part for the PRAM again, which is innocuous since that can always be eliminated by zapping the PRAM.

Also bear in mind that in 9.x there you need to remove the Multiprocessing Folder -- at least it was the 7447 Cube upgrade. That needs to be pulled if you happened to reinstall 9.x. Again see p.2 of the Guide.

rwm
07-31-2011, 02:51 PM
If you type into Google...

"2 photos have been found in the iPhoto Library that were not imported."

It's a 5 minute fix. :D

Thanks for the support and tips. I just am not running on all cylinders this past few weeks.

rwm
07-31-2011, 06:11 PM
1 - Go to your Pictures Folder

2 - find the iPhoto Library Folder there - actually iPhoto library icon

3 - Open that Folder - right click or Control -

4 - look for a Folder called 'Import' or 'Importing'. or look in "Show Package Contents" for it

5 - Drag it to the Desktop.

6 - Make no other changes.

7 - Start iPhoto.

8 - That should fix it - trash the folder

Damien
07-31-2011, 07:18 PM
The Google..... There is nothing it can't do!

rwm
07-31-2011, 07:32 PM
Yes, gosh I've been okay but just a few issues that have had my concentration level or focus very low at times. It was to easy. :o

My friend is here to move the drive from FW into G4 again.

Stay tuned. - :D