PDA

View Full Version : Problem on an old OS-9 partition



Froggy
07-21-2010, 03:57 AM
Here's the situation: I have an old (2002) iMac (round base, 17" screen), with the drive divided into three partitions. The iMac is bootable into either OS 9 or X. Until yesterday the OS-9 partition was working like a top, although occasionally showing problems when examined with Norton.

Recently (like a week ago) I got a brand-new iMac 21.5" Intel Core 2 Duo, but decided to hold on to the old iMac for nostalgia's sake, just to run OS-9.

So, yesterday I ran Norton on the OS-9 partition, it showed major problems, attempted to repair the volume but said volume could not be repaired. After that it didn't remount the volume on the desktop, and I didn't wait... rebooted with a "hard restart" with the power button, it took a long, long time to boot and longer to mount. When finally everything appeared, the system worked at a glacial pace - when clicking on an icon, it takes several seconds for it to be highlighted, same for moving something on the desktop, pulling down a menu... The system is alive, but does not respond well - everything has slowed down. I'm thinking corrupted system file or something of that nature. I have backups of OS-9 on several backup drives. It can also be that the old hard drive is about to bite the dust, but when I boot into the OS X partition, it functions perfectly. So I'm thinking that the problem is limited to the OS-9 partition and not the drive itself.

I would love to resurrect )S-9 on my old iMac... not sure of the best course of action. OS X's Disk Utility is powerless. An option is to "restore" the partition from a backup copy, which is what I'm attempting to do right now, by copying a recent backup on the new iMac to a portable drive and then moving it to the old computer. Keeping fingers crossed...