PDA

View Full Version : Oops - Disk Utility RAID Mirror Problem



spclark
06-02-2010, 08:54 AM
Last week my mirrored (via Apple's Disk Utility) 10.5.8 boot volume suffered a degraded RAID pair & failed to boot my 1st gen Mac Pro.

So I booted from my maintenance volume, tried to repair the degraded mirror pair with a re-partition....

Guess that's not the way to do this as after a restart the remaining RAID volume, now a loner, fails to even appear in System Profiler or any of the other disk-related utility programs I have: SoftRAID 4, Disk Warrior 4.1, TechTool Pro 4, Data Rescue II.

I've tried moving the invisible drive to another internal SATA port, as well as pulling it physically & using an OWC universal adapter to connect by either USB or to an add-in eSATA 4-port external drive host card.

So far no luck. That drive doesn't want to appear at all.

Is there any way to get it to show up again on my Mac Pro?

rwm
06-02-2010, 05:29 PM
I am no RAID expert but the HD sizes, makes, models might help others. You have some good tools. Hang on... don't panic yet :eek:

ricks
06-02-2010, 07:58 PM
You may be able to get a utility like Disk Warrior to repair that volume. It somewhat depends on what the corruption is that damaged it. Afraid I have no estimate of the likelihood of success. Worth a try if the data on the boot volume is unique and hard to replace.... my guess is it is basically everything of yours from Applications to emails, including licenses and passwords.

I would recommend you start with Disk Warrior, see if it can repair it. Does Disk Utility see the drive? That is important since if it doesn't then DIsk Warrior won't either.

On another note, after you get past this, skip the RAID1 Mirror for your backup. Mirrors are never to be considered a backup, they are a convenience. A mirror only provides the *maybe* protection from a simple hard drive failure. But the big problem with a mirror is it is always connected. This means any damage to one drive is instantly duplicated to the mirror. And especially for boot volumes, having your data on a complex RAID structure makes any problem a serious one since it effects the whole computer.

Far better, once you get back up and running, to setup and use backup software and a separate drive, instead of a mirror. This protects from everything and the backup is not part of the problem should there be an event that damages your main drive.

Until then, we'll help all we can to assist in getting the data back off that drive. There are other utilities available that approach data recovery in different ways. So let us know how things are going and provide some details. We'll see if we can help.

Rick

unclemac
06-02-2010, 09:44 PM
Sounds like the RAID is already degraded......or broken.

At this point -- as long as the other drive is happy, the machine is booting, and your data is all good -- I would agree, see what DU sees. I would expect it to show a degraded RAID with a missing RAID slice.

If you like Rick's plan, you can format the drive, assuming it shows up in DU. Once formatted, you can set up back ups.

If you really want the mirror back because you need 24/7 uptime, you have an easy path as well. SoftRAID will let you convert an Apple RAID, or build a new one from a single non-RAID drive. I have not used SoftRAID 4 yet, but previous versions are rock solid, especially with boot mirrors. Would be the best option.

Yell if you have questions.

spclark
06-03-2010, 04:52 PM
... no luck.

Drive pair are both Seagate ST375033AS, 750 Gb devices. The "invisible so far" but hopefully-with-data-still-intact drive is the original of two identical drives purchased about this time in 2009, while the degraded & now repartitioned member is a Certified Repaired HDD from Seagate (same model, same size) provided under warranty replacement when the original drive failed after about four months running 10.5.8.

I agree with the "mirror as back-up only for disk failure" premise & that's why I was using the replaced drive as such; my failure apparently was in trusting Apple's RAID mirror implementation enough to think I could rebuild to the failed RAID member after a repartition.

Should have made a Disk Image first, or cloned the once-functional, intact RAID boot volume to another drive entirely. Repair under DU didn't work, I thought repartitioning the drive would help, it didn't, so then I though maybe a re-start... after which the once mounted RAID member, but now a lone RAID slice, no longer mounts or is even visible on the system.

Folks at SoftRAID have offered suggestions: run the invisible drive on a Mac booted in Target Disk mode & accessed from another machine & see if it shows up in Terminal under a "diskutil list" command (which it doesn't, either connected by SATA-to-USB or -Firewire bridge device) or perhaps swap the drive controller with a known good unit off the once paired drive to see if it's the controller that's somehow disabled.

That last step is where I'm at at present. Nothing else has succeeded in allowing the once-viable RAID "slice" to be addressable at the most basic system level by any disk utility software or the command line....

spclark
06-03-2010, 05:36 PM
When this first surfaced, I used Disk Warrior 4.1 to rebuild the directory of the remaining RAID pair

spclark
06-03-2010, 05:46 PM
... then did a re-start to see if it improved things any. No luck - RAID still "degraded" according to Disk Utility. So I thought if I could repair the RAID by re-establishing the degraded drive pair as a RAID member all would be well, but that wouldn't work under Disk Utility.

So I guess I should have done a clone of the still-mounted volume that had been a RAID to another drive entirely, or at least made a Disk Image of it on another drive.

Instead I did a repartition of the degraded RAID member drive, thinking that might allow it to become a new RAID pair, but when that failed to work I thought perhaps a reboot would help.

Which it didn't: once I got my Mac Pro booted to my maintenance drive, the Untitled drive was mounted fine but the drive with the RAID slice - which had been mounted & addressable before the restart - was nowhere to be found, by any means.

Tried swapping the drive controller with the one off the Untitled drive - they were delivered as a matched pair of Seagate ST375033AS drives, but when one failed after four or five months it was replaced under warranty by Seagate. Despite being the same model & firmware on the label, swapping the controllers gives me a "click-of-death" when the Untitled volume's controller is mounted to the now invisible drive mechanism. Put things back the way they were & the Untitled drive mounts fine.

Any suggestions as to how to approach this now will be welcome.

ricks
06-03-2010, 06:41 PM
What firmware is listed on that drive's label? Might be the problem now if one of the Seagate firmware versions that were having a problem a while back.

unclemac
06-03-2010, 11:06 PM
Wild ride. You are lucky to have access to your one good drive after the board swap. That is risky. Some drives can be damaged by that process, or so I read.

Would agree with Rick, this could be the Seagate firmware issue. Sounds right. The data is there, but it can be a bitch to get back. Seagate has a firmware update, but it does not always work in my experience. I have seen where there are some folks "fixing" the drive for a fee. Data is still there......usually worth the cost for folks with no back up.

Thing is, if you have the other working half of the mirror, I would move forward and not back. If the drive is at fault, then the mirror did its job: one drive is not accessible, but the second is, so you still have access. Victory!

As for moving forward, if it were me:

1. Clone your system over to a new replacement drive.

2. Back up key, irreplaceable data to second volume.

3. Once you are squared away again, consider reusing either of the drives for backups or other non-critical jobs, or better yet, forget the data on it and send the bad one back to Seagate for replacement.

4. If I really wanted a mirror again, I would get two matching drives again - one could be used in step 1 above - and start fresh with a softRAID mirror, then clone your system over to the new RAID set.