PDA

View Full Version : eSATA external drive invalid extents



Olsen
01-21-2010, 08:40 AM
I am running Mac OSX on a MBP. I have an external drive connected using eSATA connections and an express port on the mbp. This is my second external drive that I have been having the following issue with.

Drive 1: Everytime I would restart the computer, the osx would state that my drive needs to be repaired. When doing a verify in disk utility, the drive would fail with an error of Invalid extent. It would tell me to do a repair. Repairs always fail. I would have to erase and re-partition. Since I use the external drive for backups...this would not work since it was so unreliable. Sent the drive back.

Purchased different drive
Current Drive: I have been using the drive for over a week with no issues going to and from sleep. Yesterday, I applied a security update for OSX and it had to restart. (drive was connected) Applied updates and restarted with no issues. When time machine attempted its next backup, it failed. OSX says that there was an issue with the drive and needs repair. Disk Utility finds that there is an invalid extent on the drive and cannot repair. Again, I am having to reformat.

After searching a bit on google, I was unable to find any solutions to this problem and was hoping someone here could help. I am very recent convert to mac. Am I doing something wrong when restarting? Do I need to eject the external drive prior to reboot? Is time machine writing or causing the invalid extent? How do I fix the problem without having to reformat and lose all backups?

External drive formatted in MAC OSX Extended (no journaling)

Thanks in advance! Any help is appreciated.

ricks
01-21-2010, 08:58 AM
If you are having problems with two different drives on the same bus, it may be the bus or driver that is the problem.

What OS revision are you running and what driver is running the Express34 card? That'll tell me a lot. To find driver revision open Apple System Profiler - this is found by selecting 'About This Mac' under the Apple in the menu bar and then hitting the 'More Info' button. In Apple SYstem Profiler you can look under Extensions, see if there is one called SiliconImage.3132 and tell me which version is installed. That, and the OS will tell us a lot.

Rick

Olsen
01-21-2010, 09:08 AM
Mac OS X Version 10.6.2.

I am using a Best Connectivity SATA II expresscard. I did not install any specific drivers for it because their driver disk only appeared to have windows drivers. How would I find what the driver is? (sorry for my ignorance about macs)

System Profiler shows Unknown AHCI Standard Controller on the controller that is connecting my external drive.

Vendor: Unknown
Product: AHCI Standard Controller
Speed: 3 Gigabit
Description: AHCI Version 1.00 Supported

Does that help? I would agree that it may be the controller....or driver...or even time machine. Didnt know if I needed to first eject disk before reboot or something like that.

unclemac
01-21-2010, 09:32 AM
No, you should have to do anything to reboot. Or sleep for that matter...though sleep can sometimes be an issue with specific hardware on all platforms.

The driver is for the eSATA card, not the disk.

Question: You get a Time Machine error, yes? But does the drive mount on the desktop? Can you copy files to it manually? If so, this can be a Time Machine issue, not a drive issue.

ricks
01-21-2010, 09:57 AM
From what I can find on "Best Connectivity SATA II expresscard" it appears that is just a standard 3132 chipset host card. If so, then it would absolutely require the correct SIlicon Image driver.

If you would, open Apple System Profiler, go to Extensions. Scroll down to SiliconImage3132 and tell me what revision driver is installed.

Rick

Olsen
01-21-2010, 10:05 AM
Understood that it is a controller driver potential issue. yes, the only time I seem to get the error is from time machine stating that it could not complete the backup. Time machine recommends doing a drive check. (Drive still mounted). Disk utility finds extent error...cannot repair...drive is in read only state, cannot write. I tried to copy data off, but got the error that the operation was not allowed.

Olsen
01-21-2010, 06:54 PM
In System Profiler, under software > extensions

I do not find any entry for SiliconImage3132....Is this the problem?

Is there anywhere else I need to check?

Thanks

ricks
01-21-2010, 07:13 PM
It wouldn't work at all without a driver...

So I guess I have no idea what kind of chipset is on that card. Don't know anyway to assist you in determining what driver you should have. Not a card name I ever heard of before. Rebranded undoubtedly, but rebranded what?

Rick

Olsen
01-21-2010, 07:18 PM
I purchased from OWC. It was supposed to be compliant with Mac. I have put in a request to get the driver for this with them. I have the driver disk, but it appears that the drivers are intended for windows and linux (rh and fedora)

http://eshop.macsales.com/item/Other%20World%20Computing/EXP34SATA2P1/

Does that help any? Did I get a garbage card?

Olsen
01-21-2010, 07:30 PM
I found that it is a JMicron JMB360. I am currently looking on their site for the latest driver.

Does that help?

Here is the link..... http://eshop.macsales.com/item/Other%20World%20Computing/EXP34SATA2P1/ (http://eshop.macsales.com/item/Other%20World%20Computing/EXP34SATA2P1/)

I purchased from OWC because it was supposed to be macbook compatible....did I buy garbage?

Olsen
01-21-2010, 08:07 PM
I found system logs for the event.... Does this help any?
__________________________________________________ ______________

SYS LOG
1/20/10 10:49:22 PM com.apple.backupd[21569] Starting standard backup
1/20/10 10:49:22 PM com.apple.backupd[21569] Backing up to: /Volumes/Time Machine Backup/Backups.backupdb
1/20/10 10:49:36 PM kernel hfs_swap_HFSPlusBTInternalNode: unrecognized catalog record type (0x0000; record #28)
1/20/10 10:49:36 PM kernel hfs: node=25926 fileID=4 volume=Time Machine Backup device=/dev/disk1s2


Disk Utility Log
**********
2010-01-20 22:51:46 -0800: Disk Utility started.

2010-01-20 22:51:56 -0800: Verifying volume “Time Machine Backup”
2010-01-20 22:51:56 -0800: Starting verification tool:
2010-01-20 22:51:57 -0800: Checking Journaled HFS Plus volume.
2010-01-20 22:51:57 -0800: Checking extents overflow file.
2010-01-20 22:51:57 -0800: Checking catalog file.
2010-01-20 22:51:58 -0800: Invalid extent entry
2010-01-20 22:51:58 -0800: Invalid catalog record type
2010-01-20 22:51:58 -0800: The volume Time Machine Backup could not be verified completely.
2010-01-20 22:51:59 -0800: Error: This disk needs to be repaired. Click Repair Disk.2010-01-20 22:51:59 -0800:
2010-01-20 22:51:59 -0800: Disk Utility stopped verifying “Time Machine Backup”: This disk needs to be repaired. Click Repair Disk.
2010-01-20 22:51:59 -0800:

2010-01-20 22:52:27 -0800: Verify and Repair volume “Time Machine Backup”
2010-01-20 22:52:27 -0800: Starting repair tool:
2010-01-20 22:52:27 -0800: Checking Journaled HFS Plus volume.
2010-01-20 22:52:27 -0800: Checking extents overflow file.
2010-01-20 22:52:27 -0800: Checking catalog file.
2010-01-20 22:52:28 -0800: Invalid extent entry
2010-01-20 22:52:28 -0800: Invalid catalog record type
2010-01-20 22:52:28 -0800: The volume Time Machine Backup could not be verified completely.
2010-01-20 22:52:28 -0800: Volume repair complete.
2010-01-20 22:52:28 -0800: Updating boot support partitions for the volume as required.
2010-01-20 22:52:28 -0800: Error: Disk Utility can’t repair this disk. Back up as many of your files as possible, reformat the disk, and restore your backed-up files.2010-01-20 22:52:28 -0800:
2010-01-20 22:52:28 -0800: Disk Utility stopped repairing “Time Machine Backup”: Disk Utility can’t repair this disk. Back up as many of your files as possible, reformat the disk, and restore your backed-up files.

ricks
01-21-2010, 08:14 PM
I can't say much about the JMicron cards, never carried one, so I don't know what the problems might be with them, or even if they use a separate driver or not. I would guess you need to update it to run in Snow Leopard, but that is a guess.

The logs just say that Time Machine had a problem. I never much liked Time Machine, it never has worked well in any of our tests. That said, many of the moderators here have had great success with it. You might try a different backup application and see if the problems go away. Maybe SuperDuper (http://www.shirt-pocket.com/SuperDuper/) would work well as a test?

unclemac
01-21-2010, 08:56 PM
Does this drive have any interface other than eSATA?

If it has USB or FireWire, plug the drive (with something other than eSATA) and see if DU can repair it, or better yet, format it.

I would use the drive on another bus to remove the eSATA variable for a while, to see if the drive is OK.

Here's the complicating factor:

Likely a eSATA driver issue, but it could be a HD issue. One or both of those could cause the TimeMachine issue......but it could be its own separate issue. I would recommend tackling this one issue at a time.

1. Prove (or disprove) the drive is OK on another bus.
2. Get the eSATA card working or possible. Or replace.
3. Get Time Machine working on a known good drive and bus.

TM is usually very good, and very simple in my experience. Except when it is not. Once in a while, it just does not work and it appears to be mostly related to it being finicky about the drive/bus. I would guess it is seamless for 99% of users. I have set it up many times on all sorts of machines myself. Have had two systems that it simply would not work on.

So, in a nutshell, get everything else fixed and reliable before throwing TM in the mix. Then you can try to sort out TM. This short blurb (http://macitdepartment.com/page0/page0.html) links to a nice write up of TM troubleshooting. Looks very thorough.

If it won't work, even after you have the drive and bus sorted out, you will need to either: a) get a different backup drive/bus, b) get different backup software.

The good news is, there are lots of really good backup tools out there. Although none are as simple or fun to use as TM.

Olsen
01-21-2010, 11:03 PM
Unclemac:
I already erased the partition that was "damaged" and created a new one. Eliminating and singling out a cause will be an interesting adventure. I had thought about using the usb port to eliminate the possibilities of eSata controller being the issue. I wanted to try some simple and quick things first.

ricks:
I installed SuperDuper and ran a full backup to a second partition I created on the external drive. (I now have a time machine backup partition and a secondary SuperDuper backup partition). It was interesting to find that when I created the second partition on the drive, it made the Time machine partition a Journaled partition.

SuperDuper finished successfully....It converted the other partition to Journaled....Not sure if there are any ill effects to doing this.

Time Machine had done several backups to the other partition since last night, so I decided to try a reboot with the drive mounted.

Rebooted just fine, drives are there, no issues. I decided to test Time Machine after reboot. Time Machine ran just fine. I was hoping that the Time Machine or the reboot would have caused the error again, but it didn't. This leaves me a bit puzzled. I can't identify what caused the corruption or what to do to prevent the corruption. Even if I used the USB bus, and a backup completed successfully, it does not tell me much unless I can get another predicted failure on the eSata controller. It could be a driver problem, but not sure how to update or if an update will cause more harm than good. My plan is to run SuperDuper and Time Machine in parallel, since they give different backup options (one is convenient file restore, other is nice image in case of drive failure). If I have a failure on the time machine partition, I can just recreate that partition and my images stay intact.

Is SuperDuper the standard when it comes to system backups on Mac? (other than TM)

Thanks for the input!

unclemac
01-22-2010, 12:04 AM
Glad you are making progress.

.....No standard, really. Lot's of great options out there. SuperDuper is on the top of many lists, so unless you find fault, you should be happy with it.

"Journaled" is the default format. Nothing to worry about there.....actually safter, at least for boot drives, than unjournaled. Wonder if TM requires Journal format?

ricks
01-22-2010, 08:41 AM
In Snow Leopard, Apple actually makes Journaled required for a boot drive. I would bet that it is now TM required as well.

R

renikel
01-18-2011, 01:06 AM
turns out I have the same issue with the same card when I use time machine. call me lazy and welldont want to change backup software because of some stupid bug that should be fixed. but if you are saying this card in combo with time machine is the culprit. then so be it.

ron

ricks
01-18-2011, 08:51 AM
My experience over the last couple years has been that Time Machine will always get corrupted eventually. The data base gets too complex and big and one day TM doesn't work. You may not even know TM isn't working.

TM is still a good choice, but every few months you should erase the TM drive and start it over fresh. Get rid of all that old stuff and TM seems a good way to go.

Rick