View Full Version : Snow Leopard not happy with Burly box?

11-27-2009, 12:56 PM
I've had several 6 bay Burly boxes for the last few years. I recently had to purchase a new Mac Pro to replace an ailing G5. Over the past few days, I've been migrating data and setting up the new system. One of the Burly boxes appears to be crashing the OS.

It's a 6 bay box that is split into two 3 drive RAID 0 arrays. One is a back-up of the other. I purchased a new SATA card from here about a week before the system arrived. It's a Sonnet Temp E4P PCI-e. I have downloaded and installed the updated Mac Pro driver from Sonnet that was linked from this page (http://www.macgurus.com/productpages/sata/Tempo-E4P.php). It appears under the PCI Cards section of the System Profiler.

The drives start just fine but after about 10 minutes, one drive in each of the arrays appears to get 'stuck'. The drive light remains amber. On the back-up array, I have tried DiskWarrior and reformatted. It still gets hung up on something. I downloaded a little app called What's Keeping Me (http://www.hamsoftengineering.com/products/wkm/wkm.html) and discovered that the drives appear to get hung on a Spotlight process, actually, a number of Spotlight processes. I tried adding the drives to the Spotlight privacy list but they didn't appear to get recognized.

Any ideas? The only way I can get out of the hung state is by forcibly shutting down the system and the drive box and then rebooting.

Thanks in advance.


11-27-2009, 01:25 PM
Thanks for writing. As you probably already know, the Burly itself has nothing to do with whether Snow Leopard works or not. The Burly is a house for the drives and cabling.

The 2 places that has any bearing is the host card and the drives themselves. If you have a drive acting particularly different - as in displaying an amber light when all the others are showing a green, then that is one obvious place to look.

The other being whether you have a problem with the host card. All host cards require a specific driver to run in 10.6. Make sure your card is up to date - which you appear to have done. Double check that it is running the 2.20 version driver.

After that comes down to testing individual drives. If you see hangups and strange behaviors from one drive then testing it outside of the RAID is the only thing I can think of to figure out whether the drive itself has an issue. My preferred test is to erase a drive and write a full pass of zeroes to it. If the drive passes that test then usually mechanically the drive is good.

It may also be worthwhile to check the firmware on Seagate drives purchased in 2008. Had a run of issues that were resolved with a firmware update to the drives themselves. If your Seagate drives have firmware revisions SD15 through SD19 it is worth checking that at Seagate (http://seagate.custkb.com/seagate/crm/selfservice/search.jsp?DocId=207931&NewLang=en) to see if they need attention.

It will get figured out. Somewhere in there is something not quite right.


11-27-2009, 06:20 PM

Thanks for the response. You've always been helpful in the past when I've had issues.

I'll check the firmware on the drives and zero them out later this evening.

I'll let you know how it goes.

Hope you had a good Thanksgiving.

11-28-2009, 08:51 PM
The drives eventually zero'd out. It was quite a process though as something kept hanging during the process which caused a system wide lockup. After they were zero'd, I created a new striped array in Disk Utility and all seemed well. I then tried to copy data from the array with my originals onto the newly formatted backup array. As soon as the copy started, everything locked up.

Finder kept telling me one of the files was in use. I'd have to forcefully shut everything done and restart. Again, a file was in use. Lots of Spotlight processes appearing in What's Keeping Me even though both arrays were placed in the Privacy list.

The Sonnet driver is v2.2.0. A check on the Seagate site with my drive serial numbers showed that no updates were available. In System Profiler, the drives show SD04.

I'm at a total loss. Any ideas?

11-28-2009, 10:04 PM
What PCI slot is the Sonnet card in? Don't want to use slot 2.

You should try reformatting into a pair of 3 drive RAIDs and test/compare each.

SD04 is from before any Seagate issues, SD15 through SD19 are the ones to watch.


11-28-2009, 10:34 PM
Right now, I don't want to get my hopes up too much but it looks like I'm stable. Rather than dragging one entire drive onto the other to copy, I started again with individual folders. While doing that, I came across a bunch of files that had been locked by the system but were zero KB in size. These were very old files (3 yrs+) and I'm assuming that the lock info was there from the previous G5 which didn't make sense to the new MacPro. After removing those files, the copy started and has been running blissfully along for the past hour. I've had no lock up related issues at all so far.

At this point, I'm debating whether or not I have to break and reformat the other array after the copy is complete. Things seem to be fairly stable. What are your thoughts?

11-28-2009, 11:34 PM
First thought is: Never use drag and drop to copy!

Use a backup or copy application. I hear more problems from people trying to drag drop. It gets more stuff messed up, and often misses resource fork data.

Second is, make sure the thing is stable. It is your precious data. I would rather waste time testing than 'hope'.


11-29-2009, 10:14 AM
Carbon Copy Cloner is great (and free) for copying some or all of a drive, whether it needs to be bootable or not. SuperDuper and other share ware tools are great too......lots of choices.

11-29-2009, 11:59 AM
I still have some weirdness in a few files on my original array (back up appears to be running fine). If I go to Terminal and execute the following command:

sudo cp -Rp Photos "../../Originals Backup/Lightroom/"

Most of the files copy over except for about a dozen. Terminal comes back with the following error.

cp: Photos/path/to/file/filename.CR2: Resource busy

Nothing is running except Terminal, Safari and a couple of Finder windows. How do I discover what is hanging onto these files?

11-30-2009, 11:09 PM
Quick update...

This appears as though it may have been a driver issue. I dug around a bit more and came across this article (http://www.xlr8yourmac.com/archives/oct09/101409.html) (4th headline from the top) which posted some woes being had by the 2.2.0 driver from Sonnet. The recommendation? Revert back to 2.1.9. I've done that and things seem to be way more happy. Keeping my fingers crossed.

Thanks for the help.

12-01-2009, 01:19 AM
Good to know. Thanks for the update!