PDA

View Full Version : iBook G3 clamshell / need OSX installed



briardguy
11-26-2009, 10:01 AM
Hello Everyone,

I have a half dozen iBook G3 clamshells ( 300mhz / 64mb ram) that I am going to fix up and donate to my wife's 5th grade class ( they have no computer lab !). They are all currently running OS 9.2. I want to upgrade them all to OSX 10.3.5 so I can install MS Office. Currently, the iBooks can not read the OSX disk.........

I remember reading somewhere that in order to do so, 2 things must happen:

1) there is a minimum amount of ram that is required
2) there is a firmware update that is required

I can not find any info on the above 2 items in the Apple data base. Can someone please walk me thru this and/or point me in the right direction?

thank you.

briardguy
11-26-2009, 11:23 AM
ok- i found and installed the required FW upadte 4.1.7 and all went well. I also installed an additional 128mb of ram ( 192 mb total) which is suppose to be the minimum requirements for OSX 10.3 on this machine.

However, when i put the OSX 10.3 cd in the drive, it says "This disk is unreadable by this computer. Do you want ti initialize the disc?" I know the cd rom drive is good and it's a good copy of OSX 10.3. I even tried booting from disc ( held down the C key when booting) but it still boots to 9.2 and I get the same message !!!

I'm unfamiliar with OS 9.2 and can't even find disk utility !!!

Suggestions ????

rwm
11-26-2009, 11:57 AM
Without researching Apple further my first thoughts on it...

Will OSX even load on a iBook G3 clamshell at 300mhz and 64mb ram. Without a little hack. Also OSX needs more RAM and CPU MHz. Not to mention your graphics.

We once said OSX needs 512MB RAM and 800MHz+ better 1GHz processor. OSX would be very sluggish on a iBook.

A new hard drive, maybe some RAM and OS 9.x would speed things up noticeably and is my suggestion.

Disk Utility - look in a Utilities folder (I think) or just search it. I have not used 9.x in a few years. I like to erase/initialize a drive before a new OS install.

briardguy
11-26-2009, 12:24 PM
i have seen numerous posting on here where people have OSX on iBook clamshells. My first iBook clamshell was a 333mhz with 192 mb ram running OSX 10.2. so, I know it can work......... however, getting the job done myself is an issue.........

All 6 iBooks I'm working on are 300 mhz with 192 mb ram running OS 9.2. All say the same thing: "This disk is unreadable by this computer" .........

i was referencing the following links:

http://forums.macosxhints.com/archiv...p/t-62158.html

http://docs.info.apple.com/article.html?artnum=75128

HELP !!!!!!

Nicolas
11-26-2009, 04:43 PM
Hello,

not every iBook has a DVD-ROM drive some do have CD-ROMs only.
Only the 466MHz iBook had a DVD-ROM drive. http://en.wikipedia.org/wiki/IBook

If you have 10.3 as DVD only, you need.. (FireWire is not an option here cuz the 300MHz iBooks doesn't have FW).
1. The CD install media of the OS.
2. Or, you have to upgrade each iBook with a DVD drive (which is not worth the cost)

That's why your 10.3 OS DVD will not boot on these iBooks.

Regards

Nicolas

ricks
11-26-2009, 04:58 PM
Nic nailed it. All 300 MHz iBooks had CD drives.

R

briardguy
11-27-2009, 12:18 PM
yes, your are correct. these units have cd roms. however, i have OSX 10.3.5 on CD ( 3 disks total) !!!! when i rebuild Dual USB iBook 500mhz units I use this disks to load OSX. So, I know the disks are good. ......I've rebuilt over 50 iBooks in the last year or two and have a pretty good understanding of how these baby's run.....but these little clamshells have me puzzled.

so, my original question still stands. ......i can't see any reason this won't load

ricks
11-27-2009, 12:30 PM
I sure don't see anything in the minimum requirements listed for 10.3 that would preclude installation. In fact every iBook is listed with the exception of those that shipped from the factory with 10.4.

Maybe try a different installer CD set? I ran into a problem with the Tiger installers that shipped with a MacPro no longer allowing install on the machine it shipped with - after a firmware update. Apple sent me a full set of replacement DVDs for literally every machine they make. Kind of weird, but they did. Makes you wonder how many version of their installers are floating around out there.

briardguy
11-27-2009, 12:55 PM
Well, I've spent the better part of 2 days researching this and have come up with nothing. I'm beginning to think it would be best to just sell these units with OS 9.2 and find something else for my wife's 5th grade classroom......bummer.

it's just so irritating when you know something can be done but can't figure out why....... there's a dozen of these clamshells ( 300mhz & 333mhz) running OSX on Ebay !!! how did they do it ?

ricks
11-27-2009, 01:11 PM
Occams Razor - if you have all these G3s, none of them will take that particular install, and you know G3s will take the OS, then only thing must be that copy of the installer. Try a different one.

Frustrating I can see. But until something is changed in testing, there is no way to know why you have the problem.

R

briardguy
11-27-2009, 01:49 PM
well, this is the only copy of 10.3 that i have. I just loaded it on a G3 dual usb with no problems. i have 10.4 on dvd but it does me no good. I have however noticed, the majority of G3 clamshells on Ebay that are running OSX is 10.2 !

I wonder if that's the highest version these things will accept ????

rwm
11-27-2009, 02:18 PM
At Thanksgiving my niece had an iBook G3 800MHz (my sister gave it to her) and my brother could not get it to connect to his wireless but wired ethernet works fine.

I forgot setting this up for my sis a few years ago. So I brought it home to erase it and reinstall 10.3 again. Installed fine. Have not tested a internet connection but soon.

I really did not intend to discourage you earlier. My first thought when reading 300MHz and 64MB RAM sounded stretched. I personally think Apple specs are workable but very minimal. I am not up to date on the laptops at all.

10.3 runs fairly good on this G3 800. I never checked Apple but is there something different between a 300MHz and a 800MHz G3 iBook.

briardguy
11-27-2009, 04:43 PM
ya, 10.3 works really well with 500mhz and up......as does 10.4 actually !

I just want to get these things running 10.(whatever) so I can install MS Office on them. That's all the 5th graders will be using them for anyway. It's a damn shame the school can't afford computers for the kids. Especially here in Phoenix ( the 5th largest city in USA). If need be, I'll sell all these clamshells and buy little 12" g3 dual usb iBooks and donate them...... but for now, I'm on a mission from GOD to figure this out ! Hopefully, someone on this forum has done this successfully....... I'm beginning to think that OSX 10.2 is as high as they can go......but I still haven't found any documentation to support it.....


help anyone?

rwm
11-27-2009, 09:01 PM
Are you using the Black Retail Install CD?

rwm
11-27-2009, 09:18 PM
My apoligies I installed Panther not Tiger. and used combo updater and software update for everything to 10.3.9 now. Not 10.4 My bad.

rwm
11-27-2009, 09:56 PM
Look in this Apple search. (http://support.apple.com/kb/index?page=search&product=&q=panther10.3%20install%20ibook%20300)

Nicolas
11-28-2009, 01:59 AM
Hello,

if you tried everything and it is still a no go...

1. Create a partition on the iBooks HD which is less than 4GB and try again

2. Some Macs do need a working System9 first. So start here lay in the OSX cd goto the Applemenu>Controlpanesl>StartupVolume>select the OSX media as startup volume and reboot

Setting the startup volume is nessesary on some Macs due to the fact the bootrutines have to be switched to start a non classic OS (same with Linux). The G3 Beige needs this also.

Regards

Nicolas

briardguy
11-28-2009, 11:08 AM
ok, i'm going to give that a shot.........however.......

i am OS 9.2 stupid and can't find the disk utility for partitioning the hard drive !!!!

Nicolas
11-28-2009, 11:32 AM
It is there hit [APPLE]+[F] and search for "disk" or "drive" duno long time ago could be named drivesetup or disksetup. But, you can't repartition the drive as long as your booting from;) you'll need a System 9 CD as well.

Regards

Nicolas

briardguy
11-29-2009, 11:29 AM
Well, I have managed to get 2 of these clamshells loaded with 10.3.5 ! For the record, here are the things I did to reach a successful install:

* Updated the Firmware to 4.1.7
* Updated OS 9.2 to 9.2.2
* bumped the ram up to 192 mb from 64 mb ( key issue).
* Cleaned the optical drive !
* Made a fresh copy of the install disc.

I'm still having some difficulty with the other 4 clamshells but I believe it is either a bad cd-rom drive, I need a new copy of OSX or both ! My original OSX cd's were trashed years ago and I'm working off a copy of a copy. I also don't remember if they were full retail versions or upgrades !!!

Someone emailed me and informed that only full retail copies will work with these clamshells......he also advised that 10.4 will work just fine as well but unfortunately mine are on dvd!

so, I'm buying an external usb cd-rom and new oSX cd's !

thanks for everyone's input.....you're the BEST !

rwm
11-29-2009, 12:27 PM
Sorry I confused some issues in my earlier posts the Thanksgiving days rush. ;)

Looks like you have a good handle on it now.

bif
11-30-2009, 07:39 AM
Is it possible that some of the clamshell ibooks could not be upgraded to OSX? The reason I guess is that a kind of reverse logic is involved. I have a 300 MHz clamshell that runs OS 8.6. Only some of the oldest 300 MHz iBooks could boot 8.6. Newer versions had to have a version of 9 in order to run. Perhaps those earliest machines do not have the ROM to boot OSX and no firmware update can fix it.
Just wondering.
Good luck, anyway.