PDA

View Full Version : iBook G4 1.33 don't run



yeungfeng
09-11-2009, 10:41 PM
Greetings,

I have this iBook G4 1.33Ghz that seems to have a big problem. Startup is currently having the spinning, not a ball, what do we call that startup thing that spins. Anyway it's spinning and has been for some time.

Often I press power and hear the startup chime and then nothing. The screen stays dark, nada.

Sometimes I startup and get the above screen with the forever spinning thing.

A couple of times I get all the way to logging in and then the message that I need to restart.

I have tried to boot from the install CD with out any luck so far. Most often the CD will spin for just the briefest moment and then nothing.

I have tried to boot from an external FW drive with all the same luck as starting from the internal HD.

I just got the startup CD out and now the screen is all blue and nothing. The power cord is yellow. But then of course when I press the power button to start it up it goes green.

OKay I'm clueless as to what's going on, maybe a dead battery? Any ideas?

Thanks

M.Brane
09-11-2009, 11:08 PM
Startup is currently having the spinning, not a ball, what do we call that startup thing that spins.

Most people call it the spinning gear.

G4 iBooks are known to have logic board issues due to their poor build quality like their G3 bretheren. There are some fixes out there if you do some searching.

unclemac
09-12-2009, 11:32 AM
Gear or Cog.

Agreed. If you can't boot to known good external OSes, then likely a logic board issue.