PDA

View Full Version : Lucky but still a problem



Blue Magic
05-26-2009, 02:22 AM
I made a thread here a month or so ago. I had a problem with my iBook G4 not getting any power. I ordered a new power cord. It arrived yesterday so I was excited to plug everything up. I hit the power up button. Nothing happens, so I was bummed out. I went out for a few hours and came back to see if there would possibly be any changes. None. Well I got frustrated and started trying everything I could. I grabbed the power cord where it meets the computer and began hitting power moving the piece around and it began powering up! So I move the computer and it turns off. It turns out that there is a connection problem with the power cord. If I push the piece in a certain direction, the computer will start up and work fine. The moment I let go, it loses power immediately This is going to be difficult to address because I am stationed in Kuwait, and I have never taken a computer apart before, but I need to fix it. Any suggestions on how to fix this?

ricks
05-26-2009, 09:01 AM
I would start out looking over some of the online guides, like ifixit's (http://www.ifixit.com/Guide/Browse/iBook). The iBook has interesting considerations when opening it up. Check out the guide and ask away should you have questions.

Rick

M.Brane
05-26-2009, 09:09 PM
I replaced the power board on a iBook G3 once. It's a very tedious, and time consuming job. You pretty much have to disassemble the entire lower case. Lots of tiny screws of different sizes, and delicate connections/parts.