PDA

View Full Version : Printer 'hangs'



billybobski
04-16-2009, 06:34 AM
Hello.

What happens is this. I output through Quark, or Firefox, or other progs, the printer kicks in and prints the (say) 2 pages of the job, fine, but then the Print Queue shows the 2nd page still going, even though it's out and finished, and in that condition subsequent jobs just queue up behind.

The only way round this is to click on the 'hanging' job in the print queue and delete it. Then it all runs fine again.

So, not life-threatening, but a bit annoying.

Running: iMac, 10.4.11, Quark 7, Firefox latest, outputting to a Canon Pixma MP800 with PrintFab installed.

I haven't (as yet) tried running without PrintFab, which might make a difference. First course was to ask you, in case there's a button someplace that needs pressing...

Thanks

Allen.

Nicolas
04-16-2009, 07:37 AM
Hello,

clean up the tempfiles+system cache+font cache+extension cache+cron jobs using e.g. OnyX http://www.titanium.free.fr/pgs/english.html

If this won't help post back again.

Regards

Nicolas

billybobski
04-17-2009, 06:00 AM
Hello Nicholas,

And thanks for that. The OnyX program is very useful, and although it hasn't cured this fault, I shall be using it for general clean-ups in future.

So, back to the print problem.

I tried it without PrintFab, and it works fine (i.e. changing to plain printer in the System Prefs, and changing to plain printer in the final output to print).

Then, it runs through without problem, and finishes.

So, do you know if there is a likely culprit in PrintFab, or should I try a reinstall?

Thanks.

Allen.

Nicolas
04-19-2009, 11:24 AM
Hello Allen,

sorry for my late reply... B2T...

I think there is a problem with the Printerqueue of your Printfab-printer in the Printing-system (CUPS) of OSX.

Sometimes after a "hard-crash" this problem arise.
There is no way to prevent this.

Another culprit could be Quark itself, changing the output file method (e.g. from PS2 to PDF or PS3).

Check your installed printers, at the printer config there is an address shown at queues e.g. 127.0.0.1:xxxx (xxx stands for the port).

You can open this adress in your www browser just to check if the queue is set correctly (by normal you can not change anything).

A reinstall "could" help or not depends if printfab is setting up a new printing queue instead of using the old one.


Regards

Nicolas

billybobski
04-21-2009, 04:46 AM
Hello Nicolas.

Thanks for the reply.

Tried the uninstall/reinstall of PrintFab, as that still SEEMED to be the source of the problem, but it didn't solve it.

As the only printer I have is the MP800, the only other variable is USB or USBTB, so I switched over from usbtb, the output of choice, to the straight usb, and so far so good, i.e. the problem has gone away.

I'll keep an eye on Quark, but for the moment all seems peaceful.

Talking of Quark, are you an expert in the program? I wonder if there is an EASY way of getting rid of the hundreds of PPD options that come with Quark, that is to say easier than going through the tedious PPD manager and deleting 5 at a time. Or doesn't it matter that 'generic color' comes up as the PPD option on printing?

Thanks again for pointing me in the CUPS direction.


Allen.

Nicolas
04-22-2009, 03:12 PM
Hello Allen,

sorry for beeing not a big help here...

If I had a Mac I could do a test but at the moment I am lost with PC only.

:jollyrog:

I will try to get my hands on an older G4 set it up, and see if I could help you any further.

Best Regards

Nicolas

billybobski
04-26-2009, 07:27 AM
Not at all, Nicolas. You pointed me in the right direction, and that has helped a lot.

The set-up I use seems very sensitive. (Intel iMac, 10.4.11, PrintFab, Canon MP800 PIXMA, Quark 7, etc). The Quark is particularly fussy - if you don't specify the printer in each of the Print panels (rather than leaving it as Any Printer, for example), then the whole lot stops, and I have to clear the print queue manually and often reset the printer by turning it on and off. Most of the time I am VERY careful!


Allen.