PDA

View Full Version : MacBook Pro will not load OS



samantha
10-31-2008, 09:04 PM
I bought a 15" macbook pro 2Ghz core duo today with a blinking question mark folder when you start. I thought I just had to reload or repair the os but haven't been able to do it. This is what I have done:
I tried loading tiger os and also leopard os. Unfortunately i do not have the original macbook pro os install disks that came with it. I do have retail versions of tiger and leopard. Neither is working for me. The MBP does not see the tiger dvd at all and it sees the leopard dvd but when I tell it load the OS DVD it starts and then stops on the grey screen with the apple and hangs there....
I have tried both of these disks in an external firewire and it is the same symptoms as when in the MBP's internal optical drive.
I have tried to just put in the leopard cd when the blinking question mark/folder is there and it will stop blinking and then the optical drive winds up and then down a couple of times and then it spits the disk out. As I said it doesn't seem to see my tiger disk at all.
It will start in target disk mode and when i do a disk check from another computer it sees the MBP as a good hard drive but there is nothing on it.
I have tried resetting the SMU, PRAM and am stuck now as to what else to try. Sorry this is so windy....I would appreciate any help you can give me.

M.Brane
10-31-2008, 09:43 PM
That is a puzzler for sure.

What happens if you try to install to the MBP in TDM?

unclemac
10-31-2008, 10:12 PM
Don't think your 10.4 retail media will work, as Apple never put out a retail version of 10.4 for Intel Macs, only the OEM disks that came with the machines, so don't worry about that.

As for 10.5........what Brane said. Try to install10.5 in TDM, with the 10.5 media in the Mac you connect the MBP to. Keep in mind that the host Mac needs to have a DVD reader for 10.5, and that you should initialize the drive in the MBP and format it using GUID, not Apple Partition Table.

Apple Partition Table = PPC Mac
GUID = Intel Mac

M.Brane
10-31-2008, 11:07 PM
Apple Partition Table = PPC Mac
GUID = Intel Mac


Looks to me like that could be the problem right there. Could someone have formatted the drive with the wrong file system? That would explain the blinking ? even though the drive checks out OK.

unclemac
11-01-2008, 12:38 AM
Maybe not. Intel Macs can boot from APT formatted volumes, but it is not the preferred format. One problem it can cause is that firmware updates appear to validate against GUID on Intel Macs and will fail (http://support.apple.com/kb/HT2434) (not install) should they find APT instead. Learned that the hard way. :)

Sounds like there might be a problem with the optical drive, or perhaps the 10.5 media?

samantha
11-01-2008, 01:49 AM
Thanks guys I repartitioned and made sure it was on the guid selection. I installed it via firewire and it installed normally and even said it was successful at the end. However when I start the MBP it is still the same only it never shows the folder question mark any more, which makes sense. Now it chimes and begins to start up and then stays stuck on the grey screen with the apple, but no pinwheel like it is working. The same as earlier. If i choose it as a startup disk from my other mac it begins with the leopard welcome screen, so it seems it is a good install.
I tried again to start in safe mode but it didn't make any difference. I opened up and reseated the ram, it only has one 1Gig stick in it. Would it be unhappy if it has an empty ram slot? It also seems to get quite hot along the top of the keyboard area if i leave it running for awhile. Perhaps this is normal I do not know.
What it seems like to me is that it begins to load the os then just stays at the apple screen but shows no beachball or pinwheel.
:(

samantha
11-01-2008, 05:19 PM
Today I tried to put in some different ram but this did not change anything. Then I tried to fsck. It does not even finish it's tests and just seems to freeze and it never gets to the command prompt. I took a pic with a camera and this is as far as it gets: (hope it is readable)

http://members.cox.net/probitysound/DSC00911.jpg

The cursor is not blinking. It is stuck too. I am guessing this is not the disk's fault?

unclemac
11-01-2008, 10:06 PM
Hmm.... Not good. Things to consider:

Software - Just to confirm, this is using a retail 10.5 (black) DVD, correct? Seems there might still be a chance that the OS is not right. Consider downloading the stand along 10.5.4 or 10.5.5 Combo updater and running it via TDM like the install. Can't hurt. What kind of Mac are you using as a TDM host?

RAM - All the current Macs prefer (are optimized to run with) matched pairs of RAM, but should run with a single stick. My 1.83 MBP has a 1GB and a 512MB with no issues. Could be somebody installed the wrong or bad RAM? Hate to see you buy RAM if the box is a lost cause, but bad RAM can cause serious trouble. RAM tips (http://www.everymac.com/systems/apple/macbook_pro/faq/macbook-pro-ram-installation-instructions.html) for this model. Reseat the RAM, and try moving it to the other slot.

Hard Drive - It is possible the HD is bad. Just because the quick initilize works does not prove the drive is good. You should consider booting it to TDM again, and from the Host Mac, or from the 10.5 DVD running on the host Mac, you can initilize the HD again, but this time select Security Options, and choose to write zeros to the drive at least once. This will write data to every single sector of the HD, which is a pretty good test. Will likely take about 2 hours, and if the dirve is bad, it will never complete, just hang at some point. Should that happen, the drive is toast, so you can just force quit, and round up a new HD.

History - So you bought it with a flashing ?, right? What's the story? Did the seller give any clues about history? Seems somebody may have changed RAM in it once....pretty sure these earlier MBP can with Pairs from Apple (but I could be wrong). Could it be this box has a serious hardware issue?

samantha
11-06-2008, 04:25 PM
Thanks for all your time and suggestions. I think there is not much more that I can do.
I bought a black retail disk, not the gray mac specific disks. I was using a 1.83 macbook as my host. I believe they both use the same kind of memory so I tried swapping the memory over and this made no difference. I think it freezes after so many seconds no matter what, whether I had it with no os, in single user mode, or loaded with leopard.
I will try zeroing the disk but I think now that this has a serious problem such as a logicboard and the guy advertised it as hard drive problems. I'm guessing that after 8 or so seconds something inside heats up and quits. I bought second hand off craigslist and so was taking chances I guess, and not much recourse.
Thanks again.....Sam

unclemac
11-06-2008, 10:47 PM
Rats! :mad:

Since you have the same model MBP, try this before you throw in the towel:

1. Connect the two with a FW cable.
2. Boot the good MBP to TDM (hold down the T key)
2. Boot the bad MBP to EFI by holding down the option key (http://docs.info.apple.com/article.html?path=BootCamp/2.0/en/bc1147.html).
3. You should see the good OS over firewire from the good MBP.
4. Select it, and see if it boots farther.

Why?

A quick way to rule out the internal HD and OS on the bad one. Should it boot OK this way, then we are back to (most likely) HD or OS.

If it still doesn't boot, then I have to agree with your diagnosis. Some bad Mojo.

There are software tools to check hardware, including the OEM gray disks, TechToolPro, and others. In my experience, they are marginal at best. Your tests so far are as good as anything. Apple techs have some other tools, so I expect they can give you an accurate diagnosis, but will cost you $$, and outside of a HD or power supply, it will be a pricey fix.

samantha
11-11-2008, 10:16 PM
There was no boot, so I did take it in to the Apple Store. They have some sort of thing going on right now that they will charge $280 for any repair and so they are replacing the logicboard for me.
Thanks you guys for all your help, I really did (and do) appreciate it!...sam

unclemac
11-12-2008, 08:03 AM
Wow, sweet deal!

Let us know if it was the logic board, CPU or whatever, so we can wrap the mystery up.