PDA

View Full Version : The Dreaded Flashing ?



rogabert57
02-29-2008, 08:25 AM
Hi Ya'll!
Just found and joined this site... hoping that with all the expertise and knowledge ya'll have here, i might get my problem resolved. Here it is:

I recently purchased a PowerMac G4 Digital Audio model 7450 733mhz with a 120gb HD off Ebay. It came installed with OSX.4.10 and 9.2.2. Powered up fine in OSX, and I browsed around a while in OSX and everything was fine. I made a DVD copy of all applications on the hard drive. Then, I had the bright idea that I would try it out booting up into OS 9.2.2. So I went into System Prefs and opened startup disk. I selected the folder icon representing OS9.2.2 and clicked the Restart button. :crossbne: That's when my troubles began. It restarted to the blank gray screen, with the little floppy disk icon with the flashing ?. I have tried so many things, and none of them work. Some of what I have tried:
:( Holding the x key to force start into OS10-not work.
:( Startup from an emergency startup disk I made on my old mac with system 9.1-not work. (However, doing this, it does give a smiley computer for a couple seconds, but then I get the dreaded Mac BOMB with the "unimplemented trap" message.)
:( Tried updating my emergency startup disk to 9.2.2-not work because my old 8600 is too old.
:( I even tried zapping PRAM, but that doesn't work, it still goes straight to the flashing ? as if i wasn't even holding the Zap PRAM keys down.

I just don't understand why any of the key-combination startup things I try don't work, as if I don't even have a keyboard. Seems I should at least be able to force it to boot back into the OS10 that was working fine just a little while ago.

ANYBODY have any idea how to get this thing to boot back up?? Oh, BTW, coming from Ebay, of course it came with no system disks.

Thanks.
:confused:

unclemac
02-29-2008, 08:54 AM
Howdy and welcome aboard.

Have you tried booting and holding down the option key? Should boot to open firmware, and let you a see and select all bootable OSes that are visible. Hold the option key quick.....if you don't have it down within about 1 second, you will miss it.

See what shows up.

Even without this problem, we would still recommend you round up the some system disks. For that G4, I would not consider 10.5, so you should be on the hunt for 10.4 retails disks.

rogabert57
02-29-2008, 09:09 AM
Thanks for the welcome, unclemac.
Yes, the option key is one of the keystroke-startup things i tried, and as i mentioned, with any keystroke-startup combination, it just ignores me as if i don't even have a keyboard, and goes straight to the gray flashing ? "where's my startup disk?" thing. I was holding the option key down before i hit the button to restart, or power up.

Getting some system install discs is what i figgered would be the answer... it should startup from a system install disc, right? Was hoping there might be another answer that didn't require so much $$$.

Thanks,

ricks
02-29-2008, 09:45 AM
Unfortunately, most recovery options start out with booting to a installation CD. You should be able to find a used one fairly inexpensively. Anyone who moved up to Leopard probably has a Tiger one that they can let you have cheaply.

I do have a couple thoughts as well. One is, lets do resets on everything. First one to do is a Open Firmware reset. No downside and may clear up what ails that G4. Stat up while holding the Command+Option+O+F keys. Hold them until you are told to release to continue. Then at the '>' prompt type:

>reset-nvram
Hit Return
>set-defaults
Hit Return
>reset-all

Hit return and the computer will restart. At this restart let's throw in one more reset, a PRAM. So when the chime goes off after the reset-all hold the Command+Option+P+R keys. Keep holding until the third chime and release. See if it will boot to one of the installed OSes.

If your keyboard is not having effect then I would question either the keyboard or the USB port. Hard to do anything if the keyboard is ineffective during startup.

Rick

rogabert57
02-29-2008, 11:27 AM
Hi Rick, and thanks for all the great advice.... unfortunately, as I had mentioned previously, none of the keyboard-startup combinations work because the computer is acting like there is no keyboard! Just to be sure, I tried it again, (thinking this being a new day, maybe it will respond to the keyboard things today) first with your suggestion of the open firmware reset. So, I held down the Command+Option+O+F keys, then started up the Mac... NOTHING, just the plain gray screen and the flashing ?
Then, I tried one more time, holding the same keys, and pressing the restart button on the front of the computer... NOTHING, same result.
Just for fun [ha-ha!].... I restarted while holding the x key, which is supposed to force boot into OSX, according to what I have read, and still same result: flashing ? on the little disc icon. In all cases, just as if there was no keyboard.
I tried the keyboard in a different USB slot, no help. I cannot try a different keyboard, I have no others that are USB. I do not see how it could be the keyboard, tho: since the same keyboard was working fine just before all this happened.... it was working ok when I first powered the machine on and looked around in OS 10 first. Plus, it works fine if I connect it to my older mac.
I'm beginning to wonder if even system discs will help?
Oh well, thanks Rick for taking the time to post your suggestions.
:confused:

unclemac
02-29-2008, 06:02 PM
How about a PMU reset?

Know how to find the little button?

Is it an Apple keyboard?

rwm
02-29-2008, 06:07 PM
A fellow moderator (Greentree UK) posted this a long time back and so this has some variations. This really has helped people get things going. Personally I'd pull most everything out like RAM and battery at a minimum and let sit overnight. Then try one of these....

1 remove all ram
2 press mobo reset button
3 press power button (you should get the no ram chimes*)
4 Power down and reinsert ram
5 press reset
6 boot normally
---------------------- OR
- remove the CPU
- press the CUDA for 30 seconds or so
- remove the PRAM battery!
- unplug the power cable
- press the power button to discharge any left over power (this might not actually be necessary)
- let it sit with no PRAM battery for a while. I'm not sure exactly how long... probably an hour is good, but if you're patient, you can leave it overnight.
- then put everything back together and try the upgrade again.
------------------------- OR
Remove ram. remove power cord. remove battery. Reset cuda/ PMU, push pwr button. insert pwr cord and boot yes without ram you should get a beep. Put ram back in. if not as above but press pwr and cuda together. have had this issue with a good few G4's and this always fixes them. if not. then leave overnight with pwr out. battery and ram out and when you come in in the morning press pwr button on front one last time. then pwr up. Goodluck

rogabert57
03-01-2008, 11:22 AM
First, Unclemac wrote:

How about a PMU reset?
Huh? don't know what that is....

Know how to find the little button?
what little button?

Is it an Apple keyboard?
negative... is a Logitech Elite keyboard, windows and mac compatible

Sorry, but I am not that big on the tech-end of this stuff... I mean, I've been using macs since, well, i can't remember... it's been at least 10 years tho. And when it comes to OS-X, i have relatively no experience!

With that said... I did find an OS-10.4 Tiger install disc on ebay that I should be getting early next week. I think I'll wait til I get that and see what happens, before trying what rwm suggested!!
If it comes to that, I'll really need a lot of help, cuz I haven't got a clue as to what a lot of what rwm wrote is.

Thanks to all for your time and expertise!! I'll come back and let ya'll know what happens when i get the system disc.

rwm
03-01-2008, 12:50 PM
Next to the battery or within an inch or two is a silver button and that is the button. I would say it is smaller than a pencil erasure and larger than the lead.

There are a few different recommendations on exactly how and when to press. I think... Usually 1-3 seconds but can't recall everything or other steps, sequences.

It's in the Guru's FAQ's and Apple but seems very hard to find and not a bunch of help. There are several discussions in the trouble shooting forum.. worth a search. I'll look in an hour or two. I'll be busy now for a while.

eric
03-01-2008, 01:38 PM
Resetting the PMU from Apple:

http://docs.info.apple.com/article.html?artnum=86760

Down at the bottom there is a link under "How to find the Cuda/PMU"

unclemac
03-01-2008, 03:33 PM
Not sure the PMU reset will help, but running out of options.

Two things going on here.

1. The flashing ? means that a bootable OS can't be found. Could be several reasons for this; most common would be a snarfed OS, or a hardware problem like a bad drive, loose cable, etc.

2. Even with a bad OS, bad hard drive - or no hard drive - your keyboard shortcuts should work. You should be able to boot to open firmware, and do the OF reset that Rick suggested with no hard drive attached. As you say, it is like the keyboard is not attached. Most likely culprits: Bad USB ports (or bus that controls them) or a bad/unrecognized keyboard. Any chance you could borrow a different USB keyboard from someone? Not common, but I have seen third party keyboards do what you are describing: seem to work fine with typing in the OS or applications, but not work at the boot (firmware) level. If it is not the keyboard or USB........then it could be the firmware itself. That could be the kiss of death.

I would try the voodoo reset and pull the RAM. If you get three beeps, then it means that the firmware has correctly tested and reported that there is no RAM installed.......which is a round about way of testing the firmware itself.

So, these would be the steps:

1 power off, leave plugged in
2 remove all ram
3 remove all cables, including power
4 press mobo reset button (PMU reset)
5 press power button (still with no cables plugged in)
6 plug in power, press power button (you should get the no ram indicator - 3 beeps)
5 Power down and reinsert ram
7 plug in power, power on

rogabert57
03-03-2008, 12:09 PM
Well, here's a bit of info for everyone....

I went to Best-Buy here locally today and purchased an Apple Keyboard--dwelling on what unclemac said: "Even with a bad OS, bad hard drive - or no hard drive - your keyboard shortcuts should work."

On first try, I booted up holding the x key, and it booted up into OS-X. So, apparently, the computer was not recognizing the Logitech keyboard early enough in bootup for the start-up key combinations to have effect!! Now, I am booted into OS-X and everything is running fine.
BTW: I tried it again one more time, went into System Prefs and opened startup disk. I selected the folder icon representing OS9.2.2 and clicked the Restart button. And it again does the same thing.... Flashing ? on the little floppy disc icon.
This time, with the Apple keyboard, I simply pressed the restart button on the front of the tower, held the x key again, and came up fine in OS-X again. So, I wonder why it won't boot into 9.2.2?? 9.2.2 runs ok within OS-X, but to try to boot-up into it, it gives the flashing ?
No big deal to me, now, since I know that I can boot into OSX just fine, and then run classic within OSX for my Classic apps.

Thanks to all for your efforts!!!
Thankfully, I didn't have to go as far as some of those "extreme" solutions... but the info is good to have on hand!
Thanks again to everyone, and God bless ya'll!!!
:o Bob