PDA

View Full Version : intel iMac screen problem



Macnewbe
05-23-2007, 07:24 PM
Hey Gang,
This is a bit new for me as it is a new intel iMac that the screen has suddenly go flaky. actually it just looks like grainy and missing half the colors. Regardless of what resolution I select the resolution changes but the grainyness and color looks the same. Ran the hardware test, both and it found nothing wrong. How can I reset pram or what ever the new mac have that would do the same thing. Firmware and boot rom versions are current. running 10.4.9

Any ideas
Thanks Bob

unclemac
05-23-2007, 09:14 PM
Doesn't sound good. Your only shot (I think) is an SMC reset (http://docs.info.apple.com/article.html?artnum=303446). Replaces PMU reset function from the PPC Macs.

If that does not resolve your issue, better call Apple. :(

Macnewbe
05-23-2007, 09:41 PM
Thanks Unc, you always seam to know at least where to start. Will let you know.
Bob

unclemac
05-23-2007, 09:55 PM
That's why they pay me the big bucks. ;)

Luck.

Greentree_uk
05-24-2007, 12:35 AM
I'd say your lcd is gone. have you tried the lcd tester pixel check?

http://www.macupdate.com/info.php/id/10793

Macnewbe
05-25-2007, 05:51 PM
I ran the pixel test on my laptop just for grins no problems. Have not been back to check the iMac yet.

Unc got another one for you, the 100gb HD I installed two months ago on the Ti PBG4 went south with no warning. (used drive) when I installed it, it was so quiet you could not here or feel it run. After waking up the PB yesterday I had a few windows open I did not recall using like a preferences Accounts window that I could not close, force quit would not work the desktop was randomly changing in the background like normal. I closed a few of the open windows, forcee quit others via the dock icons until I was only left with the finder but no window , now no dock and nothing to do but force shutdown with the power button.

then no reboot, just a folder with a ?, could not find the system file. Booted off an install disk, no HD mounted on the desk top. Ran Disk utility found the drive, but could not repair it Got this:
invalid volume header
invalid B-tree node size
Error the underlying task reported failure on exit

Disk warrior saw the drive, again not mounted
ready to rebuild directory had a green check
started the rebuild and it got hung on step one.

I can not tell if the drive was actually spinning, I suspect not. I have removed the drive and put the old 30gb back in and I am up an running. No backups for the last two months so out of luck on few things but most stuff and the overall setup was still on the old drive.

Any thoughts on next steps to recover the data, there is a few things I would really like to have back, I can recreate but would rather not. Not worth $800 Professional Data recovery services

And what the heck happened?

Bob

Greentree_uk
05-26-2007, 01:49 AM
you need to run diskwarrior on that drive. it should be able to recover. not a great sign when it does that so soon. new drives are not that much these days I would have opted for that. safer bet.

Macnewbe
05-26-2007, 09:25 AM
you need to run diskwarrior on that drive.
I tried but the system just stopped at step one.

Trying to figure if the drive is actually spinning.

Bob