PDA

View Full Version : SATA card and drive Disappears



russelljr1
01-29-2007, 01:20 PM
I just installed a Seritek/1S2 in my G4 533, OS 10.3.9. Attached a Seagate Barracuda 7200.9 SATA drive. I initialized the drive and it appeared on the desktop.

At the next startup the drive did not appear on the desktop and neither the drive or the Seritek appeared in Apple System Profiler.

Any ideas out there?

Thanks

ricks
01-29-2007, 05:38 PM
Reseat the card. Reset the firmware using Open Firmware:

At startup hold the Command+Option+O+F keys. At the '>' prompt type:

>reset-nvram
Hit Return
>set-defaults
Hit Return
>reset-all
Hit Return and your computer will restart.

After that try Firmtek support. They may have a firmware updater or something that will help. It is not the drive if the card isn't showing. Do the resets and reseats and see what happens.

Rick

russelljr1
01-29-2007, 08:12 PM
Ok I followed the instructions and now I have a nice bright screen with a circle with a slash through it.

What now?

M.Brane
01-29-2007, 09:13 PM
Will it boot from the ATA bus?

You may have to pull the SeriTek/Seagate to get the system stable again before further troubleshooting.

Any other PCI cards in there?

ricks
01-30-2007, 08:59 AM
Next:

Try a startup holding the Option key down. This will get you into a system selection window. Select the OS install and press the straight arrow to continue. If it comes up with no startup disk to select you will need to insert an installer CD and run Disk Utility to see if you can repair the drive.

From the installer CD you can also use Apple System Profiler to look at the Seritek and see if it is seen. If it has the right firmware, that sort of thing.

Rick

russelljr1
01-30-2007, 01:12 PM
To; M brane; Thats where I am trying to boot from the ATA bus not the SATA Drive. There is a sSIIG ATA 100/133 PCI card but I have connected a drive to it yet.

I will remove the SeriTek card and try again.

I sent their suppot an email two days ago but have not heard from them yet.

russelljr1
01-30-2007, 01:56 PM
OK the startup holding down the option key worked. I installed the card again and got the same results = big bright screen with a slashed O.

Removed the card and started again OPt key down and I'm back running again.

FirmTek support site says all cards come with up-to-date firmware.
I will call them if I can.

rwm
01-30-2007, 04:08 PM
I seem to remember talking about a conflict with the Seagate 7200.9's and a Seritek card maybe it was a certain OS X version. I am sure the issue was fixed long ago and as I recall it did not hurt to many people. I just honestly can't remember - this might remind someone else what it was. Or if there ever was a conflict. :rolleyes:

TZ
01-30-2007, 04:54 PM
If and when there was an issue, we put it into the FAQ under SATA drives. It would also show up searching the xlr8yourmac.com Drive Upgrade DB which you can search for reader reports.

Also, there are some notes on SATA controllers like SeriTek and which models are not supported. Should think it would be listed with the controller page on www.firmtek.com/seritek/ or OWC's as well as ours.

ricks
01-30-2007, 05:03 PM
Just about everything, drive models that is, should work with a 2 port Seritek and its Silicon Image chipset. Some sort of other problem is present here. May be a bad drive. Or something else. If just the presence of the card without any drives connected means it won't boot then likely the card or a combination of that card and some other card.

Try sending your email to cks@firmtek.com. The support emails get lost a lot there is cyberspace, probably from an over aggressive spam filter. Kim answers the cks address pretty conscientiously.

russelljr1
01-31-2007, 07:48 AM
Thanks for the leads. Interesting that the computer will only start up (on the ATA bus) with the option key startup procedure.

Just going through the normal startup procedure gets me the "slashed O" without the Seritek or any other card installed..

Wow, what have I done?

I will try to reload the system software to start unless somebody else has a better suggestion.

TZ
01-31-2007, 08:57 AM
When you remove a PCI device, reset nvram again.

NVRAM stores where the boot volume is located and has to be reset in System Prefs (can be done from OS X DVD even).

unclemac
01-31-2007, 10:01 AM
I have always associated the circle with the slash through it with a software (OS) problem. Have seen it before, long ago, when cloning an OS to a machine that would not support it.

I would think a reisntall would be a good starting place, and you might be successful with an archive and install. Always good to start over clean though.....although it can be a real pain.

kaye
01-31-2007, 11:33 AM
You have gone to the System Preferences pane, selected Startup Disk and chosen the drive or volume you wish to startup from? k

russelljr1
01-31-2007, 02:59 PM
Ok I have everything back for now. Reinstalled system software and ran DiskWarrior.

FirmTek responded that they tried to do some engineering on the SeriTek/1S2 and DA Macs because of incompatibilities, but perhaps my machine fell outside of those that they could fix.

It may be too late to return the Hard Drive and probably the SeriTek card, I'll see.

Or maybe it will work in my B&W but I won't do that until I complete my taxes-too much data could be lost because of my experimenting.

yeungfeng
01-31-2007, 08:07 PM
FirmTek responded that they tried to do some engineering on the SeriTek/1S2 and DA Macs because of incompatibilities, but perhaps my machine fell outside of those that they could fix.

I'd love to know just what they said, since I have a DA and a SeriTek/1S2. Care to post their reply?
Thanks

TZ
02-01-2007, 04:48 AM
There were some conversations, now archived in the FAQ on SATA controllers, regarding DA and SeriTek. Mostly there is a bug in the PCI bus that affects these systems (find me a system that doesn't have some kind of PCI anomaly or limitations) and that affects sleep (or wake from sleep).

russelljr1
02-01-2007, 07:59 AM
I'd love to know just what they said, since I have a DA and a SeriTek/1S2. Care to post their reply?
Thanks

They really asked me not to share this information because of some kind of regulatory restriction. So I probably have already said too much.