PDA

View Full Version : SCSI Burly revisited



kaye
03-30-2005, 01:14 PM
A lot has changed since I last tested my SCSI Burly. Previous test from the DB:

Kaye* MDD 1.25G DP 4xX15.3 18GB Cheetah ATTO UL3D firmware 1.6.6f0 SR0 2xCH Apple RAID 10.3.2 QB2.-100MB Read: 222 MB/sec Write: 203 MB/sec

Even the X15.2 drives in my other SCSI Burly did nearly as well then (did not test them today):
4xX15.2 18GB Cheetah QB2.1-100MB Read: 220 MB/sec Write: 203 MB/sec

Just shows the limitations of the MDD and earlier. Anyway, now we have 10.3.8, revised ATTO software, latest SoftRAID 3.1.3 (I used the 64KB stripe), QB2.1.1, ZoneBench 1.0, GigaMDD, and the same ATTO UL3D-33Mz card.

Tho the test result sez QuickBenchÈ 2.1, it is actually now v2.1.1:
QuickBenchÈ 2.1 Test Results File
©2003 Intech Software Corp.
Test file created on Wednesday, March 30, 2005 at 8:52:15 AM
Test Volume name: 4xX15.3SoftRAID

Extended Test Size: 20 MB Read: 201.580 MB/sec Write: 200.890 MB/sec
Extended Test Size: 30 MB Read: 213.188 MB/sec Write: 202.527 MB/sec
Extended Test Size: 40 MB Read: 217.262 MB/sec Write: 203.137 MB/sec
Extended Test Size: 50 MB Read: 218.454 MB/sec Write: 203.308 MB/sec
Extended Test Size: 60 MB Read: 219.305 MB/sec Write: 203.457 MB/sec
Extended Test Size: 70 MB Read: 219.024 MB/sec Write: 203.625 MB/sec
Extended Test Size: 80 MB Read: 220.260 MB/sec Write: 203.696 MB/sec
Extended Test Size: 90 MB Read: 220.475 MB/sec Write: 203.780 MB/sec
Extended Test Size: 100 MB Read: 221.684 MB/sec Write: 203.911 MB/sec

At 100MB file size, Read the same, Write up a a slight bit. However, the smoothness of the results as you go thru the file sizes is better than before.

On to ZoneBench. Don't ask me why these results are less than QB2.1.1, I don't know. I edited the results below to show only Zone 1 and Zone 7. It shows how well the X15.3 striped RAID does on the innermost tracks.

Test Date: Wednesday, March 30, 2005 (9:05:46 AM)
Test Volume Name: 4xX15.3SoftRAID
Test Volume Size: 68.327 Gigabytes
Transfer Size: 100 MBytes
Zone Count: 7
Iteration Count: 3

Measurement Zone: 1
First Measured Sector: 0
Last Measured Sector: 204799
Read Speeds Write Speeds
Maximum: 212.620742 195.294954
Average: 210.030803 194.641086
Minimum: 206.814967 193.890510
Iteration 1: 210.656701 193.890510
Iteration 2: 212.620742 194.737795
Iteration 3: 206.814967 195.294954

Measurement Zone: 7
First Measured Sector: 143291904
Last Measured Sector: 143496703
Read Speeds Write Speeds
Maximum: 178.492063 177.777778
Average: 177.860570 177.408126
Minimum: 177.385795 177.145408
Iteration 1: 177.385795 177.145408
Iteration 2: 177.703853 177.777778
Iteration 3: 178.492063 177.301192

I wish I had a PCI-X G5 to show how well this Burly would do with an ATTO UL4D or UL3D-66MHz card. k

Nicolas
03-30-2005, 01:25 PM
Nice gear Kaye.

SCSI :kickass:

Regards

Nicolas

TZ
03-30-2005, 02:06 PM
kaye,

When you say revised ATTO software, I assume that means driver 3.20v2.

Damien
03-30-2005, 05:44 PM
Boy those Granite cables sure do the job! Too bad they cost more than my house.

kaye
03-30-2005, 06:20 PM
Yes TZ, driver 3.20v2 plus latest Configuration Tool. k

TZ
04-01-2005, 03:51 PM
... just noticed a change and that Config 3.01 is only for FC cards and that SCSI adapters should still use 2.80....

www.attotech.com/software
http://attotech.vwh.net/software/app1.html

I also noticed that Hot Topics page is now gone, empty, and old URLs to it result in error. So even ATTO web site links in articles are "dead."
http://attotech.vwh.net/hottopics.html

Site map:
http://attotech.vwh.net/sitemap.html

kaye
04-01-2005, 04:56 PM
I swear to God TZ that ATTO just changed that. I wish they would date the pages, or better yet each of the downloads. I'm using v3.01. k

Boots
04-02-2005, 06:48 AM
Same here Kaye; at the time it said it was for UL4D. Doesn't seem to be causing any problem though...

kaye
04-02-2005, 07:03 AM
I checked the date of the last downloads, 3-28-05. I have redownloaded everything for my UL3D-033, UL3D-066, and UL4D. What a pain. k

Nicolas
04-02-2005, 08:39 AM
Same here, saw it (Config Tool 3.01), installed it and it was running fine.

Regards

Nicolas

kaye
04-03-2005, 08:23 AM
I have been sick with the flu for nearly a week so progress has been slow but with all of the latest for the UL3D-033 from the ATTO website, uninstalled Config Tool 3.01, and set it all up for running the same unchanged SoftRAID 4x X15.3 RAID 0, 10.3.8, GigaMDD, SoftRAID 3.1.3, 64KB stripe.

I don't have a clue why, maybe Config Tool 2.80, but the RAID is consistently slightly faster from 20MB to 100MB in QB 2.1.1. Same for ZoneBench. I won't show ZoneBench but QB 2.1.1 previous:
Extended Test Size: 100 MB Read: 221.684 MB/sec Write: 203.911 MB/sec
now:
Extended Test Size: 100 MB Read: 222.299 MB/sec Write: 204.165 MB/sec

When I'm up to it I will test the UL3D-066 and UL4D on the same RAID. k

kaye
04-04-2005, 07:32 AM
One other point that I should have mentioned, I have been running the GigaMDD with all slots full and Hardware Monitor and QuicKeys X running in the background.

Slot-1: GF4ti
Slot-2: Acard 6885M, 4-channel PATA card, 2 drives connected
Slot-3: Revolution 7.1 audio card, running powered speakers
Slot-4: ATTO UL3D-033 card (keeping it away from the AGP slot)
Slot-5: NitroAV, FW800 and USB 2 combo card with printer connected to USB 2

This morning I stripped out all of the PCI cards except the UL3D-033 and ran QB2.1.1 on the RAID with no increase. Same results so none of these removed cards are stealing bandwidth or hogging the bus. k

Nicolas
04-04-2005, 08:15 AM
Kaye,

thanks for this info.

Get well soon!

Best wishes

Nicolas

kaye
04-07-2005, 09:47 AM
On to the UL3D-066. The ATTO files for this card are the same as for the UL3D-033 except for the FlashBundle_2003_07_15.UL3-66 Folder. I did however download everything again.

The first time around only changed the FlashBundle. Results disappointing to say the least:

UL3D-066
Extended Test Size: 100 MB Read: 203.062 MB/sec Write: 202.897 MB/sec
UL3D-033
Extended Test Size: 100 MB Read: 222.299 MB/sec Write: 204.165 MB/sec

So next I reloaded all three files listed for the card. Same result. I guess best to test in a G5 with PCI-X slots. k

kaye
04-16-2005, 07:32 AM
I had intended to test the same SCSI RAID with a UL4D in my GigaMDD just for comparison's sake, tho the UL4D is optimized for the G5. That is not going to happen anytime soon and I am really ticked at ATTO.

I nearly totally florfed my boot drive with ATTO's latest software for the UL4D until yesterday I discovered a not very prominent link to this:

ATTO ExpressPCI UL4D and UL4S Flash Bundle Readme

The following flash bundles are available for the ExpressPCI UL4D and UL4S:
FlashBundle_2005_02_23.U320 - released 2/23/2005
FlashBundle_2004_03_19.U320 - released 3/19/2004

If you have received errors in the ATTO Configuration Tool when using FlashBundle_2005_02_23.U320, please use the following procedure to restore the flash:
1. Shutdown your system, wait 10 seconds, and reboot.
2. Open the ATTO Configuration Tool and verify you have the latest driver from the ATTO website installed. For Windows, it is version 1.20. For Mac OS X, it is version 3.30.
3. Download the ExpressPCI UL4D and UL4S flash bundle FlashBundle_2004_03_19.U320.
4. Update the adapter flash with this flash bundle using the ATTO Configuration Tool.
5. Shutdown your system, wait 10 seconds, and reboot.

If you have not experienced problems using FlashBundle_2005_02_23.U320, you may continue to use it. Typically, this will apply to those who purchased their adapter after 3/3/2005. If you purchased your adapter prior to 3/3/2005, please do not attempt to use FlashBundle_2005_02_23.U320. We are working on an upgrade solution.

We apologize for any inconvenience this may have caused.

By "If you have received errors..." ATTO means but does not say the Config Tool for the UL4D when launched goes into the splash screen and an endless beachball which even a forced quit will not stop. I had to push the front button to shutdown. Like an idiot I tried several times to get the UL4D going and to see if the RAID would mount. Nothing worked including forced prebind with Cocktail. And each attempt to use the UL4D Config Tool resulted in the beachball. Then I saw the above "inconvenience" yesterday.

So the UL4D is back in its antistatic bag. BTW, the Config Tool installer for the UL4D removes the UL3D-033/UL3D-066 Config Tool. Another ATTO florf. k

Nicolas
04-16-2005, 09:34 AM
Cra%$& drivers.

Problems with some card configurations and so on.

Regards

Nicolas

TZ
04-16-2005, 12:41 PM
it isn't the "drivers" as the installer and firmware, maybe. One thing I now do every time I do an install, is to have Disk Utility launched and run Repair Permissions before I even Restart.

When I installed 3.20v2 driver just now:
ATTOExpressPCIPlus Driver ReadMe

This document and utilities mentioned within have been installed to
/System/Library/Extensions/ATTOExpressPCIPlusUtils.

Contents

A. Open Firmware Options
B. Event Logging
C. Troubleshooting
D. Uninstallation


A. Open Firmware Options

An Open Firmware environment variable, atto-args-plus, can be used to pass
arguments to the ATTOExpressPCIPlus driver. To set this variable:

1. Boot to the Open Firmware User Interface by pressing Command+Option+O+F
while booting.

2. At the prompt, enter the following command:

setenv atto-args-plus [options]

where [options] may be one or more of the following:

-b Bypass SCSI Domain Validation.
-d Disable the driver.
-e mask Specify the hexadecimal mask 'mask' for event logging.
See Section B for more details.
-f Load the driver in 'flash-only' mode. You will be able to use
the ATTO Configuration Tool to update the adapter, but devices
will not be visible.
[blank] Leave the options parameter blank to clear the options.

3. At the prompt, enter the command 'mac-boot' to continue booting OS X.

Note:

1. These options are stored in system NVRAM; therefore they persist between reboots
and shutdowns.

2. These options may also be set using the nvram utility in OS X. Enter 'man nvram'
at a terminal prompt for more information on using the nvram utility.

So it might be possible to boot into Open Firmware and get past those issues... I didn't see any such "tip" when installing Config 2.80.

Hot Topics: Mac OS X (http://www.attotech.com/troublemac.html) (login required to access)

TZ
04-17-2005, 06:45 AM
LSI 3MEGARAID 300-8 SATA controllers (http://forums.storagereview.net/index.php?showtopic=19208&st=0&#entry202569)

kaye, you/we aren't alone. :(

kaye
04-17-2005, 07:16 AM
That is a very ugly and expensive situation TZ. There was some pretty significant damage to my boot drive with my UL4D saga but running off of my backup boot drive and repairing with DiskWarrior, Disk Utility, Norton Disk Doctor, and finally DiskWarrior again, everything is back to good health with my primary boot drive. k

Macaholic
04-17-2005, 11:34 PM
I would guess that all Hd manufactures and RAM manufactures want to have
" the next big thing"
In these areas the "standards" are bent or do not exist,

Dave