PDA

View Full Version : Problem with RAID?



speters1
03-23-2005, 11:58 PM
I have two RAIDs. One 6 drive Atlas 10kIII across two channels of the UL4D and a 2 drive Cheetah 15k.3's. This is in a G5 dual 2ghz. I downloaded Photoshop test 1.0 and did the first test with the scratch set to be the startup. I then changed out the scratch disk for the 6 Atlas, and set the ram amount to 100%. Everything was going fine until I got to the apply image. I got the beach ball half way through, and when I canceled it read 140s. The previous test, with the startup as scratch only took a total of 40s. So I lowered the ram allocation to 70%, same problem. I then switched the scratch disk back to the startup, and it did it in 42s. So I then switch the scratch disk to the 2 Cheetahs, and it did it in like 20s. So there is some problem with the 6 Atlas's. I am using Softraid 3.0.2. I even tried to use the Apple Raid to see if that would work, and still the same problem. I ran QB 2.1, extended, 20-100mb and one time it started out at 195 read, 285 write, then at 60mb, the read was 260 write 7. It ended with a read 285 write 78. The next time I ran it I got 203 R, 285 W @ 20mb, then ended with 263 R, 161 W. So obviously there is a problem. How can I test to find out what is going on?
I only use the 6 Atlas's for scratch, so I never store file son there.

kaye
03-24-2005, 05:09 AM
speters1,

First a couple of questions. What version MacOS are you running? And why not SoftRAID 3.1.3?

Interesting how the Pshop test will point to a problem. I think that I would start by breaking the 6 drive Atlas 10kIII RAID and initializing each drive separately in SoftRAID. Run the same QB2.1 a couple of times on each drive. Might point to a failing drive or cable attached to that drive.

Of course there are more questions about cabling, terminators, etc., but I would start with testing each drive in that RAID. k

TZ
03-24-2005, 05:44 AM
I seem to recall a number of posts of nearly the same - problems with your 6 10K IIIs.

If you own SR3, I can't understand not installing and updating to 3.1.3 either.

Four Atlas 10K V or 15K II; or add more 15K.3s and all the same firmware.

speters1
03-24-2005, 12:54 PM
TZ, the problems before where with the slow speeds i was getting with a UL3D and a UL4S. Once I got the UL4D, I was getting reads and writes in teh 280 range. I did have a problem with some i/o errors on one of the drives a while back, but it has been ok recently.

I am running OS 10.3.8. Is v3.1.3 really any better than 3.0.2, as far as errors and speed?

TZ
03-24-2005, 01:02 PM
there have been ten updates to SoftRAID. I guess you'd have to read all the release notes for each to see a full list of changes. And test for yourself - it is a free update to registered owners afterall.

Are some drives off (15K.3s) when you use the others? probably not wise, definitely not if on same channel.

speters1
03-24-2005, 02:08 PM
all drives are on

speters1
03-24-2005, 02:11 PM
I am using OS10.3.8. I just updated frmm 3.0.2 to 3.1.3. When I started 3.1.3, it said that I needed a new driver, then I needed to restart. I did tha, and me computer got hung up with the apple on the desk top and the little thing spinning under it. I force quit, then started with all dirves off, and it started just fine. There is no number for Softraid, and I need to use these scsi drives today. Any ideas?

Boots
03-25-2005, 06:08 AM
Steve,
To make sure everything's in tip-top shape, I would first disconnect the SCSI sub-system, then thoroughly repair your startup drive and any other internal drive with a repair permissions, First Aid from Disk Utility, and Diskwarrior, then-

1. Make sure you are using the latest ATTO Configuration Tool: version 2.80
2. Update the UL4D driver to latest version: 3.30
3. Flash the UL4D card to the latest available flash version for it: 1.4.2f1
4. Make sure you are running the latest version of SoftRAID: 3.1.3

Then reconnect SCSI sub-system and follow Kaye's advice to break the UL4D RAID into individual SoftRAID-initialized drives and test each.
This way, you can rule out problems with the software and focus on the sub-system's hardware.
------------------

Boots,

The latest ATTO Config is 3.01. Not sure when it showed up but has a date of "March 4, 2005" so it seems to have slipped by. (I only check for driver updates, but at least once a week.)
1. Make sure you are using the latest ATTO Configuration Tool: (http://attotech.vwh.net/software/app1.html) version 3.01
2. Update the UL4D driver (http://attotech.vwh.net/software/driver34.html) latest version: 3.30
3. Flash the UL4D card to the latest available firmware ("flash file"): 1.4.2f1
4. Make sure you are running the latest version of SoftRAID: (www.softraid.com) 3.1.3 -------------------
- TZ

speters1
03-25-2005, 10:45 AM
I figured out that i had one bad drive in my 6 drive raid, but I stil can not get my computer to even start up with Softraid driver 3.1.3 installed. As soon as I disconect my scsi drives it will start up. I did just check the firmware on my UL4D and it is 1.4.2f1., the driver is 3.2, so I will update that. As soon as I remove the 3.13 Softraid driver and put back 3.02, everything is fine. I emailed Softraid, and they could not really help me. He had me try a couple of things, and it did not work.

speters1
03-25-2005, 10:51 AM
I have a dual 2ghz G5. I installed asecond SATA drive about a year ago, and everything was fine. About 3 weeks ago, my second drive ( which is actually the drive that came in the commputer) disappeared. I called apple and they ahd me reset the Pram, that did nothing. They then hgad me go inside thecomputer and push asmall button behind the fan, that worked, but it has now again disappeared. Any ideas?

TZ
03-25-2005, 11:22 AM
Steve,

I like to have one thread because it all is related. In your case, the 2nd SATA drive may be causing problems. A damaged boot block would do it.

speters1
03-25-2005, 02:02 PM
I am not sure that the issues with the SATA are related to the issues with my RAID or softraid? The guy at apple seemed to think the issue wiht my SATA may be a power issue. I geuus when you press that button on the inside if changes the way that power is destributed, or something like that. This second drive does not have any sytem sdoftware on it, it is just used for storage.
I am so busy with work that I do not have alot of time to be trouble shooting. I did fined out that one of my drives in mty 6 drive raid was having issues, so I figured that out, but now I can not use Softraid 3.1.3 and my second drive will sometimes not show up. I figured I would jsut post my issues here in the hope tha tmaybe some one else has ahd the same issues, and I would be able to resovle them with out having to spend hours trouble shooting.
I do appreciate everyones input.
thanks,
Steve

speters1
03-25-2005, 02:07 PM
Are the 15k.3's still the best drives to use for a RAID 0? Anything coming out that will get us over 300mb transfers?

TZ
03-25-2005, 02:21 PM
www.storagereview.com - leaderboard and performance DB.
http://www.storagereview.com/comparison.html

#1: Atlas 15K II
#2 Cheetah 15K.4

No drive by itself but 15K II and 15K.4 are ~95MB/sec. I wouldn't even use four on one channel of UL4. You could put two on each channel. They are still relatively "new" to market.

one moderator picked up some 15K IIs though. Not sure when the Store will have 15K.4s.

TZ
03-25-2005, 02:32 PM
There was an article on MacIntouch or MacFixit this week about someone with 3 failed SATA drives and Apple replaced the LB. No more trouble.

RAM can cause disk errors. A disk error to the directory can interfere with booting.

With your bad drive removed, try again.

I just had a ATA drive fail on startup and when I hard restarted with the power button, the permissions information, which is stored inthe directory, was wiped out - couldn't boot that drive. I do boot from SR 3.1.3 mirror and it is solid as a rock. Very safe now finally.

If I was in your shoes, I would probably be using a four or eight port S-ATA controller and 10K Raptor drives which Barefeats benched in the 300MB/sec - and above - range.

No matter what comes up, we have people that begin with adding a drive and end up looking at RAM, cpu upgrade, moving home folder around, goes in any direction, but easier to follow if it isn't splintered into a new thread for each question, so anyone can follow what has been asked, tried, progress.

Some G5s have had loose or disconnected power or data cables on the 2nd SATA port. Some thought it was the drive itself until 3-4 drives all fail.

That button was the PMU and we have links to articles or just google Apple Support in www.apple.com/support - G5.

speters1
03-25-2005, 04:00 PM
A couple of questions.
What do you think I should use teh SATA controller for?

Are you suggesting that I getr rid of my UL4D and external drives?

I am think of maybe getting a couple of the Atlas 15kII's. Those would have to be faster than 4 10k Raptors, don't you think?

I was thinking of getting a Seritek card for my boot drive, which is a 10k Raptor. I just checked and I think that I actually have the Western Digital Caviar. When I go into System Profile it says WDC WD740D. I could of swore I bought the 10k Raptor? Is the Caviar as fast as the Raptor? Would there be any reason to get a 4 channel card, if I plan to stay with my UL4D for my RAIDs?
One more question, what do you mean by "replaced LB"?

speters1
03-25-2005, 04:01 PM
I got Softraid 3.1.3 working. I installed the new 3.0 driver on my UL4D.

kaye
03-25-2005, 04:38 PM
Steve,

That System Profiler report which sez WDC WD740D is the 74GB 10k Raptor. See http://westerndigital.com/en/products/Products.asp?DriveID=65

Replaced LB means a replaced logic board or motherboard or mobo. I'll leave the rest of it to TZ. Good that you have SR 3.1.3 going.

How about Boot's list:
1. Make sure you are using the latest ATTO Configuration Tool: version 2.80
2. Update the UL4D driver to latest version: 3.30
3. Flash the UL4D card to the latest available flash version for it: 1.4.2f1

All of that done? k

speters1
03-25-2005, 06:37 PM
Yes, the only thing that i had to update was the ATTO driver. I had 3.2 on their. Everything else was up to date.

speters1
03-25-2005, 07:03 PM
So has anyone actually ran 4 Atlas 10k II in RAID? I am thinking of doing that, but I know that theoretical speed and real speed are two differnt things.
So, is scsi still the fastest? I saw something on Barefeats about Rocket RAID. I thought is said the they got like 400mb transfers with a 8 drive RAID?
Basically, I want the fastest possable RAID 0 for phtotshop scratch disk. I want to keep i under $2000. What would be the best way for me to go? Should I keep UL4D and get some new drives or go with PCI-X SATA?

TZ
03-26-2005, 06:44 AM
10K II is not what I said or what you want. 15K II. Check SR and its forum.

I think SATA would be nice. cheaper. the Atlas wouldn't even break into a sweat. but 4 x 70 = 280 (Raptor) while I said *3* 15K IIs (90 * 3 = 270). SCSI has deeper queue depth.

Cost: $300 x 3 = $900 for Atlas
$200 x 4 = $800 (+ cost of SATA $200) = $1000.
Pretty much a "toss-up" I think.

ps: the Atlas 10K V is 89MB per second, less costly and easy to find. The 15K II is SCA only for now. For editing, 15K. For sequential I/O, 10K is fine and less costly. Both models of the Atlas family -15K and 10K - use the same firmware (reduces costs and seems to work well).

Sometimes small 18GB 15K drives work the best, or single platter, which is what the small 36GB 15K drives use. The 10K III was great in its day and good for high sustained reads. But it is a couple generations old now.

speters1
03-26-2005, 01:45 PM
I meant type 15K II.
I want to get over 300. How can I do that?
Does multiplying the single drive speed by the number a drives, give you a real world speed? So if I got 4 10kV, I would get 356mb/s? That is what I want.

speters1
03-26-2005, 02:24 PM
I am still having an issue with me second SATA drive not showing up. Last night, after a restart, it cam back up. I ran Disk Warrior on it, and rebuilt the drive and it was fine. Started up this morning, no drive.

TZ
03-26-2005, 02:24 PM
I wrote a nice reply, then my cast on fingers hit command + W :(

Prices on zipzoomfly for Atlas (http://www.zipzoomfly.com/jsp/ProductList.jsp?ThirdCategoryCode=011005&SortBy=BA&Brand=MAXTOR) looks like $900 whatever you use.

And using two channels, four 10K Vs should deliver your 300GB, as long as the UL4D and 133 MHz bus are up to it. There is ~15% "overhead" you can subtract per channel. The more drives on a channel, the worse it gets.

You'll have 73GB per drive, use SoftRAID to partition the outer 1/3 for your most demanding needs (20-25GB slice) and 80GB total, and then only half of that or 40GB for your active files.

I would consider the Atlas 15K which is rated for 75MB/sec, $155 18GB. Nice drive also. Four would not hit 300MB/sec. Six would. and run ~$900 also.

So yes, four 10K Vs should do well, and make it easy to add two more later if you want to add or replace the Cheetahs.

Maybe use SCSI instead of SATA? Price of Raptor is close... do you have a UL3S/D - ?

speters1
03-26-2005, 05:44 PM
Right now I have a UL4D in my G5,but I also have a ul4S that I am noy using. I am holding on to it because I may need to add a second computer, so I would put the 4S in that.
If I am going to just be using this RAID for scratch disk, then I don't really need large drives. I was thinking of going with 4 18's, unless larger drives are faster.
If there is a limit because of the bus, or something else that will only allow 300mb sec, then I am not sure it would even be worth it. I was getting 280mb/s with my 6 Atlas 10K III. I found out that I had an issue with one drives, that is still under warranty. So unless I can get over 300, with some new drives, I don't think that it's worth spending $900, unless maybe they would be more reliable?
I do have a question about partitioning the RAID to take advantage of the fastest part. So is the inner 1/3 of the drives that are the fastes? So I should then set up 2 partitions on my RAID, designating the first 1/3 to scratch?

speters1
03-26-2005, 05:46 PM
Is there a way to mount my RAIDs after I have already started my computer? Right now, if I forget to turn on my RAIDs before I start my computer, I will shut down, turn them on, then start back up.
One moer thing, should I leave them on or turn them off, when not in use?
Thanks

TZ
03-27-2005, 04:18 AM
NEVER - ever - turn drives on or off when the system is running, even in sleep mode. You will harm the drives or even the controller.

And SCSI is used in servers 24/7. It is the off/on cycles that is hard. Cold - hot - cooling off again - that ages metal and parts.

The issue of size is the OUTER 20% of a drive is where you get close to the theoretical performance. SR's report on outer tracks? - that is reliable and what you should get.

Replace the drive that is under warranty by all means! maybe buy a spare?

Do you have 6 drives on two channels?
You also have 2 Cheetahs. Are both on their own?
are both RAIDs in use at once? that will affect what happens.
I would use the UL4S for the Cheetahs - and/or you could put one drive for boot drive.

I would think that 8 Atlas 10K IIIs would be the best setup with four on each channel. They are on the slow side (55MB/sec I seem to recall off top of head). So even 45 x 6 = your 280MB/sec. You might see if one or two more really all that you need.

If you want to play and have fun, then one of the new 10K V or 15K IIs would be nice just "for evaluation purposes and testing" and see what either would do for your system as boot drive.

The inner tracks are very slow. I would recommend getting the Intech speed test utilty for $25 which lets you see and test your drives. It even pointed out a bad cable for me so it has more diagnostics than I realized, and why I think we'll recommend it to everyone.

TZ
03-27-2005, 06:39 AM
I went to SR Review of the 15K II and clicked on a google ad for a place that specializes in Maxtor drives where they have one for $255.

Technical Information:
Storage Capacity 36.7GB
Heads 2 Physical
Discs/Platters 1
Bytes per Sector 512
Drive Performance
Data Transfer Rate 270MBps External Maximum Ultra320 SCSI
320MBps Burst Maximum Ultra320 SCSI
98MBps Sustained Minimum
Computergiants: Atlas 15K II (http://www.computergiants.com/items/one_item.asp?part=81549&cat=5&subsubcat=600)

speters1
03-27-2005, 03:28 PM
Do you know if anyone had gotten over 300mb/sec with a RAID?
www.Barefeats.com

I thought that I read that there is some bottle neck somewhere wiht either the G5 or the UL4D that keeps you below 320? There was.

I have the 2 Cheetahs across 2 channels of the UL4D, and the 6 Atlas across 2 channels. I had those cheetahs on the UL4S and it was slower.
Try again.

I use the 2 Cheetahs to save my working files. So I am constantly opening and saving files to these two drives, while I am using the 6 Atlas's for scratch.

So I am never actually wroking while it is saving, so then they are not both really running at the same tiem, correct?

What I have noticed is that sometimes I can save a 700mb, layered file, in a minute or less, then other times the same file will take several minutes.

Maybe this was do to the faulty Altas drive that I am going to replace. It seems to happen after I have been working for a while. It always seems a lot faster when I first start up. I meen start up my computer, not just restart phototshsop.

I typically will work on files that are over a gig, so I need the fastest possible saves.

I know that they say it is suppose to be faster to save to the same drive that you use for scratch. The only thing that is scary about that, is the I have 6 drives that could fail instead of just the 2 that I am saving on now, and I really did not see that much of an improvement in time when saving to the scratch disk. whatever works best

I do have Speed tools, but I have only used Quickbench. Which utility did you use to find out that you ahve a bad cable? (ZoneBench - it is mentioned earlier. )

speters1
03-27-2005, 04:05 PM
I just tried partitioning my RAID, which is only 5 drives unilt I get the 6 atlas fixed. I seperated them into 3 28bg partitions, and I got the same results with Quickbench 2.1, (extended, 20-100mb test), on the first partition as I did on the non partitoned raid.

So is this speed test not endicitve of what would happen when I used the firts partition for scratch ?

==========

speters1
03-27-2005, 08:58 PM
The 6 atlas dirves I have are ultra 160's.

I while back I ahd soem issues with on of these drives, so they sent me a new one, but it was a 320. My RAID would not work with that drive in. I ended up sending it back, and the drive I was going to replace started to work again.

I asked them if they could just send me a 160 and they said they do not ahve them anymore.

Does anyone know if you can mix 160 and 320 in a RAID?

Also, does having different versions of firmware slow you down at all?

speters1
03-27-2005, 09:56 PM
So I took out the one drive that was giving me problems, well I did not physically take it out, I just did not inlcude it in my RAID volume.

I used Quickbench to test the RAID and everything was fine, I was getting 222 read, and 240 write on the 100mb test.

Then one time the write dropped at 90mb. It went from 240 @ 80mb, to 95 @ 90mb, then back up to 240 @ 100.

So I tested my second RAID, the 2 Cheetahs, and that did the same thing. I got a drop at 90mb.

I re ran the test and everything is fine.

I repaired the disk permisions on my main drive.

Should I unhook my SCSI to do this, as boots recommends?

I have not yet run Diskwarrior on my boot drive yet, but I figured that maybe this new info, may have some kind of indication that something is not right?

TZ
03-28-2005, 04:58 AM
Steve,

This sounds the same as months ago.

ATTO has been working to improve their driver and firmware, so that is why that was one of the first things asked to do.

Have you read articles on SCSI and RAID, Steve?

Having the same firmware is essential for best performance.

U320 is backward compatible, but they would be different drive characteristics (spec, performance, firmware, everything).

I wish you could edit your post(s) and figure out what the questions really are... it is a lot to wade through to find the essential issues. More of a story. Go back, take your recent 3-4 posts, combine, edit, put it one new one, and delete the old ones afterwards.

Boots
03-28-2005, 05:04 AM
..not sure that the issues with the SATA are related to the issues with my RAID..

Perhaps not, but all parts of your system need to be functioning properly for best results.

If you have Diskwarrior, use it regularly to fix startup drive and and that second SATA. How much free spce on those two SATA drives? Filled-up drives will slow you down for sure.

Are you sure you have adequate scratch space on the Atlas RAID? 1GB file could be making a pretty big scratch file depending on what you do to it, history settings, etc.

Perhaps there is a way you could alter your workflow; do the files have to be that large to begin with? Could you do an up-rezzing routine in stages for final output? What is the final purpose of these big files? Tell us, inquiring minds want to know! ;)

Are you using Photoshop CS or 7? CS is faster.
How much RAM? Settings of less than 100% will give you faster saves, slightly slower filters.

If you are using 2 x Cheetah stripe to store files, is that not just as much of a risk as using 6 x Atlas stripe for working file?

TZ
03-28-2005, 06:53 AM
Results of a first gen Atlas 15K two-drive stripe (G4 MDD 1.25/SP, 10.3.8, UL3D):
Apple DU RAID:

QuickBenchª 2.1 Test Results File
©2003 Intech Software Corp.
Test file created on Monday, March 28, 2005 at 8:30:43 AM
Test Volume name: AtlasRAID

Xfer Size Sequential Read Sequential Write Random Read Random Write

Extended Test Size: 20 MB Read: 119.182 MB/sec Write: 170.301 MB/sec
Extended Test Size: 100 MB Read: 138.107 MB/sec Write: 145.141 MB/sec
===========
ZoneBenchª 1.0 Test Results File
Test Date: Monday, March 28, 2005 (8:52:23 AM)
Test Volume Name: AtlasRAID
Test Volume Size: 34.224 Gigabytes
Transfer Size:100 MBytes

Measurement Zone: 1
First Measured Sector: 0
Last Measured Sector: 122879
Read Speeds Write Speeds
Maximum: 135.167100 133.472738
Average: 134.125218 133.295694
Minimum: 132.886539 133.035334

======================
SoftRAID 3.1.3 Results
======================

QuickBenchª 2.1 Test Results File
©2003 Intech Software Corp.
Test file created on Monday, March 28, 2005 at 9:03:09 AM
Test Volume name: Atlas_SR_RAID

Xfer Size Sequential Read Sequential Write Random Read Random Write

Extended Test Size: 20 MB Read: 118.577 MB/sec Write: 171.230 MB/sec
Extended Test Size: 100 MB Read: 139.325 MB/sec Write: 144.879 MB/sec
--------------
ZoneBenchª 1.0 Test Results File
Test Date: Monday, March 28, 2005 (9:04:20 AM)
Test Volume Name: Atlas_SR_RAID
Test Volume Size: 34.206 Gigabytes
Transfer Size: 100 MBytes

Measurement Zone: 1
First Measured Sector: 0
Last Measured Sector: 204799
Read Speeds Write Speeds
Maximum: 134.309495 133.548970
Average: 134.294706 133.481782
Minimum: 134.275410 133.445962
-----------------

Atlas 15K vs. 15K II Review (http://www.storagereview.com/php/benchmark/compare_rtg_2001.php?typeID=10&testbedID=3&osID=4&raidconfigID=1&numDrives=1&devID_0=279&devID_1=232&devCnt=2) - new models of this generation are rated for outer max transfer rate of 75MB/sec, at the time of introduction (when I got mine) it was 72MB/sec. Single drive results are more in the 70MB/sec and 65MB/sec for sustained writes. The center section of the drive or RAID show about 15% drop-off in performance.

The only reason to partition is to use the inner partition for backup/storage, or for 'testing' when it was not possible to benchtest across the entire tracks of a drive, which ZoneBench will.

TZ
03-28-2005, 07:27 AM
Maxtor Atlas 10K III (http://www.storagereview.com/articles/200107/20010711KW073L8_1.html)
Maxtor Atlas 10K IV (http://www.storagereview.com/articles/200411/200411028D300L0_1.html)
Maxtor Atlas 10K V (http://www.storagereview.com/articles/200411/200411028D300L0_1.html)
Maxtor Atlas 15K (http://www.storagereview.com/articles/200304/200304068C073x0_1.html)
Maxtor Atlas 15K II (http://www.storagereview.com/articles/200412/200412088E147L0_1.html)

Head-to-Head Comparison (http://www.storagereview.com/php/benchmark/compare_rtg_2001.php?typeID=10&testbedID=3&osID=4&raidconfigID=1&numDrives=1&devID_0=279&devID_1=232&devID_2=264&devID_3=40&devCnt=4)

speters1
03-28-2005, 11:54 AM
TZ, I tried to start new posts, on the different issues, but they kept getting put back in this post. I am having several issues, that is why I tried to start two different posts. I am having an issue with my second drive not showing up. I ran diskwarrior on that disk the last time the disk came up and it was fine, the next time I started up it was gone. I was having an issue with my 6 atlas RAID. I figured out that one of the drives was bad. I took that dirve out, then it was fine. Then later I ran into one little hickup at the 90mb mark. Plus, I am trying to figure out if I should just get a new RAID. Not so much because of my issues, but because I figured that maybe I could get something faster.

I know I am asking some of the same questions I asked before (http://www.macgurus.com/forums/showthread.php?p=38630#post38630) (and see April 2003 thread when this began (http://www.macgurus.com/forums/showthread.php?p=43252#post43252) two yrs. ago) - things change. That was June 2003 when you started this "thread" and asking about RAID using Atlas 10K IIIs. or "high end retouching in photoshop" RAID for Photoshop (Jan 2003) (http://www.macgurus.com/forums/showthread.php?p=53059#post53059)

So don't repeat.

Since the last time I was here two new drives have come out, so I don't think that I should just assume what good for me several months ago still applys. I am no engineer.

Read the reviews. Check Storage Review. I posted the links even, so there isn't even any work there.

I figure that maybe the whole firmware issue could have been resolved with the latest update to softraid.

Don't confuse software with firmware.

I know that this is alot to waide through. That is why I tried to start different post with my different issues. So what would you like me to do? How about we delete this whole thing and let me have seperate posts for the seperate issues?

That isn't the issue.

speters1
03-28-2005, 11:59 AM
I just want to make sure that I did not come off the wrong way in the last post. You guys have helped me immensely, in putting my RAIDs together. I just a little confused about how you want me to handle my post? All in one post, or separate posts for separate issues?

TZ
03-28-2005, 12:06 PM
I like to see a problem well documented with English and grammar to make it easy to read and understand. And all of it in one thread. (Filters and plug-ins for Photoshop might be best in another thread, or questions of PS 7 vs CS).

That is why I edited your posts (and added some quick answers to some). I tried to break down the "story" into what I thought was pertinent issues and facts.

I don't have any problem with multiple issues, except when I can't tell what the question really is. Or if it is a midnight "rant" when I see 3-4 posts in few hours when I check back.

Does it say what you want? Will people understand it? Do you re-read or preview before submitting? (I realize there is only a small 5-10 minute window to edit a post... you should have been able to add the last post to your prior post.)

The only issue I see is you want to use 4 yr old drives, get 300MB/sec.

How about ordering six Cheetahs to replace the Maxtor drives?

That would make the two years asking about the same "problem" (if there is a problem), seem like it wasn't all for naught. For $2K. And, for once, done "by the book" and no cutting corners. A hand-built custom RAID box. Read, and print out, the "Guide to building SCSI RAID" (http://www.macgurus.com/productpages/scsi/seagatescsidrives.php) which is the SCSI Hard Drive page of the Store.

Trolling through the Graphics Studio forum I happened upon a thread Cheetah RAID for Photoshop: What is wrong? (http://www.macgurus.com/forums/showthread.php?t=19970)

TZ
03-28-2005, 02:37 PM
I'll let others evaluate Photoshop performance area.

PhotoShop FAQ (http://www.macgurus.com/forums/showthread.php?t=19792)
PS Benchmarks Discussion (http://www.macgurus.com/forums/showthread.php?t=19688)
Guide to Photoshop Performance (http://www.macgurus.com/guides/photoshopguide.php)
Photoshop Test Utilty (http://www.macgurus.com/forums/showthread.php?t=19746)
Photoshop FAQ Index (http://www.macgurus.com/forums/showpost.php?p=79890&postcount=1)


NOTE: Adobe is waffling on the Ram/Memory issues for 2.5GB-plus work stations...if 100% Memory is not working optimally, as recommended above, try reducing down to a "safer" 80%, said Adobe's Chris Cox

# Cache Levels: Adobe is recommending setting this to 4 (for now because of an OS10.3.2/PS8.0 conflict). I generally set the Cache Level to 8 on newer machines.
PSD Troubleshooting (http://www.gballard.net/psd/troubleshootpurgepsd.html)


For Photoshop on PowerMac G5’s, we recommend a minimum of 2.5GB of RAM be installed in order to maximize Photoshop’s RAM allocation. This way, the operating system will not suffer under a "100%" or a "75%" allocation to Photoshop. Recent studies have shown that loading a G5 with 4GB of RAM provides about the maximum possible benefit. Beyond 4GB the cost/benefit ratio for Photoshop acceleration quickly deteriorates.

#10: For advanced users who have implemented a separate two or four-drive striped RAID array for Photoshop’s scratch disk, an additional speed boost is obtained by saving the image file to disk at the same volume location used for the scratch disk. This is commonly known as the "work disk/scratch disk" method.

... SoftRAID offers settings optimized for specific applications or workflows, including Photoshop.

Performance of Photoshop CS is actually about 7% faster than Photoshop 7
Photoshop Guide (http://www.macgurus.com/guides/photoshopguide.php)

Question:
Does the UL4S have the latest firmware, and driver, as well as running 10.3.8 on an otherwise clean stripped down OS X system?

Is your RAID partitioned? optmized for PS?
(You would need SoftRAID 3.1.x for this)

Do you copy the file to the RAID first before working on it? From my read of the PS Guide, that helps some.

Also, what one person found, suggests to that one fast 15K drive (now that they are in the 89-98MB/sec ballpark) might suffice.

SATA does give good performance - and Raptor or DM10 seem about even in performance - my hat would go to the 10K Raptor. with its TCQ. I think the future for most users is 4-channel SATA-II controller and drives.

speters1
03-28-2005, 02:59 PM
I guess maybe my issues got confused by putting them all in one post. That is why I started the thread asking if the "Cheetah 15k.3's was still king" for RAID. You put that post into this post. Me wanting to get over 300mb/s has everything to do with that post, and nothing to do with this post that started out about the problems with my 6 Atlas drives. I was not complaining that I could not get over 300 with those drives. When I discovered the problem, I posted that.
Every time I asked a different question, you put it in here. This is why this thread has gotten so messed up. I try to give as much info as I can when I am reporting problem. If I figured something out, then I would post that. I figured that maybe there where some simple answers to some of my questions. Maybe some on has had the same issues as me.
I am not sure how I cut corners, because I bought my Atlas 10KIII drives several years ago, and now there is something faster? I am using Granite terminators and ATTO cables, and the Ultimate drive coolers. You tell me where I cut corners. Those 6 drives, when they are all working, are as fast as 4 cheetah 15k.3's.
You are right, I have been asking what is the fastest for the last two years, and obviously things changes, because now there is something faster.
I guess there is no reason for me to come back here, since I just keep asking the same questions, and cutting corners. So when I get 4 Atlas 15K II, I will just keep my findings to myself.
Thanks everyone for your help,
Steve

TZ
03-28-2005, 03:17 PM
Sorry you feel that way but I understand.

I have gone to great length I think to try to put this thread on track.

repeating doesn't help.

By "cutting corners" (you pick up and focus on what you see as the one and only negative comment>?) I see using 3-4 yr old drives (the 10K III was already prior generation in Jan 2003). It was more general advice for others, and for some other FAQs I am working on today - Photoshop, SCSI, SATA FAQ for the future.

But, did we sell you the Granite cables and terminators? I would not have any way of knowing that. But I do have and recommend Granite's cable tester (internal and the larger interface, not the VHDC 8mm cable).

As far as your six Atlas drives go. Correct me if I am wrong, but they seem to have been trouble all along.

You didn't like your MDD. You didn't like the UL4D. I think you tried a PC board and flashing it. Not sure which that was but I recall reading that. - Going back and seeing ALL of the questions and hardware "issues" or what could lead to it.

The fact that "updating to 3.1.3" caused trouble was not normal - and maybe 3.0.2 was different or buggy, or the drive was. When I update SoftRAID, I like to reformat the drives.

It seems like you are hear more for an education, which would be helpful, but don't know what to ask or do. All of the Todays Threads (http://www.macgurus.com/forums/search.php?do=getdaily&days=1) or the Troubleshooting FAQs and Guides (http://www.macgurus.com/forums/showthread.php?t=18533) are born out of trying to find and provide answers. When we don't, it reflects on us. But sometimes people offer suggestions that are off the mark or not on target. I try to get down to the hardware. If I had my way, people would fill in a Problem Report (http://www.macgurus.com/forums/showthread.php?t=20044) as first step to posting a question.

And almost all troubleshooting with Mac should start with testing memory to see that it is still working properly, until Apple starts using ECC that will always be an issue.

I know you'll be happy with those Atlas 15K IIs.

I hope you take the time to read the Photoshop Index (http://www.macgurus.com/forums/showpost.php?p=83687&postcount=6) along with the Guide to Photoshop Performance (http://www.macgurus.com/guides/photoshopguide.php) if you haven't. They will remain a work in progress and need to be updated for Photoshop CS2 over the months.

TZ
03-28-2005, 06:12 PM
Good information on RAID is here: RAID background (http://www.storagereview.com/guide2000/ref/hdd/perf/raid/index.html) from "The PC Guide" reprinted by StorageReview.