View Full Version : Linux variations

03-23-2001, 04:12 AM
Anyone have success installing a non-Mac OS on a drive connected to a Sonnet Ultra66 Tempo PCI card?

I just failed to install Yellow Dog Linux Champion Server 1.2.1 on an IDE drive in my PM7500. The YDL installer didn't recognize either of the drives on the Sonnet card. I've also discovered that the BeOS 4.5 installer fails to recognize IDE drives in this configuration

Both installers see only my SCSI drive on the 7500 native _internal_ SCSI-2 bus. I haven't done the grunt work of testing whether YDL or BeOS installers see a SCSI drive on the 7500 _external_ SCSI-1 bus.

Anyone know if YDL can see anything but the first SCSI bus?


my free 7500 is nickel and diming me to death.

[This message has been edited by ricercar (edited 23 March 2001).]

03-23-2001, 03:05 PM
I had heard that people were having good luck with the sonnett card and YDL. I haven't tried it myself, YDL's running on my other machine for now, but I had hoped to move it over. I'll run pdisk on that machine tuesday when I get back, and I'll let you know the results...

04-05-2001, 12:54 AM
I am also having the same problem gett YDL and BeOS to see my IDE drives on the Sonnet ATA card. Pdisk will not see these drives. As for BeOS, unless they have recently added IDE support to the OS, (which I doubt, since trying to get any kind of answer from Jean-Louis and Cie. is tatamount to have several root canals performed on the same day.) probably will never happen.

04-05-2001, 01:01 AM
ricercar (or is it recicar?(recicar is an ancient dance that originated in either France or Italy. I don't have my copy of Donald Jay Grout's History of Western Music here, so I can't be sure)),

I installed YDL on my exteral SCSI drives connected to my 7500 with no problem. Ditto with BeOS v.5 before I started looking at YDL. What is driving me bonkers is that I have a small partition with MacOS 8.6 installed (since BeOS won't work with Mac OS 9.x.x) on one of my IDE drives, and installed the BeOS Boot Launcher. I can launch BeOS here no problem, but I still can't see the IDE drives.


04-13-2001, 05:50 PM

Could you give me a blow-by-blow account on how you installed Yellow Dog Linux on your machine at work? I have attempted to partition one of my IDE drives connected to my Tempo card with pdisk, but still can't see the card. What did you have to do in order to partition for YDL?


08-16-2001, 01:10 PM

This may be a bit esoteric, but:

1.) Are there Linux emulators for OSX (i.e., for running Linux apps in OSX [in particular ColdFusion and a decent relatational db])?

2.) Has anyone tried getting Apache (the web server) to run in OSX?

3.) In particular has anyone tried the above with the new iBook?

I am a web developer who has had to deal mainly with NT over the last couple of years (other than a couple of gigs with Solaris)...man, I tell you, if I can get OSX to do what I need done...boy, boy, boy!!!

OSX may steal the limelight from Linux and _truly_ be the way that Unix gets to the desktop!!

Thank you in advance for any info!!


08-16-2001, 08:54 PM
1.) No Linux emulation, but I assume you're more interested in running X Windows (XFree86) and Open Source programs like GIMP. If that's the case, check out XonX at http://www.sourceforge.net/projects/xonx

2.) OSX includes the Apache Web Server. Just turn on Web Sharing to start it.

3.) Yes. The iBook works with all of the above!

Good luck!

08-18-2001, 11:49 PM

Thank you very much for the info...at this stage I'm probably going to continue using my 'legacy' Macs for the graphics and the like (until Adobe, Quark, MotU, and the like commit more completely to OSX).

What I am particularly interested in is OSX as a web application platform...I really like ColdFusion for its RAD (Rapid App Dev) environment, easy database connectivity, and security and communications implementations. I have also developed apps with 'asp' (which I don't like) and a bit with Perl (which is way cool and powerful, but I like giving clients apps they can relatively easily learn to maintain themselves). Solaris is really cool, but very expensive (at least on the Sparc hardware side).

Frankly, I am genuinely excited about the potential I see in OSX as a new, powerful, and easily maintainable server platform (granted it's built on BSD, which is not new, but the spin that Apple brings to the fray is very refreshing).

Anything that can be brought to the market as a cost-effective alternative to 'Redmond' is good for the industry...

Thanks Again!


08-22-2001, 01:26 PM
I really didn't know where to post this question, so I decided to post it here.

Not that you have to know why to help, but here's my reasoning for the following question http://www.macgurus.com/ubb/Forum18/HTML/000092.html

-I think I know what images to download for Red Hat's Alpha-Linux, but I'm wondering what's going to happen when I download the images when they're unzipped (they're assuming that this will be done via a PC, so I'm using PC jargon). IF they're just disc images, I can go ahead and burn a ISO 9660, but if they require compiling, I think I'd be screwed and have wasted 20+ hours of downloading (unfortuantly I only have 56K dial-up)

I'll be using Toast to burn the disc
However, I haven't burned a ISO 9660 disc that will be used on a Alpha-NT Workstation.

Is there anything specific I need to be aware of?

I apologize for this being a very vague post. But if there's any Linux users lurking around here, they have a chance to really shine (hint, hint, hint)!!!!


"I made a conscience decision in a semi-conscience state"

08-22-2001, 04:06 PM
They should be ISOs.

I d/led RedHat for Intel, and burned the images with Toast, and all went smoothly. One thing I would do is copy EVERYTHING you d/l, so if you flarf the image somehow, you've got a fresh copy.

I've also used Toast to burns Solaris images, and if those work, anything should.

08-22-2001, 06:05 PM
thanks chris. It seems that anytime I have a question about this Alpha machine I'm trying to get up and running, you're the only one interested. Wow, you've burned Solaris Images and they've worked?

Sweet, that means that I can finaly get Star Office working on my Linux PC.


"I made a conscience decision in a semi-conscience state"

08-22-2001, 09:36 PM
Chris is right. ISO files are automatically supported in Toast. Just drag the ISO file into the Toast window and burn. Likely the resulting CD will be in 9600 format, but it doesn't really matter. It's the image that's burned, not the format.

Netatalk will be a different story. Current versions of the Linux Kernel have built in support for AppleTalk networking, although you may still need to install Netatalk. This will be a compile job. Don't stress too much about it though. Just print out the HOWTO and follow the step by step instructions. Then if you run into a brick wall, come back and ask about it.

10-05-2001, 12:50 PM
Hi List. I am trying to help a friend of mine :
G-4 Dual 450, IDE Master HD : Maxtor 30GB 'Stock', OS 9.0.4 , Apple HD drivers, HFS standart
IDE Slave HD : IBM Deskstar 60, came new with OS 9.2 , maybe a factory installed rescue Syst
folder. ( it was sealed )
I have formated this IBM with FWB's HDT 4.0 ( quick, HFS standart ), and partitioned
( tot. 6 ). BTW low level would take some 40 hours...
Then made on this Slave HD a SW restore with Restore CD Software that came with the G-4
on the 5. partition.
Trying to boot from the slave ( configured in startup Controlpanel and Sys Folder blessed )
goes wrong, the Master HD starts up.
I can boot though with *shift+option+command+delete* the Slave HD.
I didn't change the jumpers of Master/Maxtor HD, only configured the Slave/IBM
to Slave Modus..
We would like to use FWB drivers, to be able to change partition sizes later, and because of
'Device Copy' !
Any prefs that have to be trashed ?
Please respond as well to my address below privately.
Thanks a lot and best regards

10-06-2001, 03:10 AM
While Apple's drive setup does not have partition size adjusting, Apple does support device copy. It's actually quite easy! But first¬Ö Why Standard HFS? Any drive over 2GB should be formated in Extended HFS. Otherwise the block size gets way out of bounds!

To device copy any drive to another drive equal to or larger than the contents of the original:

1) Boot MacOS CD (8.6 or newer)

2) Locate the application Apple Software Restore located at:
Software Installers:Upgrader Files

3) Drag the original drive to the Apple Software Restore icon.

4) Select Destination disk if not preselected in lower portion.

5) Verify that Erase before restoring is selected in middle portion.

6) Click the Restore button.

Let it do its thing! This technique exactly duplicated the original drive restoring all icon and window positions as well as aliases!

10-06-2001, 05:17 AM
Thanks a lot, Lasvegas
HFS: This thread has been discussed in our Forum motu-mac, and even motu didn't
find any benefits in performance for an audio / midi workstation, so I kept
compatibility with older hfs disks...
The software restore with an existing device via installer cd is good news for me.
But what could be the source of the mentioned boot problem, this is my main
question. Should I gtrash some / which prefs ?
Best regards

10-06-2001, 04:05 PM
BTW - low-level formatting is NEVER needed unless you are changing the Block size of the drive. I have seen this mentioned several times as a possible 'fix' for some drive ailment on various threads here and elsewhere (& PC forums as well).

from the manual for FWB 4.5 hdtk, pg 276 (pdf)

"Blocks are logically created on a disk during low-level formatting. Blocks are the minimum storage unit to which data is saved. HDT can change a disk’s block size to your specifications when it performs a low-level format or when you create a new volume from unallocated free space (if the device supports block size changes)."

Perhaps some mega-Gig file sizes will have improved throughput results with larger blocks. Certainly off this topic, but I've not seen anyone rec this even on forums like Adobe's Premiere forum, for example.

I've even had some 'pros' confuse this with a Surface Scan...definitely not the same thing. Though, a surface scan can, theoretically, be a good thing to do.
I'm not even sure if a surface scan CAN be performed on a Mac. http://www.macgurus.com/ubb/eek.gif

Mixing brands of hard drives...not necessarily a good thing...
Perhaps this is not relevant to your problem or the Apple implementation of onboard EIDE support on recent macs.

However, I more than once, in the peecee world, have had different brands of EIDE (ata/33, 66 et al) hard drives NOT coexist well at all on the same EIDE controller; let alone on the same cable.

Sometimes a drive wouldn't show in the BIOS during POST, other times the Windoze System control panel wouldn't show one of them. Usually, an IBM 75 or 60gxp was involved and invariably, always showed up. My last experience a couple months ago had a Maxtor drive playing 2nd fiddle to an IBM 60gxp. Of course, improper master/slave configs can produce this result...and that is what you hope for if a drive doesn't show up as it should. http://macgurus.com/infopop/emoticons/icon_wink.gif

Historically, there have been caveats in the peecee world (Dumb Operating System) about problems when mixing hard drives from different manufacturers. My experience has been that 'most' will mix together well.

[This message has been edited by DHB (edited 06 October 2001).]

10-06-2001, 10:02 PM
You cannot low level format an IDE drive. This is not a feature of the mechanism. I've known of people that tried to bypass the protections and write a low level format anyway, but I've never known of any drive that survived the attempt. If your driver software offers low-level formatting, it's actually doing a media verify only.

Did you make sure that OS 9 is installed on the lowest partition of the Slave drive? While Linux and OS X will boot from higher partitions, OS 9 needs to be in the first.

10-07-2001, 01:07 AM
Thanks for replying !
I used HDT 4.0 to quick format. But I installed the OS 9.0.4 on this slave drive
on the 5 th partition. From Your replies I read this could cause the problem, which is, again :
Choosing the slave drive as startup volume in startup cp doesn't work.
But holding down *shift+opt+com+del* makes boot the slave drive o.k.
Otherwise no problems till now.
Maybe someone knows, if OS 9.1 or 9.2.1 can be on the 5 th partition on a slave drive ?
Thanks a lot

10-07-2001, 02:58 PM
Yes and no¬Ö If it is the only OS on the drive, and the drive is Master, it will boot from any partition. If the drive does not meet the above criteria, OS 9.x must be on the first (data) partition.

10-07-2001, 05:00 PM
Thanks a lot, Lasvegas
inthis case I could try exchanging the master/slave configuration between the
two drives ? Then, the new master would have the OS on the 5 th partition,
and the new slave would have the OS on the one and only partition.Right ?
TIA and best regards

10-08-2001, 11:15 AM
Just wanted to confirm, that everything works fine with the configuration I
mentioned in my previous post.
Thanks a lot and have a nice time...

02-17-2002, 02:58 AM
I've been transferring a floppy disk back and forth between this IIci and my 9500 all night (none of my Cat5 cables were long enough to do it via A.Talk) and now have Navigator 3.0.4 working like a charm while writing this (damn this is slow, I can write 3 lines before they show up in the box!!!).

Anyways, I was wondering if any of you Guru's were running "Potatoe (or 68K if you prefer) Linux" on a IIci.

I have a 750MB drive that I'd like to replace the 500MB drive with, however, I'm not sure how to create a System 7.5.5 Boot Floppy and was wondering if any of you older (I mean no disrespect) Guru's might be able to give me a hint.

I thank any replies in advance!


"I made a conscience decision in a semi-conscious state"

02-17-2002, 06:35 AM
Download the PowerMac 7500/8500 Disk Tools (http://download.info.apple.com/Apple_Support_Area/Apple_Software_Updates/English-North_American/Macintosh/System/Other_System/PMac_7500_8500_Disk_Tools.sea.bin). This will create a System 7.5.3 boot disk with Drive Setup and Disk Firstaid. The disk also contains an enabler for the 7500/8500 that you can dispose of. Your IIci predates the computers that required "enablers" so this disk should work fine for you.

02-20-2002, 03:26 PM
Well, thanks and no thanks -vegas!!! http://macgurus.com/infopop/emoticons/icon_biggrin.gif

Even after I tossed the "701 Enabler", I couldn't use the disk to boot from <BLOCKQUOTE class="ip-ubbcode-quote"><font size="-1">quote:</font><HR>This Startup Disk doesn't work on this computer. Use the latest Apple Update to install System Software<HR></BLOCKQUOTE>

I know I can make a bootable CD, (I downloaded all of the System 7.5.3 and 7.5.5 "images" from Apples ftp site) but trying to install 7.5.3 on one of my extra hard drives (I don't have my external, Red Baron-case finished yet http://www.macgurus.com/ubb/cool.gif ) the installer locks up about 2/3's of the way through.

At least I burned a disk. Unfortuantly I was a moron when I backed up all of the data and applications from the whopping 250MB drive in IIci. I burned Mac Files & Folders in Toast (I was amazed that Toast v3.5.7 actually worked on it!!) because I didn't save as a disc image first.
So, now I can't install anything. Nor boot from my External CD-R/W drive (via the IIci).

If I could just install 7.5.3 onto my HD to make a 'minimal' boot floppy disk from, I'd be OK.

Any suggestions?


"I made a conscience decision in a semi-conscious state"

02-21-2002, 09:04 AM
Have you tried doing a Custom Install and select a minimal system for your computer and manually select the CD-ROM Extension as well. This should be able to be installed directly on a floppy.

Come to think of it¬Ö I'll send you a disk image of the 7.5.3 Disk Tools. This disk worked fine in my old //ci. Give me a day or to to find it though.

[This message has been edited by lasvegas (edited 21 February 2002).]

04-20-2002, 03:35 PM
If the applications I have now are not OS X - is it even worth running OS X?

I was reading something between bif and ricks - and it is making me think I should forget running non OS X programs in classic?

Right now I am both to cheap and broke to buy new programs. But I am adding as few small freebies into OS X.


04-20-2002, 05:45 PM

There are so many free programs out there that you could spend the next 6 months downloading them and they'd have come up with another 12 months worth by the time you were done.

What do you mean there's no programs, what about Exploder, My fancy new browser is OmniWeb. You'd love it, so much nicer than Microshaft, no caomparison. OmniWeb will allow you to use it for free, it's guiltware, I went ahead and paid the license fee, it's that good. (BTW, OmniWeb was around back in the Rapsody days and was one of the first developers to crowd Apples Developer meetings to write for OSX. Wonderful product. http://www.omnigroup.com/

Just spending your web time in OSX will keep you learning its little tricks and treats. There are free photo editors (see OpenOSX and GIMP for OSX) many, many free useful audio programs, like iTunes and a bunch of third party shareware titles. Everywhere you look you'll find great stuff to try.

I spend at least 2 or 3 hours a week searching the data bases on OSX downloads. Virtually every night when I go to bed I leave a list on OmniWeb of the downloads to do that night. (I have a very slow connection, takes a while to download anything, Toast Titanium for OSX took from 11:00 at night to 10:45 the next morning)

If you run out of things to do let me know, I'll find you something (Yes, daddy) http://www.macgurus.com/ubb/tongue.gif


04-20-2002, 07:38 PM
Mozilla is the fastest at loading programs. You can run OS 9 under Classic and see if they run as well or better - using a trimmed down set of extensions etc.

Yes, it might be expensive buying and upgrading. Then there is the hardware upgrading. Or books. But if you have the time to experiment and test, I would. I bought all the firewall programs, but other than a couple great shareware pieces that I felt deserving and indispensible, I'm only buying hardware.

For $75 you could play with Linux which comes with a lot of programs and open source. I expect to buy OS X 10.2 so I have a full - not upgrade - CD. And that is when I think OS X will be 'ready' for prime time, more optimization, if they can get better installs and support or compatibility (even new G4s have issues), we'll all benefit.

I spent a pleasant week not using OS X and OS 9 does all I need. But I can't be scanning and doing three other things smoothly.

04-22-2002, 10:15 AM
I've really put all my cards on X at this point. I got away with no hardware upgrades/flashing. ATTO card has been great. I'm preparing to buy a nice Epson scanner- just waiting 'til they get the driver done. My Epson printer worked fine immediately with 10.04.
I'm waiting on only one app- Portfolio- to go carbon, and then it's bye-bye Classic which I rarely boot at all since getting PS7, Painter 7, Canvas 8, Eudora for X (I must confess though I really like Mail better at this point), Graphic Converter, Appleworks, iCab for X, Interarchy, OmniWeb, Mozilla, Opera, FontReserve...
And all these great utilities: ASM, CarbonCopyCloner, SNAX, SuperGetInfo, Skeleton Key, XOptimizer, TrashX, MacJanitor, DeLocalizer, and on and on. I've got the full war chest, 9/10ths of which I don't really need!

Since Apple updates have been fast and furious, and we're all waiting on SoftRAID, I decided to maintain a conservative setup of 1 main volume with everything on it, a scratch disk, a striped work disk, and a firewire backup drive. About once a week, I clone my entire startup drive to the fw, and more frequently drag copy various folders for backup to the fw. I haven't settled on any particular backup utility yet- not necessarily keen about forkin it out for the Retrospect update...

I decided there was no need to move my home folder off my startup volume, as I have a complete and perfect bootable copy always ready..It was a nice speed bump to locate users on the apple stripe, but why play chicken with a freight train?

My future plan if I can work out the installation, is 6 internal drives in the QS: a hardware-striped ide startup volume, an apple-striped ide scratch disk, and a softRAID striped scsi work volume, all backed up to fw.
I think all the doubling up of the Applications folder and so forth has turned out to be a moot point..I'll get my app speed backup with a hardware stripe of startup volume. Though really by opening all the main apps and then hiding them, they're accessible instantly- especially with that command-tab and command-shift-tab dock navigation. I figure I'll take Apple at their word on the memory management. IT shouldn't matter how many apps you have open.

Mac OSX: The Missing Manual has really taken the edge off learning this thing. It's a delight to read and you can pick a page any page and just go from there.

Looking forward to 10.2, I'd like to see more help in Help, a better printing dialog, more control over internet connect (this machine insists on being online always!), but really my complaints are minimal; X is such an advance on classic, there's just no turning back..

Well that's my first rant for the day!


[This message has been edited by gmidd (edited 22 April 2002).]

04-22-2002, 10:44 PM
Rant Part II:

As far as 3rd party drive utilities goes, I'm not going to bother anymore til I can put a bonafide cocoa or at least an advanced carbon version of DW and Norton on my backup drive. I know TZ, you've given Systemworks I think a 2 out of 4- maybe I'll try it if I can get it for cheap..
I just fsck -y on every restart and haven't had any problems since I quit booting 9 and running DW, NU and always getting 'bad blocks' and all kinds of minor errors and this and that and so on- I mean what a pain when its a dubious analysis of problems that may or may not be problems...


04-22-2002, 11:42 PM
I'm with you George, No More OS9! I am nineless. Since TZ and redress turned me on to VueScan I now have virtually full functionality. Well, sort of, since VueScan doesn't support Canon scanners I get some weirdnesses from it, like inverted colors on black and white scans, and some others, all in all better than dropping into OS9 any day.

I have run DW off the DW disk, it helped a thrashing I gave an index by having a loose cable on a IDE drive that was my boot disk. IDE does not handle being unplugged mid-session. Not a great way to amuse yourself.

I haven't been running fsck, I'll start. Until the full versions come out I ain't spending money on each crippleware beta utility that surfaces. No way to tell until later which are worth owning.

BTW, Photoshop7 is the screamin daemon it was supposed to be. I love its controllability and speed. So far the ideal upgrade, at least with what time I've had to try it out.

A good evenin' to ya all.


04-22-2002, 11:59 PM
I took my entire 60 gig drive and made it all OS X - except a small OS 9 boot. Rick, I went out to cnet, apple, and such... and such and found a lot of my software in OS X - enough to move over a lot. Boot up in it each time. http://macgurus.com/infopop/emoticons/icon_smile.gif

Helped a friend tonight - backup, initalize made 2 partitions one with OS X the other OS 9.2.

Ya Hoo Later http://www.macgurus.com/ubb/tongue.gif

06-25-2002, 04:42 PM
I've tried partitioning my iBook internal drive so that I get:

Mac OSX format HFS+, Mac OS 9 HFS+, SuSe Boot HFS; SuSe Swap A/UX; SuSe Root A/UX.

This has never really worked. I would expect 5 partitions but end up with 12 or 13. I've never had Mac OS X run successfully & to date Apple has had me twice re-initialize the drive & write zeros to it. Last week, the drive wouldn't boot after migration to Mac OS 9.2.2; iBook got sent back to Apple and Apple installed new 10 gig internal.

The default position from Apple is, more or less, "installing Linux" or "partitioning" screws everything up. I notice they sent it back to me with a single partition, Mac OSX and OS 9.

Has anyone tried partitioning using Intech's Harddisc Tool Kit? What is causing Apple's DiskFormat to create 4 or 5 extra partitions. (This can be noticed when setting mount points for Linux. Thus, I might see something like: hda/8 HFS+, hda/9 HFS+, hda/10 HFS, hda/11 "/" (if remember correctly.0

The alternative is a dedicated Linux hard-drive. Is that a better idea? Or instead of new dedicated Linux hard-drive, I built a Granite Digital/IBM 120 GXP and could partition it into 4 partitions: SuSe swap; SuSe root; SuSe boot; iBook backup; iBook OS 9.x.

I'd loose a portable Linux box, but that might not matter so much.

Any advice or experiences about successful partitioning will really be appreciated.



Richard Moss
Law School, Uni District Columbia
4200 Connecticut Av., NW
Washington, DC 20008

tel: 202-415-6801

06-25-2002, 05:28 PM
I'll jump in but it's been awhile and haven't tried with the latest SuSe 7.3 version. The "extra" partitions are normal. 10GB might be a little small though - OS X 10.1.5 and 9.2.2 on 4-6GB as one volume (or two) would allow you to stay under the total of 11-12 partitions. See www.MACOSXHINTS.com (http://www.MACOSXHINTS.com) with a tidbit on the issue.

The YAST ? installer ought to let you walk through and take one hfs volume created with Drive Setup and break it up for use by SuSe. Disk Utility (part of OS X) should also let you partition. You don't need Intech but 3.5 should be safe. FWB HDT 4.x use to be recommended and included iwth the last LinuxPPC distro. However, I'd stick with Apple's driver if possible.

Do you have the ability to boot from FireWire? Are you saying that you could use that for OS X and 9.2?

OS X really likes to have 256MB (512MB better) for even 'normal' use, G3/450 seems a little better than G3/300 was.

Apple does not have a position regarding partitioning that it would 'screw' things up, only that it is easier for them to master a drive rather than deal with partiitions. Most people I know take any drive and partition, reformat, etc.

Did you create an HFS volume(s) to then use pdisk or whatever SuSe includes? There is a lot of online help, and SuSe tends to have good manual and documentation.

Apple's OS X is based on Darwin, has a lot in common, and "triple boot" of Linux, OS X and OS 9 are definitely doable.

06-28-2002, 02:01 AM
Thanks for your advice & the pointer to hints.com. The thread was kind of over my head & I had thought the threshold for trouble was well below 15 partitions.

SuSe's PPC installation protocol asks you to create partitions prior to using YAST2, a graphic iteration of YAST. SuSe's manual corroborates your point about older, SCSI drives needing to be set up with FWB. fdisk is noted only in passing & in this context: if you want to install on a disk not recognized by "drive set-up" then you may use fdisk, but you will not be able to boot the MacOS.

At 2.2.1 (p 18 Linux PPC 7.1) SuSe says "We recommend that you install SuSe on a separate disk."

The FireWire has proved much more stable than the iBook's internal drive---or maybe I should, a single partition FireWire with only 9.2.1 has proved more stable. In fact I usually do boot from it and out of law school paranoia mirror or synch data files between the iBook and the Firewire.

So I was thinking rather than iteratively repeating the hassle over formatting and partitioning, I added another Firewire or USB drive dedicated to Linux. I should, given your comments, check on SuSe's knowledge bases if both protocols are supported.

A lot of this is about redundancy, wanting to learn Linux, and avoiding a purchase of Photoshop by using GIMP without being dependent on consistent behavior of OS X. (It might be much, much better than it was at OX 10.0.3 and 10.1). Another approach is buying the Linux Kit for SONY PlayStation 2, which gets me a USB keyboard and mouse, ethernet card, monitor cable, and whatever Linux for PlayStation 2 is.

I think the marginal difference in cost between going the PlayStation way and an extra FireWire with a firewire hub will around $150, which looks awfully good if were to loose a month's use of the iBook while Apple shipped the wrong keyboard & installed a new drive, new sub-assembly, and new cable for the 802.11 card.

(Obviously, I'm not happy with Apple's build quality on the first iBooks or with any tested to date iteration of OS X. I'd love to know if I've an especially low tolerance for disruptions, prone to complaining, or if my year with the iBook is fairly normative.)

If this has gone on too long, my apologies & again thanks for indicating ways I could approach installing SuSe Linux.

06-30-2002, 12:53 PM
Hello all,

Not sure if this is the proper forum but, is anyone running Apache from their OS X machine and either using it as a web server or a development platform for web development. If not, you still might be able to help. Ultimately, I'm seeking to find out if Apache 2.0 can be installed without causing problems in X. Does anyone know if Apple has, or has had anything to say about this.

I read somewhere, and I do not remember where, that MySQL can be set up on a X system and be a self-contained database development platform for web development. Does anyone know of this or how it's set up to be done? I assume of course it is via Apache.

Thanks to all replys.

07-01-2002, 02:31 PM
I assume you are aware of a new Apache WORM that targets BSD, along with SSH needing to be updated. Apple responded to both over the weekend.

MySQL 3.23.51 (http://www.versiontracker.com/moreinfo.fcgi?id=10425&db=mac) seems to be one of the easier installs so far and was just updated.

There was a series of threads over on the XLR8yourmac BBS on installing
http://www.mysqlstudio.com/MySQL (http://www.mysqlstudio.com/)
Also, these threads on XLR8yourmac BBS:
mysql manual install (http://bbs.xlr8yourmac.com/ubb/Forum23/HTML/000187.html)
Nice PHP/mySQL based Forum (http://bbs.xlr8yourmac.com/ubb/Forum23/HTML/000183.html)
MySQL on OS X (http://bbs.xlr8yourmac.com/ubb/Forum23/HTML/000170.html)

07-01-2002, 04:47 PM
Just to update,

Review of books on administering Apache on Linux:

General info on upgrading from 1.3 to 2.0:

New Features in 2.0

O'Reilly MacDevCenter Apache Series Articles:

O'Reilly - Guide to Installing 2.0 (March 2001)

Migrating from Apache 1.3 to Apache 2.0


Apache Web-Serving With Mac OS X, Part 5
"Ah, it's one thing to have your Apache Web server fired up in Mac OS X; it's another to have it communicating with a MySQL database. Kevin Hemenway walks you through this process. Your life will never be the same! Mar. 8, 2002"

07-04-2002, 11:22 AM
Apple Discussion OS X Server (http://discussions.info.apple.com/webx?14@161.wFY7a5Wcc2a^13@.eeff4aa) - Web Services

07-04-2002, 11:38 AM
Thanks all! Keep um comin' if you gots more! Big help, so I just wanted to say thanks so far.

07-04-2002, 01:53 PM
I was curious and wanted to find out some links to help point in the right direction. It seems that the best discussion forum is Apple's OS X Server area.

The forum over on www.xlr8yourmac.com (http://www.xlr8yourmac.com) is down and has had trouble but some great people and good info on mysql.

Glad you found it helpful!

Garry Heaton
10-26-2002, 07:07 PM
I've just acquired an old 7100/66 which I'd like to use for testing web pages on my network. I use Linux for my development work so what do I need (software/cable etc.) to get the Mac connected? The 7100/66 has an AAUI-15 Ethernet card installed but my existing network uses 10/100 Ethernet.

10-26-2002, 11:43 PM
If you can a find a AAUI-to-10BaseT transceiver localy, it shouldn't cost you anything, or very little at the least.

I'd check any sort of continuing education place to see if some department has some stacked in storage collecting dust.

If you can't find one, try a ebay search. I picked up a couple when I got 2x Apple IIci's (for nostalgia) a couple of summers' ago.

Unfortuantly I didn't have the foresight to pick up more than just two, otherwise I'd send you one.

You can also just search for a NuBus e/Net card as well. Either way, as long as you have one or the other and have installed "Ethertalk", you just need to point your browser toward the (I'm assuming) Apache/Linux box.


"I made a conscience decision in a semi-conscious state"

10-26-2002, 11:44 PM

It also helps if you have a browser of some sort installed on the Mac as well.



"I made a conscience decision in a semi-conscious state"

Garry Heaton
10-27-2002, 06:31 AM
Some sources I've come across say AAUI-15 with transceiver only but another said if there is a NuBus slot available then a NuBus 10baseT card can be installed. There are 3 NuBus slots in this machine, according to the spec, though I don't yet know how many are free. Are NuBus cards cheap/freely available? I'll also have a look for a cheap transceiver. Another question: I can only find 2 memory slots but the spec on EveryMac says it should have 4. Any ideas?

10-27-2002, 09:59 AM

A page here http://www.lovemacs.com/products/nics.shtml with both NuBus Ethernet card new/used and AAUI transceiver to 10base-T adapter. Pricey, but it will show you what you are looking for. I preferred the adapter but you already have a NuBus Ethernet card.

Yes you have four memory SIMM slots http://www.macgurus.com/products/motherboards/mbppc7100.php plus 8MB soldered to the motherboard. k

10-07-2003, 08:34 AM
<BLOCKQUOTE class="ip-ubbcode-quote"><font size="-1">quote:</font><HR> ven worse, Microsoft's email software is able to infect a user's computer when they do something as innocuous as read an email! Don't believe me? Take a look at Microsoft Security Bulletins MS99-032, MS00-043, MS01-015, MS01-020, MS02-068, or MS03-023, for instance. Notice that's at least one for the last five years. And though Microsoft's latest versions of Outlook block most executable attachments by default, it's still possible to override those protections.


Unfortunately, running as root (or Administrator) is common in the Windows world. In fact, Microsoft is still engaging in this risky behavior. Windows XP, supposed Microsoft's most secure desktop operating system, automatically makes the first named user of the system an Administrator, with the power to do anything he wants to the computer. The reasons for this decision boggle the mind. With all the lost money and productivity over the last decade caused by countless Microsoft-borne viruses and worms, you'd think the company could have changed its procedures in this area, but no.

Register 10-7-03 (http://www.theregister.co.uk/content/56/33226.html) <HR></BLOCKQUOTE>

What's new on CERT -


The old and now, unfortunately, closed, Security FAQ is HERE (http://forums.macgurus.com/6/ubb.x?a=tpc&s=40160367&f=45260029&m=30060229)

10-07-2003, 09:03 AM
I am sure you saw this, but for anyone who has not, M$ will have to defend itself in court regarding security holes (http://zdnet.com.com/2100-1105_2-5085730.html).


Charlie Don't Surf!

02-21-2004, 05:47 AM

Linux servers become target of more attacks

According to british security company mi2g, Linux servers increasingly become a target for hacker attacks. The firm found that Linux servers were the most frequently hit, accounting for 13,654 successful attacks, or 80 percent of the survey total. Windows came in a distant second with 2,005 attacks. This study confirms recent warnings of security firms such as Symantec that the growing popularity of the open source operating system will result in a dramatic increase in attacks in 2004.

Full article: ZDnet News (http://news.zdnet.co.uk/software/linuxunix/0,39020390,39146776,00.htm)

02-21-2004, 08:28 AM
You may retrieve this story by entering QuickLink# 44942
ComputerWorld (http://www.computerworld.com/)

Security flaw in Linux kernel gets vendor patches
FEBRUARY 20, 2004

A security vulnerability in the Linux kernel that could have allowed a hacker to gain control of the operating system on user machines has been patched by the open-source community and Linux vendors.

In an e-mail today, Starzetz wrote that the bug affects all kernels from the 2.4 series to 2.4.24, all 2.2 kernels to 2.2.25 and the 2.6 kernel series including 2.6.2. The only kernels that are not vulnerable, he said, are 2.4.25 and 2.6.3.

Patches are being worked on for the 2.2 series kernel, he said. All the odd kernel releases including 2.3 and 2.5 are also vulnerable, but it's unlikely that many people use them because they are development kernels, not release models.

"The bug is very serious," he wrote, if an attacker gains local access to a vulnerable machine. On a scale of 0 to 10, with 0 being no bug at all, the vulnerability would be scored 10, or "the most serious danger we can imagine," he said. "Due to this seriousness we decided to delay the release of the exploit code until the next week (so that people who care about their machines have enough time to update them)."

The problem can only be corrected by upgrading a vulnerable machine to the latest kernel version, Starzetz wrote. "These are issues found by goods guys, reported responsibly and dealt with in the right way," Cox said. "It's just kind of a textbook example of how these things should work out." No reports of any attack using the vulnerability have been received, Cox said.

Patches have already been posted by major vendors, including Red Hat and SUSE Linux AG.

Last month, iSEC found and reported a similar but unrelated security vulnerability in the Linux kernel memory management code. Patches for that problem were also made available by Red Hat, SUSE and other Linux vendors.

Linux kernel Security Flaw Patched (http://www.computerworld.com/securitytopics/security/holes/story/0,10801,90359,00.html)

Copyright © 2004 Computerworld Inc.

02-24-2004, 06:35 AM
A Security Primer for Mac OS X
by Fran?ßois Joseph de Kermadec

The recent security issues that have affected Windows users have led the media--and sometimes even Mac-specialized publications--to talk about the shortcomings of the Windows security scheme and to provide surprisingly detailed advice.

An in-depth tutorial at O'Reilly's MacDevCenter takes a look at Mac OS X Security and techniques and applications that users can employ to make their Mac more secure.

In this article, I'll take a hands-on approach to what I call "security through common sense," the basic security steps that every single Mac user should take.

Published on MacDevCenter (http://www.macdevcenter.com/)

03-08-2004, 11:39 AM
Apple-X.net Attacked
Posted by: Trent on Mar 08, 2004 - 07:07 AM
SiteNews 508 Reads
We've been DoSed.

It appears someone has performed a Denial of Service (DoS) attack on this site.

You may have noticed, we even experienced a bit of downtime. We are unsure of the source of the attack, or the reasoning behind it. If anyone knows anything about this, please let us know ASAP.

The IP behind the attack was:

The attacker used a web spider similar to those used by Google, although this one had apparently been modified to ignore which directories spiders/bots are told to leave alone. It was also set to execute thousands of times, severally screwing up our statistics module as well as our ad tracking system.

03-18-2004, 11:19 AM
<BLOCKQUOTE class="ip-ubbcode-quote"><font size="-1">quote:</font><HR>SUSE unveils Linux versions based on 2.6 kernel - Its personal and professional versions will be followed by enterprise versions this summer

News Story by Todd R. Weiss

MARCH 18, 2004 (COMPUTERWORLD) - Fresh from its January acquisition by networking software vendor Novell Inc., SUSE Linux AG today unveiled its Personal 9.1 and Professional 9.1 Linux operating systems, which are based on the new Linux 2.6 kernel.

In an announcement today, Nuremberg, Germany-based SUSE said the two desktop operating systems will be followed by enterprise versions this summer.

The SUSE Linux 9.1 personal and professional editions include a host of performance benefits from the new 2.6 kernel, including improved threading and memory management and greater ease of use with both 32- and 64-bit processors, according to SUSE.

Both versions also include the latest Linux desktops -- GNOME 2.4 and KDE 3.2 -- so users can choose their desktop interface.

Also new in the personal edition is the SUSE Linux 9.1 LiveCD, which requires no installation and allows a user to boot a machine and try out a complete version of the operating system before installing it fully. A second CD with the normal install routine is also included. <HR></BLOCKQUOTE> SuSe stopped making a PPC version. I've run x86 linux on VPC 4.x just to check it out. I know there is YDL that is native. Would be interesting to show someone your Mac, have Linux, OS X, Classic, even Windows (just be sure to patch it or you've opened up your windows system to the same worms and security problems. However, this is a perfect way to test various operating systems or versions of the same, in a somewhat safe environment.

04-06-2004, 10:32 AM
I think accidentally just trying to boot from YDL 3.01 CD screwed up my Beige beyond ever getting it to boot from OS 9 now or Panther.

I know now that it messes wtih nvram. I thought that was fixed last fall as far as 10.2.8 and 3.0.

I tried on B&W and it didn't 'see' Adaptec 29160 properly. I tried on MDD but realized it would require initializing. They now want a ONE MB ("1") hfs partition for a boot loader. You can't even specify something that small on 80GB drive. A 9 or 18GB SCSI drive would be perfect. Small, great performance. But terrible with non-ATA.

They do support G5 - or so I read on Apple Discussions. I thought Beige, while OldWorld would be easy. And 10.3.3 seems to have messed up Sonnet Tempo's but Sonnet can't confirm ("What to do?" thread). 10.3.3 alone plays havoc. I thought this would be 'safe.' NOT.

SuSe Linux 6.4 was easy on my B&W. That was years ago and I skipped SuSe 7.x and they have never brought out another PPC build, so YDL seemed "natural." Now I have lots of doubts on that front.

I subscribed to YDL lists.

Panther on Beige was easier. http://forums.macgurus.com/infopop/emoticons/icon_frown.gif

04-06-2004, 06:21 PM
It does do things in the NVRAM... but I also think it writes som pretty primary boot OSROM file stuff into the harddrive... I have installed Panther on my Beige a few times and it failed... and I could not get into 9 after... SO I thought to myself "X.3" has written to my PRAM... so thinkin that a good ol' PRAM reset would do the trick I tried the cmd+opt+p+r to no avail... then I did a CUDA which also did nothin'... then I did a logic bd reset which also did nothing... so... I booted from a OS9 CD via the "C" key... then I ran XPF again and rebooted to nuthin' again (actually the /APPL,ROM attenpted to boot to OS9 but it appeared to get hijacked by OSX and it went to the Black Apple On White field with spining icon for EVER)... booted to CD again after a three finger forced restart... from the OS9CD ran disk ut and ZEROED the target drive (I run OS9 on one drive and X on another)...restarted to OS9 on the hdd no issue... SO.. the conclusion is that it does something to the NVRAM and the hdd..."boot" vs. "bye"...

EDIT: uh... so I think YDL might also do something to the PRAM and hdd... it does do a BootX thing...

04-07-2004, 07:08 AM
I've always found that just booting from Jaguar will also "clean up" and update NVRAM and whatever else has happened - a good 'cure all.' Ended up installing 10.2.8 on the drive I was going to use for YDL.

Looking over their support and problems with a more cynical and experienced eye, I can't see doing it.

The issue of having to have 1MB partition? BAsically impossible using Disk Utility or even Drive Setup. 32MB was the smallest on 120GB drive. 4MB on another.

I never even got to boot from a hard drive. I did get to install OS 9.2.1 - meaning I can boot from the CD, but that doesn't do anything and I mistakenly ran XPF from CD. That locks that up and had to force quit. Not good either, it might have corrupted more.

I don't ususally find zap pram useful, rather, use Open Firmware reset, the "init-nvram" is unique to just the Beige but works.

I don't trust or think YDL should be trusted with Open Firmware.

All I did was left YDL 3.01 CD in my system and system tried to boot from it. I also have two computers sitting side by side and forget which one I am connected to and working on at times. ;-(

Jaguar to the rescue!

04-15-2004, 09:25 AM
<span class="ev_code_red">Network Intrusion Detection (NIDS)</span>

<BLOCKQUOTE class="ip-ubbcode-quote"><font size="-1">quote:</font><HR> Attacks at universities raise security concerns
High-performance computer centers targeted

By Paul Roberts, IDG News Service
April 14, 2004¬?

Malicious hackers in recent weeks have infiltrated computer systems at universities in the U.S. and worldwide, leading to questions about the security of scientific research data, according to an official at the U.S. National Science Foundation.
Attacks at universities raise security concerns

The systems were located at universities and research facilities that operate high-performance computer centers, including facilities that are part of a project funded by the U.S. National Science Foundation (NSF) and called TeraGrid, said Sangtae Kim, director of the Division of Shared CyberInfrastructure at the NSF, an independent U.S. government agency.

Supercomputing centers at U.S. universities including the National Center for Supercomputing Applications (NCSA) at the University of Illinois at Urbana-Champaign and the Center for Advanced Computing Research (CACR) at the California Institute of Technology are partners in the TeraGrid project.

Systems at TeraGrid partner facilities were hacked, but no systems that make up TeraGrid itself were compromised, Kim said.

NSF does not know who was behind the attack, but believes it was part of a much larger action that affected high-end systems worldwide, including sites in Europe. Many of the compromised systems are connected to university research centers, he said.

Stanford University's Information and Technology Systems and Services (ITSS) group published a security alert on Saturday warning researchers about compromises of a number of systems running the Sun Solaris and Linux operating systems on the Stanford campus. The advisory also noted that the attacks were part of a move against "a large number of research institutions and high performance computing centers."

The university became aware of the intrusions after users noticed discrepancies in the time of their last reported log-in, which indicated that their log-in information had been hijacked. Other systems began performing poorly or reporting errors after the intruders installed so-called "rootkits," or programs that allow the malicious hacker to disguise his or her presence and gather information such as user names and passwords from the compromised system, the ITSS alert said.

Attackers gained access to the systems by cracking or sniffing passwords from insecure network traffic such as Telnet remote communications sessions or from password files on other compromised systems, according to the alert.

Once logged on to a system, the attackers looked for systems that were not up to date with their operating system patches, then used known software exploits to elevate their privileges from user to administrator (or "root") status.

Other systems fell to hackers because of loose security configuration for Network File Service (NFS), a way to share files and directories over networks or the Internet. Many institutions applied loose security to these shared directories to "facilitate the distribution of system management and data processing tasks," the advisory said.

The ITSS group recommended that compromised systems be taken off the network and completely rebuilt, with new versions of the operating system and up-to-date patches installed.

Universities that cooperate to conduct scientific research are particularly susceptible to compromise because of the open nature of their mission, according to Jonathan Bingham, president of Intrusic Inc., in Waltham, Massachusetts, which sells technology to spot covert and illicit activity on computer networks, which it terms "noiseless action."

"You've got large groups of individuals trying to access systems from all over world, so universities commonly have portions of their network set up almost like the Internet, in that access is wide open," he said.

Malicious hackers can easily gain access to less secure areas of a university's network, then listen to network traffic to capture the credentials needed to access more sensitive areas, he said.

While some experts raised the specter of massive denial of service (DoS) attacks using the hijacked supercomputers, the real threat to the TeraGrid project and the universities that got hacked is from stealthier behavior, such as quietly leaking sensitive research data or discoveries from compromised research machines, Bingham said.

While rebuilding and patching compromised systems will close the holes that intruders used, it is no guarantee that the malicious hackers behind the compromise do not still have access to the sensitive networks.

"Once they're in a network of this size and scope, they're going to compromise other systems using stealth techniques that are different from the ones they used to get in. Once you figured out (the compromise) and know what systems are vulnerable, they're already on a different system," he said.
Infoworld Security (http://www.infoworld.com/article/04/04/14/HNuniattacks_1.html) <HR></BLOCKQUOTE>

08-26-2004, 12:56 PM
I am venturing into the big wide world with a project that is going to be hosted on a dedicated server. I would have loved to have hosted this on one of my G4s but I don't think that I can get enough bandwidth for what I need to do. This puts me in the hands of a host and unfortunately I cannot use OSX to run it, it has to be Wi*£*ws (urrgghhh!!!), Debian, Slackware or Redhat.
I will be using vBulletin to run the guts of the project, but I don't know the first thing about Linux and have never used MySQL before either so this is going to be a huge learning curve.
But before I get into that I have to make a decision on the OS - any suggestions? The server will be a Linux Series 3.06+ HT RAID
1024MB RAM
2 x 120GB Harddisks running
Hardware Raid-1
HyperThreading processor
1000GB data transfer (yearly)
1 IP address
24x7x365 FREE reboots
Redhat / Debian / Slackware

So any constructive comments would be great, the server cost is around $120 a month based on a 1 year deal.

Thanking you in eager aniticipation!

09-06-2004, 12:46 PM
I have a g3 bw 300 running 10.3 on a scsi drive that is being hosted off a atto express psc card. I have 2 maxtor drives hosted off my firmtek one as a backup drive the other i plan on installing yellow dog 3 on. Now here my problem.

I begin the installation and everything is fine. I go navigate through certain screens selecting settings for the install and then i get to a screen which it asks me where i want to install my the OS. it only sees the scsi drive and not the sata drives. How can it see a drive hosted off a scsi pci but not a sata pci....can i install onto the sata drives?

I was thinking it would be easier to buy an ATA drive and just use that but i want to make sure im not missing something with the sata.

before you all tell me to go to linux boards, i want you to know i have been to 4 and no one answers me :mad:

09-18-2004, 05:24 PM
Believe it or not, just got around to installing YDL on B&W. It wouldn't install on my Beige and I'm letting it have at my 120GB drive all for itself. Maybe I'll add a 2nd drive for OS X on a host card.

It doesn't support ACard ATA, or Adaptec SCSI. It seems like they could do a LOT more to support other than native IDE.

I have an ATTO UL3S except that doesn't have any drives on it (did but I had to "borrow" the SCSI cable). Surprised the PSC works. Maybe they support old stuff only.

And here they are with YDL 4.0 and G5 64-bit version. Doesn't figure. When I tried on MDD, it would only see ATA.

So what you are seeing is what I am also, on three systems. Even MDD G4.

Perhaps somewhere in the newsgroup email digest is how to. Maybe there is an advanced settings tab during install to add a device driver for the FirmTek or something. But it isn't there. Even support for four button mouse is actually absent.

I'll be interested in Firefox, Thunderbird, file server for home, KDE.

I hope there are updates, and that it isn't too hard or complex. There is support for Ext2/3 filesystem under OS X now.

09-18-2004, 05:51 PM
Failed on restart.

Just "?"

Boot from Panther CD - nothing shows.

I know it messes with NVRAM and Open Firmware.
I did it on B&W instead of MDD... because I actually don't trust Terrasoft.

I also think they could do a better job with installer; with recognizing devices. What they seem to want is paid support services; or, to sell you a pre-configured ATA disk drive I guess.

So, no hard drive shows up. Not when on native IDE, not on ACard. So it sure looks like it totalled and destroyed one disk drive.
:( :( :( :mad: :mad: :mad: :( :( :(

09-18-2004, 06:52 PM
Failed on restart.

Just "?"

Boot from Panther CD - nothing shows.

I know it messes with NVRAM and Open Firmware.
I did it on B&W instead of MDD... because I actually don't trust Terrasoft.

I also think they could do a better job with installer; with recognizing devices. What they seem to want is paid support services; or, to sell you a pre-configured ATA disk drive I guess.

So, no hard drive shows up. Not when on native IDE, not on ACard. So it sure looks like it totalled and destroyed one disk drive.
:( :( :( :mad: :mad: :mad: :( :( :(

I gave up on it....when i get a machine down the line that isnt great and i use ata on the mobo bus then ill try to install again....but untill ive wasted to many hours on it....sucks i really wanted to get to use linuxs GUI

09-18-2004, 07:11 PM
I got the feeling it didn't talk to an ATA drive with 8Mb cache.
It didn't like or know my ViewSonic LCD (KVM could have prevented that).

It installed. I let it auto do its thing and went through 3 disks.
Wasn't even a shared Mac OS X or Classic.

I might try once more and see what happens with YDL CD.
For now, I am using 15K SCSI external drive(s) that "work."
- and are safe.

I too wished to. I didn't have any trouble with SuSE 6.5 on this machine years ago. I was saddened that SuSe dropped PowerPC (before OS X maybe there was more interest).

09-25-2004, 07:42 AM
OSNews link to Linux Status on G5 (http://www.ppcnerds.org/displayarticle176.html) it would be nice if the news was better, and that support for graphics, SATA and wireless was there - it isn't really though.

Yellow Dog Linux v. 4 (http://www.yellowdoglinux.com/products/ydl.shtml) is worth consideration of course.
Terrasoftsolutions (http://www.terrasoftsolutions.com/tss_home.shtml)


11-14-2004, 01:18 PM
I'm getting ready to go with (4) X15 Cheetah's on a UL4D in one of those cewl Guru's enclosures, but first a couple of ?'s for the SCSI Gods:)...
Do the UL4D's still need to be flashed in something other than a G5 to have the latest firmware? Has anyone been successful running softraid0 on Linux in this type of environment?
Tanx, Tom

11-14-2004, 01:34 PM
Most UL4s out there now can be updated in OS X - assuming you didn't go the ebay route you should be fine.

I assume you are thinking of YDL 4.0? I've never been impressed with their support of hardware and especially of SCSI in 3.x. SuSe was much better and easier to use.

By software raid or SoftRAID? After all, SoftRAID is a product. And you would have to ask but I don't think they do. Does linux support stripped RAID? yes.

Sounds like you'll want to subscribe to YDL email digest just to evaluate where they are at in support etc. unless you are favoring another distro.

11-14-2004, 02:22 PM
Thanks TZ. Nah, NO EBAY for my G5!...Good News.

Yeah, YDL4 and Gentoo PPC64 with Softraid the product , unless you know of another product out there that would work.

So far looking at the YDL lists hasn't turned up anything definite. It does look like the Softraid product did have support for Linux in previously released versions. :(

With their current release they claim that they donot currently support Linux, but from experience I know that some creative people work out ways to do things that software co's don't allways want to make for public consumption.

I imagine this setup would SCREAM in GentooPPC64 w/its low overhead.

Anyway, thanks.

11-14-2004, 02:39 PM
When I read the information @ SoftRAID.com, I read that as a "no" or "alongside" or "inspiteof." you can use EXT2/3 volume support in OS X. And there is OS X support in YDL4. I think you can use pdisk or command line in linux.

You might find some useful stuff here (http://linas.org/linux/raid.html) Linus.org RAID if you hadn't already.
Or, Linux RAID (http://www.ram.org/computing/linux/dpt_raid.html#toc3)
How to use multiple disks (http://www.nyx.net/~sgjoen/disk.html)
SuSE: RAID How-To (http://www.evotegra.com/root_raid_howto.htm)

11-15-2004, 01:20 PM
I have a G4 tower that I want to run NetBSD on to serve up some web. Has anyone tried using the SeriTek/1S2 PCI host card for SATA drives on any OS other than Mac? Anyone think this would work?

11-15-2004, 04:46 PM
I think you'd have to ask FirmTek about that one. Even Darwin (based on 10.3.2 and now at v. 7.2.1) doesn't install to SCSI drives, even though it 'says' that it supports any hardware that Panther supports. Yellow Dog 4.0 supports G5 so it has some support for SATA. Take a look there. When I tried YDL 3 on my B&W it didn't see SCSI controllers. Odd, becasue years ago I had no trouble with SuSe 6.5. I did try NetBSD or something on VPC 4.x though.

11-15-2004, 04:49 PM
Another throught is to give Open Darwin 7.2.1 a shot and see where it is. I can tell you though that it didn't support Adaptec 39160 in B&W :( So I popped an ATA drive on the native bus, which it is happy to use, but *I* am not. However.... it is installing all the drivers that you had with 10.3.2 (ATTO 2.04 which is old and minimal - 2.05 was posted days later, 2.1.x is for Jaguar now, and Panther needs 3.10 or later (3.20 prevented waking from sleep so that is buging me, if not ATTO). So it seems you have to install to ATA/SATA and then see about building and accessing a RAID. Which is where it would be nice to install and use EXT2/3 in OS X so you can access files in either OS X or Linux.

11-20-2004, 07:48 AM
All things linux.

11-22-2004, 09:05 AM
For tip on burning YellowDogLinux ISOs


As a side-note, I found that my B&W w/ Adaptec 39160 allowed me to target YDL 3.01 to use my SCSI drives. When I had ATTO UL3S, they didn't show as available target drives.

12-10-2005, 10:24 AM
- I've spent two days at least, trying to get SuSE linux 10 installed and working. But it isn't creating and configuring the Mac boot loader, probably didn't get much testing. Just to see and have another OS to choose from and see how well it compares, and how well Firefox runs on it. It requires a 40MB partition. But tiger won't let me setup a partition smaller than 1.4GB! YDL4 amost installs and runs, but it too needs a small 1MB partition, even harder to create (unless I go with doing it "by hand" in the terminal or something).
the only way I even got SuSE to partition properly was to use disk utility to set up a drive as one large MS-DOS style partition and then it was able to create and resize partitions - except for the Mach_HFS partition. I don't see a way to have both DOS/Windows along with HFS+ on the same drive.

I tried leaving a drive free of partitions. I used SoftRAID 3 to delete all partitions. YDL4 will format it okay, then tried to edit the partitions in SuSE.... a lot of time spinning my head doing little to get either installed and running.

And SpeedTools which may have a PC Drive tool, doesn't even recognize the existence of SCSI drives at all, so that was useless.

Funnily, these were things that are easy to do in OS 9.2 Drive Setup, but I don't have OS 9 partition anymore. And I'd have to format another drive to use it.

All in all, though, SuSE 10.1 A3 looks very promising and I like its ability to do an Automatic Repair of your system, reinstall components and such, resize or edit partitions.

Before you install:

From the developers:
OpenSuSE Beta PPC Forum (http://www.suseforums.net/index.php?showforum=66)
*PPC Known Issues* (http://www.suseforums.net/index.php?showtopic=18092)
How to Install and possible issues, workarounds

Install Guide FAQ (http://www.suseforums.net/index.php?showtopic=18000&hl=)
OpenSUSE PPC Resources (http://www.novell.com/products/suselinux/)
Booting on PowerMac (http://www.opensuse.org/Booting_on_PowerMac)
PPC Partitioning (http://www.opensuse.org/PPC_Partitioning)
PPC Installation Issues (http://www.opensuse.org/PPC_Installation_Issues)
Most Annoying Bugs (http://www.opensuse.org/Bugs:Most_Annoying_Bugs)
Power@SUSE (http://www.opensuse.org/POWER@SUSE)
Released Version Mirrors (http://www.opensuse.org/Mirrors_Released_Version)
What's New (http://www.novell.com/products/suselinux/whatsnew.html)
mac fdisk (http://penguinppc.org/bootloaders/yaboot/doc/mac-fdisk-basics.shtml)
IBM SuSE Software RAID (http://www-128.ibm.com/developerworks/eserver/library/es-conf-swraid/)

Reviews, Downloads, Books:

SuSE 10.0 CDs $12 (http://www.osdisc.com/cgi-bin/view.cgi/products/linux/suse?ad=distrowatch)
A Practical Guide to Linux(R) Commands, Editors, and Shell Programming (http://www.amazon.com/gp/product/0131478230/) Amazon.
SuSE Unleased: DVD and book:
Linux Documentation Project - How To Guides (http://tldp.org/docs.html#howto)
Product Guides (http://tldp.org/guides.html)
PDF Guides (http://www.ibiblio.org/pub/Linux/docs/HOWTO/other-formats/pdf/)
Linux FAQs (http://tldp.org/docs.html#faq)

SuSE Linux Forums:

* OpenSuSE Beta PPC Forum (http://www.suseforums.net/index.php?showforum=66) - Recommend you check this one.

Linux on PP (http://www.suseforums.net/index.php?showforum=65) other distros

Ubuntu (http://ubuntuguide.org/)
Ubuntu Starter Guide (http://ubuntuguide.org/)
Ubuntu Linux (http://www.ubuntulinux.org/)
Distrowatch Ubuntu (http://distrowatch.com/table.php?distribution=ubuntu)
Installing and Configuring Ubuntu on a Laptop (http://www.linuxdevcenter.com/pub/a/linux/2005/11/17/ubuntu_laptop.html)

GenToo (http://www.gentoo.org/)
Distrowatch Gentoo (http://distrowatch.com/gentoo)
GenToo Wiki (http://gentoo-wiki.com/Main_Page)

Online References:


12-10-2005, 02:43 PM
WARNING: openSUSE installation on Apple PowerMac computers requires harddrive partitioning by means of external tools. Installation requires currently manual bootloader configuration on all systems.

What I 'assume" is on the 5 CDs.

#1 bootable installer basic system and recover / repair tools
#2 has essential software for desktop and office
#3 extra software for multimedia, games, graphics and content creation
#4 - 5 server and system config

"SuSE Unleashed" (http://www.amazon.com/gp/product/0672327260) might be useful @ $33 with DVD Does NOT includes PPC versions and while the book and online info said it includes CDs, there were none. So downloading is the only means.

Alpha 4 is due on Dec 15th, so wait!

I'm not sure why it took so long to finally navigate around and fine the tips on installing and partitioning, but it does take some tweaking with pdisk.

I welcome others opinions and experience.

12-10-2005, 03:39 PM
Linux Multimedia Hacks
Tips & Tools for Taming Images, Audio, and Video
By Kyle Rankin
First Edition November 2005
330 pages, $29.95 US, $41.95 CA, £20.95 UK

This latest Hacks book gives you the technical chops to enjoy the considerable multimedia options available on the Linux platform. Learn step-by-step how to do cool things with images, audio, and video. Included are tips and tricks for connecting to iPods, creating MP3s and Oggs, watching and making DVDs, turning your Linux box into a Tivo ala MythTV, and much more.

Sample Hacks - pdf

Hack 16: Get MP3 Libraries for Red Hat–Based Distributions (PDF)
Hack 19: Shuffle Your Music the Smart Way (PDF)
Hack 54: Watch Videos in ASCII Art (PDF)
Hack 74: Watch TV on Your Computer (PDF)
Hack 91: Watch Videos Within Firefox (PDF)

Related Books

* Running Linux, Fourth Edition (O'Reilly)
* Linux Server Hacks (O'Reilly)
* Linux Desktop Hacks (O'Reilly)
* Test Driving Linux (O'Reilly)

Linux Multimedia Hacks (http://www.oreilly.com/catalog/linuxmmhks/?CMP=ILC-GG7423313304&ATT=linuxmmhks)

12-11-2005, 03:03 PM
I managed to finally get through installing all 5 CD.
Clicked FINISH and was greeted with blank screen.

I did have to use pdisk accessed via the first prompt:

install start_shell

Delete the HFS partition(s) and Create

Apple_HFS (40MB)
Swap (1GB)
Root (9GB)

pdisk is limited to 15 partitons, and Apple includes a number of its own plus small free space between each user partition.

At the end of CD #1 I also had to reboot from CD#1 and load system from hard drive to continue install from #2-5 CDs.

I still need to configure lilo to make it bootable.

I was hoping to be able to post from SuSE by now, but after a lot of trial and error, still not quite there.

12-11-2005, 05:57 PM
I can't do anything (except erase the install) now that it always puts the monitor out of range or something. Never seen flashing light on LCD power before.

YaST doesn't work on PPC to create a proper boot loader. It seems to patch nvram (so that is what I tried first).

I hope I can figure this out - at least so that the "next" install doesn't end up in the same place (get a little further each time) but it is not a quick install process (spoiled by Tiger).

12-11-2005, 06:09 PM
I can't do anything (except erase the install) now that it always puts the monitor out of range or something. Never seen flashing light on LCD power before.


is this just before loading Xfree/X.org and puts you right back to the prompt?

Can you access displayconf ?



12-12-2005, 09:36 AM
It said something about X11 not being installed. I chose to auto-login to my account (non-root).

I'm literally 'in the dark' and hope that "SuSE Unleashed" will help, plus Alpha 4 Friday. For now, I may just wipe the drive and start over again.

12-12-2005, 09:50 AM
It said something about X11 not being installed. I chose to auto-login to my account (non-root).

I'm literally 'in the dark' and hope that "SuSE Unleashed" will help, plus Alpha 4 Friday. For now, I may just wipe the drive and start over again.
Oh, OK never had this one.

Only something like:

X11 (X.org/Xfree) returned an error


Window server not configured


Window server failed: illegal config in line: XXX

Something like that.
Those problems can be solved by using Displayconf or running the setup again.

There must be a "General Video" Hardware setting sometimes, if you are using a newer kernel version the old video drivers are not compatible anymore.



12-12-2005, 10:46 AM
At this point, no matter what I try to do, even from the CD, won't display properly. I think I'll try an "Update Install" this time, if I get that far. Or just reformat.

Checking for new updates doesn't usually work, you need to manually configure to search for mirror sites. Also, maybe when the install is done, but before clicking on "FINISH" (which was the last thing I did) would be a good time to login as root and setup some of those config files.

Knowing when to do what, and what commands, is the type of experience I totally lack.

I was reading one article which walks through how to use pdisk, and to a newbie, the lack of even one sentence or step makes all the difference...

YaST initial menu, change Booting
Then select Boot Loader Installation
Next, Do not install any Boot Loader

During YaST setup, it will try to setup bootloader and alert you it cannot do so.
Continue installation as usual and set up "lilo" or "yaboot" once your system is running.
- Check PPC_Installation for more on bootloader setup - which is here.

Continue the rest of the installation until it reboots.
You need to boot your installation kernel from CD.
Boot to the linuxrc

when I type "linuxrc" nothing happens and gives an error.

Inside linuxrc you specify to boot the installed system.
Select option 4 (Start Installation or System)
and then option 2 (Boot Installed System)
Select the correct root partition and it will boot up and continue the second stage.

(I think this differs from what I see in 10.1 Alpha 3 in significant ways?)

From www.opensuse.org/PPC_Installation_Issues

Using pdisk.
A the initial prompt type "install start_shell"
You have to run pdisk from the shell first before installing.

Probably want to use interactive mode.
Select the /dev/sda (in my case, SCSI Seagate drive ID10)
List and view partitions.
If you have more than one drive, I don't know who to scrollback up the screen output, and pdisk is limited to 15 partitions.

If you won't be using any OS 9 drivers, that adds some. If you have OS X there will be an empty 128MB free partition before most likely, and one after. If you only will have SuSE on the drive, create one HFS partitions beforehand, then slice it up for the partitions needed by SuSE.

"c" is used to create a partition and name, without specifying type
"C" creates partition, asks for name and type.

Delete your HFS+ partition(s) you created previously in Disk Utility to use for SuSE linux
C/create Type Name of partition
Create Apple_HFS boot (40MB)
create swap (256-1500MB)
create root (3GB+)

After reviewing your partition table "p" you need to "w" write the new partition table, and then "q" quit pdisk.


At one point it tells you to run /sbin/lilo/ as root to write the bootloader to disk and adjust the boot-device variable in OpenFirmware NVRAM. - page 4 of Partitioning.

X11 Configuration

* Add to file /etc/X11/xorg.conf in section Section "Module" this:

Load "dri"

* After editing X11 config files, you should restart your X environment.

12-12-2005, 11:11 AM
Boot Loader Configuration in the Installed System

PowerMacs use the yaboot boot loader to provide a list of configured kernels during start-up and to load the kernel and initrd from the hard disk or over the network. To reduce the hassle of configuration, a wrapper script 'lilo' exists to generate a yaboot.conf file suitable for your setup. lilo uses a simple config file /etc/lilo.conf that contains a list of kernels, the boot partition, and the MacOS installation. An example config:

# wait 10 seconds for user input
# kernel to boot when no user input was given
# update the firmware boot-device variable
# small Apple_HFS partition

# kernel ELF binary
# kernel cmdline options
# resume= for suspend-to-disk
# quiet to surpress the useless kernel messages
# sysrq= to allow backtrace when things go downhill
append="root=/dev/hda8 resume=/dev/hda9 quiet sysrq=1"

# MacOS partition
# this label can also be the default=

If you can't find lilo.conf in your /etc folder, create an empty document and paste the above code (or any variation of it) and save as lilo.conf in your /etc folder.

Run /sbin/lilo from shell as a super user to make lilo read the .conf file and set up the configurations you entered.

* For each change you make in the above file, you have to run /sbin/lilo again


lilo: timeout to select macos/linux boot is sometimes too short, make it configurable


On Fri, Sep 23, harryc wrote:

> The problem I am having is that I only get the "Press spacebar to boot
> OSX" prompt for maybe 2 seconds before yaboot comes up. How can I make
> that prompt appear longer? I have Linux set as the default in LILO . If
> I make OSX the default I have the opposite problem.

Edit /lib/lilo/lilo-pmac.lib, line 242. The single 3 is the number if seconds.

echo "get-msecs d# 3 3E8 * +"

We should make that a config option.

12-12-2005, 11:22 AM
SUSE Linux 10.1 Alpha3

* HAL dies on laptops if ac adapter removed - get an updated package from ftp://ftp.suse.com/pub/people/aj/hal

* powersave dies at boot directly - get an updated package from ftp://ftp.suse.com/pub/people/aj/powersave.

* acpid might not run due to a race with the Xserver (Bug #133440 (https://bugzilla.novell.com/show_bug.cgi?id=133440)) - and then powersave will not run either. A workaround is available (see Bugreport, comment #8).

* After first installation the kdm won`t start!
SUSE Linux 10.1 Alpha2

* libfontconfig does crash after installation or update, this affects most GUI applications like KDE or Gnome. You need to run "fc-cache --force" manualy as root to fix this issue. [url=https://bugzilla.novell.com/show_bug.cgi?id=128080 Bug 128080[/url]

All apps that are using
fontconfig are now crashing, probably all somewhere in or near FcCharSetCopy.
This means I cannot really run any other X application that xterm... KDE/gnome
etc. are all crashing. I really need quick help. Downgrading is unfortunately
not possible since the packages are not on the ftp anymore and I havent cached
them somewhere.
I need quick help, need to work on something... need any more information ?

Comment #1 From Mike Fabian 2005-10-13 08:58 MST

Thank you, I already noticed that as well and will try to fix it as
soon as possible.

As a temporary workaround for you, please run:

fc-cache -f -v

as root. This will make the problem go away.

But of course fontconfig should not crash just because there is
something wrong with the fonts.cache-2 files.

12-12-2005, 01:24 PM
Maybe I need to find and do an ATI OEM ROM update? Without knowing more, I am left to guess HOW this happens.

8. Graphics, Printer and Other Hardware
Finally, SUSE Linux will configure the remaining system hardware. Usually, all components - including the graphics card, TV card, sound card, printer, scanner and monitor - are automatically detected and merely need to be confirmed. Of course, experienced users can use YaST for fine tuning. Even with a freshly burned CD #1 to boot, and wiping the hard drive, SuSE still won't communicate with the monitor. Even a simple reset-nvram etc. doesn't help, though I am suspecting that it changed some variable or added something. No other drives connected. Maybe it send a signal to the monitor.

Luckily, my main OS X system isn't affected.

12-13-2005, 09:41 AM
From the SuSE forum:
X boots to a black screen
Description: Install/Upgrade of software leads to a black screen

99% of these problems are caused by a misconfigured X.

The easiest way to check this is as follows

1. Reboot. Once at the boot menu, where you can select the operating system to boot, just select the entry for your Linux installation and type in "3". This starts your pc in what is called "init 3", "Run Level 3" or "Text Mode" (depending on terminology)

2. At the TEXT login prompt, enter "root" for username and your root password.
3. To reconfigure X, type the command sax2 and press enter
4. Use SaX2 to try other settings.
5. To restart X - type as root

init 5

and then see if X is working.

Other messages (one Beige G3 owner who also has 9600) leads me to think SuSE has poor ATI Radeon support probably.

12-13-2005, 03:24 PM
Disappointed to find that the PL G3/1GHz crashes on trying to run the installer. it also doesn't have USB support at that point (odd because while it has had ADB, it came with USB k/b). So I can't even test on B&W, and fear that the OldWorld Beige will be just as much trouble.

The "Unleashed" book doesn't even mention "powerpc" and only mentions the G5 as being one of the 64-bit systems. But it does cover SuSE and puts a lot of information in your lap :D

I know I didn't have trouble installing SuSE 6.5 on my B&W, so I was disappointed that I have this much trouble. I am NOT about to change cpu back to G3/450 or try G4/500.

YDL 4.0 doesn't like my CD/DVD (read only) so I may put the Combo drive in.

12-13-2005, 05:33 PM

if you want/like, I can compile a stable GenToo stage build from source on my B&W (G3 optimized, fewer stages than G4/G5 builds, no Altivec) if I have some freetime.
You can use the universal install too.

The whole copiling would take at least 15 to 25 hours if all is running well;)

If you compile your own install, you can put in hardware drivers from other platforms (because source is source non specified CPU) too;)

Did this for a friends Beige with an unsupported (on the Mac) Netgear WG311T.

BTW you can compile your own G3/G4/G5 optimized version of FireFox too (DeerPark);)



12-14-2005, 04:44 PM
> Hello!
> I did an update of my Suse-10.0 PPC (on my PowerBook G3 Wallstreet - Suse works on it, great! :-) )

> This update did change the kernel and related stuff (modules), and I rebooted w/o uploading the kernel to my HFSplus partition (there I need it for BootX).

Can you boot the install kernel, into the rescue system?

Boot it with 'rescue=1', then mount the root and hfsplus partiton and
copy the /mnt/boot/initrd and /mnt/boot/vmlinux files to the hfs boot partiton.

Umount both and update the settings in BootX.

12-14-2005, 07:27 PM
If your interested in Linux here are two sources of different Linux Distributions:

DistroWatch (http://distrowatch.com/index.php?language=EN)

Linux ISO ORG (http://www.linuxiso.org/)



12-18-2005, 12:28 PM
A Practical Guide to Linux(R) Commands, Editors, and Shell Programming (Paperback)
by Mark G. Sobell

A Practical Guide to Linux(R) Commands, Editors, and Shell Programming (http://www.amazon.com/gp/product/0131478230/) Amazon.

“I keep searching for books that collect everything you want to know about a subject in one place, and keep getting disappointed. Usually the books leave out some important topic, while others go too deep in some areas and must skim lightly over the others. A Practical Guide to Red Hat® Linux® is one of those rare books that actually pulls it off. Mark G. Sobell has created a single reference for Red Hat Linux that cannot be beat! This marvelous text (with a 4-CD set of Linux Fedora Core 2 included) is well worth the price. This is as close to an ‘everything you ever needed to know’ book that I’ve seen. It’s just that good and rates 5 out of 5.”

About the Author

Mark G. Sobell is one of AWPPHPTR’s most successful authors. He is president of Sobell Associates, Inc., a consulting firm that specializes in UNIX/Linux training, support and custom software development. He is the author of many best-selling UNIX and Linux books, including, A Practical Guide to Red Hat Linux, second edition, Prentice Hall PTR, and A Practical Guide to the UNX System, Hands-On Linux, and A Practical Guide to Solaris from Addison-Wesley. Through his books, he has taught UNIX, Solaris, and Linux to thousands and thousands of computer professionals, including among them many PTR/AW authors.

* Paperback: 1008 pages
* Publisher: Prentice Hall PTR (July 1, 2005)

01-06-2006, 10:18 AM
YellowDog Linux 4.1 Released (http://www.terrasoftsolutions.com/news/2006/2006-01-05.shtml)

Terrasoft has released YellowDog Linux 4.1. This new release of course incorporates the latest and greatest of the Linux world, but besides that it also features support for the latest Apple PowerBooks, beta support for Apple G5 PowerMacs with dual-core processors, and basic 64-bit development and runtime support. The release is now only available to subscribers, but a public release is planned for mid-February.

Support for backlit keys.
PCMCIA cell phone and modem support.
Support for Atheros wi-fi cards.
Dual head config via the GUI.
Install direct to and boot from FireWire drives.
USB device auto-mount under both KDE & GNOME.
Greatly improved sound support.
Graphical Up2Date package install and update tool.
Support for the latest Apple PowerBooks.
Beta support for Apple G5 PowerMacs with dual core CPUs.
Basic 64-bit development and runtime support.

01-06-2006, 10:21 AM
Software developers contribute Novell for OpenSuSE

Early in 2006, Novell plans to release a development framework (http://uk.builder.com/programming/unix/0,39026612,39292109,00.htm) that will let outside contributors or third-party software developers contribute software or patches. The framework also will include a publicly available server that any registered developer can use to build software, Novell said. Since the OpenSuSE.org site was launched, there have been 750000 verified installations of SuSE Linux, Novell said.

01-06-2006, 10:24 AM
GNOME 2.13.4 Released (http://mail.gnome.org/archives/gnome-announce-list/2006-January/msg00015.html)

As always, the odd-numbered branches indicate dev-branches, and as such the 2.13.x series is the step-up to the GNOME 2.14 release, planned for March this year.


01-17-2006, 07:34 AM
Fedora Core 5
Supports NewWorld Macs

Preview (http://madpenguin.org/cms/index.php/?m=show&opt=printable&id=5971)
Release Notes (http://download.fedora.redhat.com/pub/fedora/linux/core/test/4.91/i386/os/RELEASE-NOTES)

01-17-2006, 07:37 AM
Ubuntu (Dapper Drake) Flight CD 3 (http://cdimage.ubuntu.com/releases/dapper/flight-3/)

01-25-2006, 09:25 AM
Red Hat representative Gillian Farquhar announced last week that the company plans to add support for Apple's new Intel Macs to its popular distribution. Fedora and several other commonly used Linux distributions support the PowerPC architecture used by Apple in the past, and Red Hat wants to ensure that its software will continue to run on new Apple hardware in the future. The current impediment is the Extensible Firmware Interface, a relatively new BIOS replacement designed by Intel that is not yet commonly used or widely supported.

Ars: Red Hat to make Linux run on Intel macs (http://arstechnica.com/news.ars/post/20060125-6045.html)

02-03-2006, 11:42 AM

Painless backups using rdiff-backup

Linux.Ars returns with an exploration of how to performing painless backups using rdiff-backup. There's also some data recovery fun using an Ubuntu Live CD, plus all the Linux news we could fit into a single issue.

Lixux.Ars (http://arstechnica.com/articles/columns/linux/linux-20060202.ars)

05-20-2006, 03:50 PM
When you're done installing SUSE Linux 10.1 OSS, your desktop system is not complete. You might still need support for Java programs, MP3 audio files, and browser plugins for Macromedia Flash, Adobe Acrobat, RealPlayer, and Windows Media Video. You may also want to add support for playing DVD videos on your computer, and to try out the new XGL graphical toys. Here's how to effectively make SUSE Linux 10.1 into the perfect desktop OS.
The Jem Report (http://www.thejemreport.com/mambo/content/view/254/42/)