View Full Version : RAID on OSX 10.2

09-10-2002, 12:19 PM
I read somewhere that the striped performance of OS X raid on Jaguar was now up to normal levels, having been extremely poor under 10.1. Has anyone here tried it - and do you know if it's now possible to boot off a RAID 0 or 1 under 10.2?

Secondly, I've been running an Adaptec 29160 with 2 IBM SCSI 36s without any problems under 10.1 and 10.2 - (I haven't tried RAID yet though) - I thought it wasn't supposed to be compatible?

I'm thinking of trying the system software RAID as an experiment while we wait for SoftRAID X...

09-10-2002, 12:40 PM
Search the Apple discussions forum on Adaptec but so far, the 39160 is definitely not supported.

The OS X Forum has a number of threads and yes, there are people using Apple RAID.

SCSI drives can't be used to boot from using RAID, even under OS 9 the G4's won't.
Beige and earlier would boot off stripped raid, yosemite off mirrored.
You can boot with hardRAID using IDE PCI but that's another story.

You might want to wait for 10.2.1 I think Adaptec and SoftRAID and others are waiting on Apple to add more SCSI support. Oddly, CharisMac does have RAIDtoolkit for 9/OS X. ATTO seems focused right now on their UL4 card.

All "performance" numbers are relative and more difficult under OS X but Apple DiskBasher and Intech QuickBenchX just for having soemthing to go by. Too bad StorageReview doesn't do OS X benchmarks. But they do have wonderful reviews and top notch testing.


09-10-2002, 05:13 PM
I'm running a two-drive AppleRAID stripe under 10.2. The numbers for that setup appear to be quite a bit better than same under 10.1.5...
'Course, there still seems to be no way to make multiple-partitions on a stripe; I tried again tonight after reading something in Help Viewer: <BLOCKQUOTE class="ip-ubbcode-quote"><font size="-1">quote:</font><HR> "Open Disk Utility and click the RAID tab. Drag the disks or volumes you want to use into the Disk list, and choose a scheme from the RAID Scheme pop-up menu."<HR></BLOCKQUOTE>
So I wnt through the motions of breaking the previous array and carefully crafting equal size volumes from the resulting single drives, then trying to drag each matching volume to the disk window, but no way no how...

Here (http://www.macgurus.com/ubb/Forum23/HTML/000197.html) are the recent numbers from both DiskBasher and Quickbench X. Why the two sets of numbers are dramatically different I have no idea...

[This message has been edited by Boots (edited 10 September 2002).]