PDA

View Full Version : Failed RAID?



pclark
03-10-2002, 10:13 PM
I have an 8600 with a Miles2 LVD and two 15K Seagate Cheetahs installed that I got from the Gurus about 2 years ago. I was just getting some things cleaned up on my 8600 when I decided in a moment of insanty to upgrade from 8.5 to 9.x. Prior to this, I was able to see the RAID drives. I installed 9.x on my orignal Quantum and all seemd ok. But now, as the system boots, it says "Softraid Driver has detected an incompled RAID Level 0 (striped) volume. The drives will not mount on the desktop and when I run EZSCSI, it starts to read the setup, gets about 75% of the way, then stops cold.

So....anyone offering some thoughts on where I can start? I've rebooted with extensions off, rebuilt the desktop and still, no joy.

Thanks,
Pat

Damien
03-11-2002, 09:04 AM
Sounds like the softraid version you used to make th eraid is not OS 9 compatible. If you have no data on there you need get the latest version of Softraid and reformat. If you need data from it then go back to using 8.5 long enough to back up all your data THEN get the latest version of Softraid and reformat.

ricks
03-11-2002, 01:17 PM
Hi Ya Pat.

I have had some similar problems with SoftRAID lately, frequently when I restart I have to mount the RAID via the SoftRaid utility mount menu. This on a Quicksilver with ATTO scsi card and OS9.2.

If this doesn't work the very first thing I would look at is Miles2 Firmware version. There are quite a few different revisions. Looks like the newest is 1.05. There is a beta 1.06 but someone with some experience with it will have to tell you if you should use that one.

Goto: http://www.initio.com/support/index.htm
Down near the bottom is the download for Miles2 section.

Are you running SoftRAID 2.2.2? If not you should download that version from SoftRAID.

If you need to backup the data you might try booting on a 8.6 CD and then opening your SoftRAID utility and trying to mount the RAID from the utility. Should work.

Let us know.

Rick

pclark
03-11-2002, 05:33 PM
Guys,

Thanks for the info and advice. Yes, I did update to both Firmware 1.05 and SR 2.2.2. This is still not working. Any time I attempt to lanch the SR EZSCSI software, it does precisely what I described before and it just will not go any further.

I did not think of trying to boot from the older 8.5 CD to get the system up so that will be next. Last night one of the drives did a "thunk-thunk" routine about 2-3 times so I may be looking at a failed drive in the chain. Since the drives are striped (and assuming one is/has gone bad), is there any way to mount just one of the drives or they both hooked to each other where I will have to simply reformat and initialize? (Thanks to the Mag man for the advice on using the Cheetahs. It may be a very good thing they have a 5-year warranty!) While on that issue, assuming that one of the drives is bad, who would I deal with? Gurus or Seagate?

Thanks,
Pat

ricks
03-11-2002, 07:32 PM
Pat,

Does Apple System Profiler see the drives? ASP is a great tool for diagnosing problems like this.

Seems suspicious that you 'lost' the RAID when you upgraded the OS. Possible, but more likely a software issue. If you have a copy of Disk Warrior it might be able to repair the index of the RAID. Disk warrior is available online from Alsoft and is a great tool to have around, can save you endless trouble when run on a regular basis.

When one drive is lost all the data is unreadable, the data is written across the drives alternating. Half the data is incomprehensible.

After 30 days you will usually want to take up warranty issues with the manufacturer. Seagate does a real good job of supporting their products.

If you have no data that needs saving it could be time to reinitialize and test your drives. A trashed index may be all that's wrong.

Rick