View Full Version : Another Mission critical RAID setup. . .

12-21-2001, 06:56 PM
We have a Filemaker Server that needs to be up 99.9% of the time. Part of the plan for this system incorporates SoftRAID (RAID 1), but I cannot get it to work.

The Gurus have already helped with great advice (and SCSI products). . .

OS 9.2.2
OEM ATA drive
Rambuctious (Ram Disc)
Filemaker Server 5.5
Kickoff! reboot device

2 Seagate 18 G (15X)
ATTO SCSI card (v1.64)
Granite cable/active terminator
SoftRAID 2.2.2

Set up the SCSI/RAID no problem. Left SoftRAID preferences/parameters at defaults.

Everything seems fine, except that the mirror will not stay syncronized, and when an Applescript runs at night to backup all the FM data to the mirror, FileMaker produces this error:

" Type -36 error (I/O Errors)

This file is having difficulty while either reading from the drive or writing to the drive. The file may have been improperly written data to the drive or the hard drive or disk may be damaged. This is almost always indicative of a media error (hard error on the disk). Sometimes (rarely) it is transient.

Solutions: Try copying the file to another drive. Use a disk recovery software, such as Disk First Aid to examine the disk. You can try rebooting with all extensions off. Once in a while this will allow you to read the data. The file in question should be restored from a backup that was stored on a different disk. Regular backups can reduce the time to recover from this error. "

So we now back up to the ATA drive, no problem. Oh, and by the way, we have been using this setup (without SoftRAID) for approx. 6 months, with no problem, so I have to think it is the software. . .

I contacted SoftRAID techsupport and asked if there was anything they recommend I check or configure (mode parameters,etc.), and they suggested this (so far):

" About all you can do is disable acceleration, and see if problems go
away. Install the driver on any one drive, unchecking all checkboxes,
then restart. if the problem goes away, we will know it has to do with
concurrent I/O and may point towards the SCSI card....

for performance tweaking, if you use Seagates, then it may be worth
tweaking Mode parameters, otherwise, it really isn't. (Seagate sets
drives to optimise for NT which sucks!) "

OK. . .

So. . . what does that mean? And most importantly, what can I do!? Some of my peers think that SoftRAID must be junk, and that we have to buy a hardware RAID, but I would like to solve the mystery.

Thanks in advance, Gurus!

[This message has been edited by newbie (edited 21 December 2001).]

12-22-2001, 12:20 AM
Let me get this started with a few questions:

1. You also had this problem with OS9.2.1?
2. You are using RamBunctious for what?
3. How much memory do you have?
4. Virtual memory is off?
5. I know nothing about Filemaker Server. Are you using default application memory on it, or have you increased the memory assigned to it?
6. ATTO SCSI card, UL3S or UL3D?
7. Granite stuff, LVD cable and LVD terminator?
8. I run a monthly maintenance program on my RAIDs but I have no experience with RAID 1 on a server which might require more frequent maintenance. In this order, I run Disk Warrior (DW), Norton Disk Doctor (NDD), Apple Disk First Aid (DFA), Norton Speed Disk (NSD), and finally DW again. BTW, both DW and NDD are crucial to this maintenance. Do you run any maintenance utilities?

I think I would follow SoftRAID tech's advice and try disabling the acceleration. However a couple of notes that work for me:

In Install Driver I run all of the acceleration except Photoshop. I run Maximum Concurrent IOs 256, Memory Pool Size 1369. In Mode Parameters I run Buffer full ratio 0, Buffer empty ratio 0, and Number of cache segments 28, all default as I recall for the Generation 2 X15s. For Generation 1 X15s, the only difference for all the settings is I run Number of cache segments 23.

All the above is for SoftRAID 2.2.2 striped RAID 0 off of one or two UL3Ds with 1.64 firmware, 2 to 8 G2 X15s in a G4-800DP OS9.2.1 (six of the drives in a Burly) or dual Miles2 in a PTP OS9.1. I stripe with 256SU (128KB) instead of the default 128SU (64KB) because the smaller stripe size seems too busy for me and increases overhead. Smaller is better for smaller file sizes, larger better for larger file sizes.

If you could answer the questions, it may reveal something. The rest I posted to see if it uncovers anything you may see. k

12-24-2001, 01:39 PM
1. Previously running 9.1 (SoftRAID is supposed to be compatible, and several other servers here are running 9.2 & FM Server 5.5 with no problems . . . maybe I assume too much.).

2. We have been using Rambunctious to increase read/write performance. This is configured by the DB administrator (again, used on other FM boxes with no problems).

3. 1.25 G.

4. VM is off.

5. FM memory is set at 210 M, app typically uses up to 60 M.

6. UL3S

7. Granite GD6299 diagnostic active terminator, Granite GD1200 LVD cable (internal installation)

8. About the same: DW 2.1, DD 6.0.3, DFA. . . Previous to this problem, I would run utilities at 2-3 months without any problems.

I have already disabled acceleration, but it had no effect. At this point we have split the mirror and will try to use both of the drives independant of each other, in order to test by process of elimination.

If either drive does not function correclty, there is the culprit. If both drives work correctly with the SoftRAID drivers, but not mirrored, then what?

I am also wondering if the problem could be caused by a network drive that is used to copy files to. All done through Applescript, and working fine for many months before SoftRAID . . .


12-24-2001, 03:19 PM
I have absolute confidence in SoftRAID. But not in ATTO's 1.6.4 and 9.2.1/9.2.2.
I have been running SoftRAID driver (non-RAID) for OS X 10.1.2 which could not do with PB or 10.0-10.04.

there is a beta 1.6.5a firmware from ATTO but it slows things down. I thought the UL3S was bad because as soon as I upgraded from 9.1 to 9.2.1 I had trouble; had just purchased the ATTO board.

OS 9 allows you to create RAM disks in excess of 256MB so I also don't see the need for RAMbuctious now.

I would downgrade to 9.1 and just use the ATI, OpenGL, OT, etc extensions from 9.2.2. Any chance that FM 5.5 doesn't like 9.2.2 also?

I thought 3 cache segments in SoftRAID was ideal for Seagate drives on Mac but could be off base.

12-26-2001, 01:53 PM
Hope everyone had a great Christmas.

OK, we split the mirror, and tried transferring files to both drives. Had the same problem with both drives (12 out of 18 files transfered, and FM Server reported an error).

Correction: This server never ran 9.1. It went from 9.0.4 to 9.2.2, because we had suspected a conflict between 9.1 and FM Server 5.5 on another machine. I will have to do some homework before we consider downgrading to 9.1. Anybody out there running 9.1 and FM server 5.5 without a hitch?

I checked at the ATTO site, but did not see a 1.65a beta. . .although I did find this:

" My application reports data errors -
* Check your cables. There could be slight damage to one conductor causing intermittent failures.
* Try slowing down the data transmission rate by lowering the sync rate for the drives. To do this, launch ATTO ProTools or ExpressRAID. Double click on the drive you want to change in the left-hand window. The current sync rate will be displayed. Lower it then close and save the changes. Reboot. "

Can I try this even though we are using SoftRAID and not ExpressRAID?

How about trying the Seagates with Apple drivers to eliminate the possibility that the SoftRAID drivers are the problem?

12-27-2001, 02:00 AM
Your previous post, 24 December 2001 12:39, does not reveal anything to me except that your other machines are running fine. Do any of them have a Granite LVD cable and LVD terminator? Or is this one the only one? I can't imagine that slowing the the sync rate would do you any good.

IMO, it is time to check the Granite cable and the terminator. Remove it. If you have any others, try them. If you don't, check this cable and the connector pins with a magnifying glass and your terminator and its connector. Understand that the Granite TPO LVD cable is not meant to be folded over itself for neatness. Nice gentle turns, no sharp creases. Ugly is good, neatness bad. I particularly look for the slightest abrasions to the cable and most particularly at the last lines on each side of the cable.

The next possibility is the UL3S. Do you have any others in one of your other machines to try? I leave the drives last because I just can't imagine both going bad at the same time.

You can try the Apple driver or the ATTO driver via ExpressPro Tools latest version.

I would not give up on the cable and terminator as a possibility even if you don't see anything wrong with them. Contact Granite tech and ask them to issue you an RMA to have them test both the cable and terminator. They are good folks. k

12-27-2001, 12:15 PM
I guess it is time. The good news is I have the exact same Granite components available to test with. . .

This server has constant activity from about 4 AM to about 10 PM, so I won't be able to crack it open until at least this weekend.

I did put in email tech suppot @ ATTO late yesterday, just to get their position on 9.2.2 and 1.6.4. Still waiting for a response.

By the way, any tricks required for removing SoftRAID/reinstalling Apple drivers? I am having visions of FWB. . . .

Thanks for your help guys.

12-27-2001, 03:11 PM
Check with FWB first. They are not ready with 9.2.2 (or maybe even 9.2.1) drivers. Check with SoftRAID, I think (as I said earlier) that it is working fine and reliable.

Some people use Expresspro Tools to remove SoftRAID for Drive Setup. 1.6.4 firmware should be fine on QSG4 and 1.6.5a was only for earlier Macs like B&W and maybe Yikes!, Sawtooth, AGP.

I'd think the FileMaker Server user list would have some info - and that FM would be more likely to run best one step behind the latest Mac OS.

ATTO was so busy on OS X this summer that they didn't look closely to see what 9.2.1 was about and if it affected their products it seems.

01-03-2002, 02:26 PM
New info-

Over the long weekend I had enough time to try the following:

reseated the ATTO card
moved the ATTO card to a different PCI slot
replaced existing SCSI cable with a new backup cable
reflashed the ATTO card firmware (latest version, 1.6.4) again
replaced existing ATTO card with a new backup card
reflashed replacement ATTO cards firware (v 1.6.4)
reseated the RAM
exchanged RAM with other G4
intilaized (low level) Cheetahs with SoftRAID 2.2.2
Installed OS 9.2.1 onto one of the Cheetahs, and booted from it

After each and every test, I ran the same test script and received the same error.

My next step was to move the entire SCSI set-up to an available G4 running 9.0.4.

Before I moved the hardware over, I tested one last thing: removing the SoftRAID drivers using Express Pro Tools, and reinitializing one of the Cheetahs with Apple drivers.

IT WORKED! Have run many tests, including installing and booting from OS 9.2.1, with no errors or anomilies.

So the conflict seems to be between the SoftRAID drivers and part of our software setup (OS 9.2/FM Server 5.5)


FYI. . . here is the response from ATTO:

ATTO suggests using our software, as it is designed and optimized for use with our hardware. A -36 (I/O Error) error is often a communication error, or a driver to disk conflict. It was a good idea that you reinstalled the drivers, that would be the first thing I would've suggested. Have you swapped out cabling? The firmware is least likely to be the issue. The firmware Mac Gurus has mentioned will not be released and was designed for a seperate issue, that we resolved in our last software release.


Now on to next question(s):

As we cannot change our OS/FM Server versions because of other conflicts/issues - until we move to OS X somtime next year, am I correct in assuming that my choice for RAID 1 is now limited to Express RAID?

Before any of this occured, we were already kicking around the idea of moving to a RAID 5. . . maybe it is time. Any thoughts, or links you can point me to? My knowledge of Mac RAID 5 hardware is all of about two hours of scouring venders websites.

I would prefer a rack mount unit (yes this G4 is in a 19" rack/cabinet), and of course we already have a couple UL3S cards, and a couple shiney new (almost) MacGurus 15 X Cheetahs. HD space is not an issue; only speed and reliability. So 4 18 Gig drives are more than enough. Do I assume too much to think that the RAID 5 is always the boot drive?

BTW - Sorry to confuse the issue, I just wondered if I would have trouble repalcing the SoftRAID drivers with Apple drivers, like removing FWB drivers. . . (I did)

Thanks SCSI masters!

01-03-2002, 03:51 PM
ATTO has trouble with 9.2.1/9.2.2 with their own drivers (2.6 not sure about 2.7 but that has other problems for me), and extensive tests pointed that their firmware 1.6.4 didn't work with 9.2.1 whether Drive Setup 2.0.7 or ExpressPro OR SoftRAID.

I'm using SoftRAID (but only hfs+ at this point) running 9.2.2 and OS X 10.1.2 off ATTO UL3S.

Have you at least talked to Mark James (SoftRAID LLC)?


01-03-2002, 04:27 PM
Maybe? I got a fast response from SoftRAID techsupport (email), but it was unsigned.

Here is the SoftRAID response (from my 1st post):

I contacted SoftRAID techsupport and asked if there was anything they recommend I check or configure (mode parameters,etc.), and they suggested this (so far):

" About all you can do is disable acceleration, and see if problems go
away. Install the driver on any one drive, unchecking all checkboxes,
then restart. if the problem goes away, we will know it has to do with
concurrent I/O and may point towards the SCSI card....

for performance tweaking, if you use Seagates, then it may be worth
tweaking Mode parameters, otherwise, it really isn't. (Seagate sets
drives to optimise for NT which sucks!) "


Just got this From ATTO:

" With ATTO's latest firmware for that card (1.6.4) and
initializing the drives with our latest utility (2.7), you shouldn't have a
problem [with OS 9.2].

Let me know if I can assist you in anyway.


Bob Coldicott
ATTO Technology "

Did I misunderstand you Gregory, or are you disagreeing with info from Bob ATTO? I do not have the knowledge to test or even verify information at the level that you guys are at, so, basically, I have to trust someone. Gosh, I feel like a lowly consumer. . . .

We have been moving data to and from this drive for a few days now with no problems (data only; still booting from the ATA drive & 9.2.2). . . don't take this the wrong way, but for my sake I hope you are wrong !! http://macgurus.com/infopop/emoticons/icon_smile.gif

Any thoughts about RAID 5? It's OK, you can say "woe boy; you are in over your head. . ." or whatever. I'm here to learn and minimize painful mistakes, so tell it like it is!


[This message has been edited by newbie (edited 03 January 2002).]

[This message has been edited by newbie (edited 03 January 2002).]

01-08-2002, 07:27 PM

Some highlights from SoftRAID techsupport:

Me: Has anyone else reported an issue with SoftRAID, ATTO UL3S, Filemaker Server 5.5, and OS 9.2?

SR: Not yet. You are the first. I need to be able to replicate it here,
though, before I can get the engineers to really dig on a problem like
this. I will talk about this and a few other things with them at Macworld
this week.

Me: Let me know if I can help with any more setup info.

Me: We really need RAID 5 (and the stability of OS X). Will (or when will)
this be a reality?

SR: We aim to get an X version first, then add RAID 5. Probably 2 or 3 months after we have a RAID 0/1 for X we will have RAID 5.

- - - -

Does anybody see anything I missed? Frankly, I am a little skepticle that I am the first with this issue; seems more likely it is a config/hardware problem, but I have eliminated every other possibilty (within my abilities to test/diagnose) as per the previous suggestions and posts.

Gregory: Sorry if I sounded snotty in my previous post. . .I just read it again and realized it could have been taken as being confrontational. I did not mean it to be. http://macgurus.com/infopop/emoticons/icon_frown.gif

Thanks for all your (and everyone elses) help and insight. This is the best, most helpful, and most knowlegdable group of folks I have ever run across; I have learned more just reading through these forums in the last few months than I can begin to describe. Thanks!!!

Speaking of which, I saw a comment (from Magician I believe) about RAID 5. It basically stated that the Gurus did not have a solution that they could recommend, but the comment was maybe 4 months old. My question is: is this still the case?


01-08-2002, 07:36 PM
duplicate post

[This message has been edited by newbie (edited 08 January 2002).]

01-09-2002, 02:04 AM

No offense taken. I know how frustrating it can be. Have you seen my thread (http://www.macgurus.com/ubb/Forum3/HTML/000565.html) on this problem?

I'm seeing offerings for FireWire RAID. Just bought ATTO ExpressStripe for OS X. It also seems that UL3x will be replaced by UL4x in the near future and their RAID package could be one "solution."

Maybe not your particular configuration. The trick with Bob at ATTO is to know as much or more than they do. You have to know there is a bug and how to duplicate it. Even when I did, I had to press my case and while their level one assured me there was no problem, their internal testing did eventually and then I got to talk to Bob who is an engineer, not level one tech support.

There must be a FM Server mailing list or discussion forum? Others who would more likely have same setup as your own? Too bad you can't search internal databases of known bugs being identified.

Email me for an update on testing FM database.


[This message has been edited by Gregory (edited 09 January 2002).]

01-09-2002, 03:48 PM
Thanks for the link, lots of stuff there that makes my head hurt.

BTW, I had a very similar problem with a BW 350 with UL3S, Granite cable/termitation, and SoftRAID, and OS 9.1about 6-8 months ago.

The machine would hang (freeze?) just as the toolbar/clock loaded when booting from the RAID. I discovered it would boot with the option key pressed, and sometimes after without. Sound familiar? Pulled out much hair trying to isolate an extension conflict. . .

Even with lots of good tips and help from the Gurus, I reached my wits end (which, sadly, is a short trip), gave up and "borrowed" a G4 450 from an unsupecting coworker. The problem went away, never to be seen again. I have been using the BW 350 myself (minus the SCSI setup) ever since with no problems.

Even though there is not a positive answer yet, it sure feels good to know that folks like yourself, who have forgotten more than I know, have had similar problems. I mean at least I can feal good about my
SCSI diagostic and methodical problem solving skills. http://macgurus.com/infopop/emoticons/icon_smile.gif

__________________________________________________ _______

As for the Filemaker Server 5.5 / OS 9.2.1 / SoftRAID 2.2.2. issue, you are right in that I am sure there must be some info to be discovered. . . someone else has been handling this, but maybe it is time I look myself. Our position is different in that the software cannot be changed, and the server cannot be offline except on the weekends.

For what it is worth, the server has been up and running without so much as a hickup, for about 2 weeks in the following Config:

G4 733, OS 9.2.2
Boot drive: OEM ATA Maxtor
SCSI: UL3S Granite cable/diagnostic terminator, 2 15X 18Gig Cheetahs
Served data drive: Cheetah that was initiaized with ATTO, then drivers installed from Drive Setup 2.0.7, and Rambuctious (ram disc) that is writing through (to this drive)

At this point, I think we will just live without RAID 1, until these issues are resolved, or better yet we can move to OS X and RAID 1, RAID 5, or RAID 0+1.

I'm a pretty strong macaddict, but I gotta say that I drool when I look at the Dell Win2000 server down in the accouting dept. with the six hot-swap RAID 5 bays, redundant hot-swap power supplies, etc. It's too much fun to yank a drive (or 2!) out of the box while just hums right along. . .

I need a mac this bullet proof, or eventually I am afraid our mac servers days are numbered.

My 2 cents.

[This message has been edited by newbie (edited 09 January 2002).]

01-09-2002, 05:03 PM
When I passed this thread on to friend who does this on a larger scale than were talking about he came back with this email. This is way beyond anything I know about but I look forward to learning about this.


Because he's running OS9 (rather than Mac OS X with its Unix underlayment)
there's not much I can offer in advice or experience if he wants to RAID
in software.

I can share some observations...

The Win server the accounting department runs is a specific physical
layout with redundant PSs and a raft of hot-swappable bays. The only
box (I think) that Apple ever built to suit that physical description
was the Network Server: PPC-based and mainly running IBM's AIX Unix
O/S, in which one finds a full-featured volume manager.

Because Apple's historic focus has NOT been on unattended servers like
the Network Server but on interactive desktops, that one product had
a fairly short lifespan and nothing like it appears in the current
product line.

1) SCSI being SCSI (subject to performance/capacity details you know far
better than I), *hardware* RAID is a whole separate ballgame. If I
needed to deploy a Mac OS 9 server with its data storage as hard-core
defended as a RAID-5 solution suggests, I'd do this:

1. Buy a 5-disk (or 6-disk) commercial SCSI-RAID box;
2. Configure it for RAID-5 (in "hardware", which is to
say in the SCSI-RAID box's software);
3. Take my hot-damn Mac and put nothing other than OS
and utilities on its as-fast-as-available internal
4. Install the fastest and most reliable SCSI card(s)
to connect to the external RAID box;
5. Mount the RAID on the Mac and store *all* critical
apps and datafiles on that volume.

In that approach, there are no software limitations on the efficacy
of the RAID and the 5 or 6 disk RAID-5 volume can play the hot-swap
games (no, they're not "games", but worst-case disaster-recovery
testing) described in the article.

2) If I could deploy Mac OS X or Mac OS X Server, then the rules
change entirely. With gig-ethernet and Unix's NFS abilities, I'd
put a dedicated NFS server (Net Appliance "NetFiler" for example)
in place, install as many (shelves of!) physical disks as I needed,
hook one of its gig interface on another port of the same switch my
Mac was connected to, and mount the RAID monster via NFS. If the
users can tell the difference between app performance on Mac-local
disks vs. NFS-over-gig-enet from a Filer, I'd be seriously surprised.

The next benefit is that one can add as many Macs or Unix boxes of
any kind as one might wish to the environment with any mix of
read/write vs. read-only access to nearly any number of separately-
constructed and RAIDed volumes exported from the one monster NFS
server, all at stunning speed and with the NFS-server's RAID
config to defend against hard disk failures.

Wanna jack it up further? Put two identical Filers side-by-side and
configure for the twin to auto-replicate all disk changes from the
primary over a dedicated back-end gig-enet hookup; if the primary
fails, it informs the twin on the backend, and twin takes over the
primary role. Bring the failed primary back online as the twin
whenever you figure out and fix what blew up and watch it catch up
to the changes made on the other (now primary) server while it was

* Approach 1 (SCSI-connected hardware RAID) is what I'd do for a
very small shop or a lightweight need within a larger shop. It can
be cheap enough to play around with at home.

* Approach 2 is industrial-strength and can run from 10s of thousands
to multiple millions, but "Oooo, Baby!" it smokes 24x7 at the heart
of a complete installation (diesel UPS generators, Halon, parallel
app and web pumps, CDR jukeboxes for backups, et cetera et cetera).

The first can be escalated to medium-scale and expense. The second
can be downgraded to small-shop -- for instance, don't deploy gig
enet, just 100bTx, and specific product selection can change the
cost/feature mix within the same design concept.

The common thread to both approaches is to put the RAID implementation
in a machine that does nothing but RAID volume service. It does one
small but critical thing exceedingly well and the wild flexibility of
running applications with the mission of doing things to the data
served/defended on those RAID machines is what a full-service O/S is
for (Mac OS 9, Mac OS X, etc.).

01-09-2002, 07:17 PM
Ricks -

Wow! Thanks for all the info. . .so how much per hour does your friend charge? http://macgurus.com/infopop/emoticons/icon_biggrin.gif

I'm afraid that what we truely need is really close to "Approach 2 ", with redundant failproof drives as well as redundant failproof servers (I think the term is clustered?) for this application.

The problem is that we are behind the times technology wise, and trying to catch up on a limited budget, and with IT folks with limited/no experience outside of Mac/Win desktop computing (like me).

I guess I better pick up Unix for dummies http://macgurus.com/infopop/emoticons/icon_smile.gif, cause I don't have much hope that Apple is gonna give me access to the tools mentioned in your post through the GUI.

Any suggestions for folks who stayed away from DOS because it seemed too complex? Now Unix. . .yikes!!!

Thanks again to all.

01-09-2002, 07:38 PM
Hey, I know what you mean about the 'Unix for Dummies' thing. Frequently he threatens me with a UNIX textbook to get me started. Not to mention the fact that a true expert zips over their expertise in such a manner as to give the rest of us inferiority complexes.

You are not that far away (Gilroy), it might be possible to get some minor, time wise that is, consulting out of him if that's what you really need. Afraid he has a real (computer) junkies job and works those wierd hours. But never know, might be able to get enough info out of him to get you started?

Feel free to email me if you want any pursuit of that at all, and I'll hook you up.


01-09-2002, 08:47 PM

Good to know. If it were up to me (and money grew on trees) I would check it out now. Others here are probably happy with what we have now, although they are not the ones who get the call when something dies.

Realistically, I think it will be a while before we get to the level your friend described.

Right now we have up to 60 users from around the U.S., and a couple in England accessing this machine simultaneously (customer info to invoicing), and the company does about $30 million a year in business. How big is big?

I guess the first step is to move this server to OS X, but before we can do that we have some serious testing to do, not to mention locating the X versions of all of the Filemaker plug ins we use. Then (hopefully) SoftRAID will be up and running on X (maybe even RAID 5). Baby steps. . .

I will sleep lots better when we get to that point!

I will chat with the boss and see if this goes anywhere. Thanks for the offer.

[This message has been edited by newbie (edited 09 January 2002).]

01-09-2002, 10:52 PM
Newbie, was fun to discuss it back and forth. I suppose that when the time comes to go OSX that then will be the perfect time to implement a Network File Server. Sounds like the requirements will change at that time anyway which would waste the money spent on the OS9 option which is so different.

Keep my email around, I passed the URL for this thread on and he said that when when you need some help he'll be around.

Until then, like you I'll be doing some UNIX studies.


02-05-2002, 10:59 AM
I have been struggling with this -36 error in Filemaker Server when backing up either from a RAID 1 or to a RAID 1 for almost 9 months. I have changed everything imagineable, OS (no diff in 9.2 or OSX), Software (SoftRAID vs. ExpressRAID), drives, cables, terminators, all seem to cause the -36 error. I recently thought I had it licked, worked fine on a test machine, but as soon as moving to the live server, same -36 error when running backup from FIleMaker Server 5.5. Unusual, the only difference was the files serving, the test server had a later version of files. Copying the newer files to the test server than caused the test server to give the -36 error. I finally got the hint that it had to do with the SIZE of the file backing up and a quick look at the Filemaker Server log showed that only the largest file gave the -36 error, all smaller files worked fine. The cutoff size seems to be around 500 mb.
A long call to Filemaker finally got support to admit that their product is not certified to run on a RAID 1 setup. WOW, what a deficiency for a dataserver. Seems they cannot backup large files accross volumes. He offerred no work around. HOW DEPRESSING.
I am now trying to keep my files < 500 mb and will try again but am always open to other solutions. I would love to keep my data being served on a RAID but need to perform hourly backups without closing the files. Any other suggestions?

02-05-2002, 08:44 PM

Wow - that is depressing.

I wonder if it would make any difference with a Hardware RAID solution? Any opinions, Hardware gurus? I sure don't want to buy a $4000 RAID box only to have this same error raise it's ugly head!

Just to clarify: you have already set up a box with OS 10.1.x utilizing the native RAID 1 and Filemaker Server 5.5, and you expereicnced the same error?

I just checked, and on our server here the largest file in question is only about 156 megs, but as I recall it was the 5 largest files that did not transfer (and I assume produced the -36 error). The plot thickens. . .

While I have you, any Filemaker Server forums you would recommend?

Thanks for the input - you probably saved me countless hours of toil and frustration http://macgurus.com/infopop/emoticons/icon_smile.gif

02-06-2002, 11:39 PM
Must be file size...

Running FMP backups to both mirrored and striped RAIDs in classic Mac. My office server runs off a mirrored RAID w/o any problems (softRAID 2.2.2, dual X15, rev 1 Cheetahs) HOWEVER the file size is only 75 Megs..


02-11-2002, 04:49 PM
Size does matter...but seems to be more sensitive to record number than abolute size. I created a test database with a serial number and one picture, incrementally growing but duplicating the record, and FM Server backs up fine till I get to 50.6 mb file size with 1.75 million records. My real databases that get the -36 error are 24K records/55mb size and 76K records/600mb size.
I found the same error with OS X 10.1.? with RAID 1 created with internal software.
I have not found a good discussion board for FM Server yet. I was on a mail server years ago with good dialogue but when things were running so well (I guess the Gremlins heard me thinking) I dropped my subscription.