View Full Version : OSX RAID

11-23-2001, 08:39 PM
So, I installed the two 60GXP drives in my Quicksilver, reformated with several identical partitions and went to OSX Drive Utility to RAID a couple of the partitions and found that OSX will only RAID the drives not the volumes. That really sucks.

I wonder if the same result wih SCSI drives? Anyone tried it yet? Looks like I'll have to wait for SoftRaidX to accomplish this. I was hoping to have a mirror volume and a stripe volume as well as a standard partition on each drive. Would hate to have to do this with a bunch o drive$$$$ http://macgurus.com/infopop/emoticons/icon_frown.gif

Best laid plans and all.......


11-24-2001, 06:52 AM
It gets even better. Those volumes don't show up under OS 9, only under OS X. And yes, SCSI is no better or different. I've heard that 10.1.1 made changes to some core portions and that 10.2 (slated for MWSF?) will do the same - and both are making it hard for those writing low level driver stuff.

Maybe best to move this to the OS X General section?

I think we're still in beta on a number of fronts.


11-24-2001, 12:32 PM
Thanks for the tips Gregory. I can see how hard it'll be for SoftraidX to get done. I would have been happy with a OSX only RAID if it could have been RAID0+1. I have OS9 on a SCSI RAID separate from the IDE bus anyway. I probably wouldn't be satisfied with the soft stripes peformance anyway, so I'll just keep it simple for now on OSX and wait for some stability.

Did you hear anything else from ATTO on the UL3D/Quicksilver issues? Make sure you keep posting the issue as it developes.


11-30-2001, 09:16 AM
Hello ricks,

I was just hitch hiking the the old GURU's galaxy and thought I would drop by with an interesting bit of info.

I have 2 RAID -5 units striped together at RAID - 0. This is being done under OS-X server 10.1.1. It is working very very well.

Here is the intersting part...... I can see the giant RAID under 9.2.1 on the network. But.... I can't see the giant RAID if I reboot my server under OS 9.

I wanted to be able to back-up my server locally, the back-up software only runs under OS 9 at this point. This has not slowed us down really at all. We are backing up gigs of data to our new LTO on a DUAL 800 that is running OS 9 over the network and it is well fast.

Another interesting little tid bit .... I have ATTO UL3D's in all of my DUAL 800's and have striped 2 X15 cheetahs in each under OS 9. These are primarily used as Photoshop scratch disks. This is working on all stations perfectly. Well except that the drives can not be seen under OS X if I reboot into 10.

Thats about all for now.

Take care,

11-30-2001, 01:34 PM
That makes some sense actually. This early in the morning I had to read that a couple times to wrap my brain around seeing the server OSX RAID from a networked OS9 computer. That should always be true, and then once the server is booted from OS9 you loose the OSX software that created the RAID.

You shouldn't be surprised that the OS9 networked computers can mount the OSX server volumes, heck, they can mount almost anything over the network, even win-ders volumes.

The only way that a computer can run OSX RAIDs in 9 would be if OS9 could run OSX as a sub-system like classic, and that would be like a mouse carrying a giant around in its pocket. I wouldn't expect that Apple will ever make a cross OSX to OS9 RAID utility, it will have to be third party, and even then that's a tough one to accomplish, if it's even possible.

I look forward to a more comprehensive third party OSX RAID utility that will give the same kind of versatility we see in OS9 software. Until then I have been trying out the File Syncronization Utilities that are becomming availiable to those having to cross back and forth from OS9 to 10. I am impressed with a couple of them. The amazing thing is I never hear anyone talking about them before. VersionTracker and CNET show some of these shareware utilities being downloaded by over 20,000 people. Being able to schedule automatic 'cloning' of your important files to ANY other location (local disks, LAN disk on a server or Internet disks including your iDisk) seems like a great backup plan. These utilities have been around for years and I never heard about them.

My brother and several of the people in his group at Apple now trying out Swithback, one of the shareware utilities that easily syncs OS9 and OS10 files while running in either OS as long as the disk is mac OS standard or extended, not Unix (UFS). Great way to auto backup your Powerbook each night on your desktop, automaically. One issue is backing up long UNIX file names to OS9 disks, OS9 has trouble with that and it takes workarounds.

Switchback at http://webnz.com/glendower/switchback.html
Synx-X at http://www.versiontracker.com/moreinfo.fcgi?id=7842&db=macos
Syncronize! at http://www.Qdea.com/index.html

[This message has been edited by ricks (edited 30 November 2001).]

01-10-2002, 05:44 PM
In case anyone is interested I received an email from Softraid with this response to whether or not they would meet their Macworld ship date for an OSX version:

"We will update the web site this week. We are not hitting January, but
until we make a decision on a couple items, we dont have a date, but will
when we update the site."

01-10-2002, 06:35 PM
ATTO came out with ExpressStripe (RAID "Lite" maybe, which I don't recommend using but does provide basic benchmark under OS X 10.1 similar to ExpressTools).

Remember that Apple Shipped an updated Developer Tools in December? People have been waiting for better documentation, APIs, and tools so that they could BEGIN writing drivers.

Sonnet's Hard RAID ATA/133 doesn't rely on software (though I think you'll be able to use SoftRAID-X), and is both bootable and can be partitioned.

I tried to initialize and create a simple volume with StripeRAID and it failed. Unable to unmout. And yet unmounted all my other drives. Maybe it didn't know or like the SoftRAID driver (seems to work fine for SCSI hfs+ volumes and no problem related to OS X). In the past I couldn't use SoftRAID and OS X 10. Probably because OS X 10.1.2 has "better" scsi support than it has.

If I get up the nerve I'll try creating RAID volumes over the weekend or next week using ExpressStripe. But it IS "1.0" all the way. And a DOS person's idea of what a Mac GUI is I'm afraid. Aqua interface to a linux pdisk?


01-11-2002, 03:15 AM

RAID 5 on OSX Server?! This is my dream come true!

How? Where? What kind of hardware? Where do I mail the check?

Seriously, any info/advice you can offer about your setup, pros/cons, etc. would be more appreciated than I can express in words. . .

Ricks and Gregory have been giving great advice (and moral support) on a SoftRAID 1 problem of mine, but this is where I need to go.



02-05-2002, 10:59 PM
Did I know this? I don't think so. Just received my real ExpressStripe, not the Macworld demo. A separate flyer says there is a compatibility extension for OS9. So I went to ATTO downloads and it says:

Important Notes:

OS 9 Compatiblity Extension - (File Size 182KB) WARNING This file can not be used unless you have a copy of ExpressStripe for Mac OS X. ExpressStripe for Mac OS X can be purchased from the ATTO Store. Click here to purchase ExpressStripe for Mac OS X.

Purpose of the OS 9 Compatibility Extension Mac OS X is a radically different operating system from Mac OS 9. Therefore, ATTO developed a completely new RAID package called ExpressStripe for Mac OS X, which only runs in the MAC OS X environment. During the transition phase from Mac OS 9 to Mac OS X, many users will need to switch between the two operation systems. The ExpressStripe OS 9 extension is a system extension that will allow users to use their SCSI and Fibre Channel RAID volumes created with ExpressStripe for Mac OS X, in Mac OS 9.

Tell me this is something new or my brain must be fried. Of course, it does not say that the RAID will boot in OS9. But is this progress or did I miss something? k

02-05-2002, 11:33 PM
Well I feel like a dummy. In talking to folks I had gotten the impression this would never happen and here we have it. Got the email today, ExpressStripe for OS9. Awesome, definately opens up the RAID to be more useful.

BTW, ordered my Burly today, yeah. Just in time for this. Xmas in Feb.


02-06-2002, 09:51 AM
I tried ExpressStripe Enblr yesterday and was glad to see it really did work. There are still problems with ExpressStripe itself, but its there.

Also, ATTO has firmware 1.66 posted for UL3S/D.

If you use ExpressStripe, you have to initialize your drive with ExpressStripe first, then create your volume(s). I'd suggest a reboot after initializing, too. And NOT have any other drives mounted. It unmounts every and anything. If I had to make "ES" interface harder and worse.... I don't think I could. DOS disk utility with Aqua thrown on.

Hey, when I update the firmware... have to have all the drives on it off and/or disconnected, right?


02-06-2002, 12:18 PM
I had the same problem, on GO ExpressStripe would unmount a seemingly random group of volumes from my desktop and then not be able to "un-mount" my not mounted volumes to be in the new raid. I got around the problem by un-mounting the volumes that ExpressStripe kept on screwing with andwas then able to proceed.

I did discuss this with ATTO tech support, but they were not very open to them being at fault, a fault in the OSX volume structure was it.

I am ready for a 9 to X raid. I have almost totally switched over to X on my G4 which is my main business computer. It'll be wonderful to be able to access all my volumes.

I am still eating crow, I flat did not think that 9 to X raid was ever going to see the light of day. My wifes been laughing at me ALL morning, she says absolutely positively NEVER SAY NEVER. (unless your her of course)

Thanks very much for the firmware update tip.


02-07-2002, 01:03 AM

That new ATTO UL3S/UL3D firmware 1.66, have you tried it? I get a ton of ATTO emails about stuff I don't have, but not one whisper about 1.66. k

02-07-2002, 09:01 AM
The 1.66 firmware I just stumbled upon while grabbing the stripe enblr - I knew it was due and was waiting 4 mos for a 'final' 1.65 or something. But what ATTO said (to be believed?) was it enhanced support for removeables primarily.

No admission of anything further. HOWEVER, backup! I did nothing more than move my internal cable with one drive attached, new install 9.2.2/10.1.2 on Atlas 10k III) off the 2940U2B onto the UL3S. Hung on booting, drive shows up but its single volume doesn't in Disk Utility 10.1. Tried for an hour booting from OS X and OS 9 CDs. Ended up moving cable back to 2940u2b and boots fine, that drive works, no hang.

I would recommend NOT using 1.66. Of course I've battled ATTO for better support or lack on this card and B&W G3 since I bought the ATTO board in September due to problem(s) booting off it.

Unless cornered, and shown proof, that seems to be their line. If there is a problem with Apple's routines (probably right) I just hope they all work out their differences. We're spoiled by SoftRAID support and knowing that when it does come out, it will be the best it can be.


[This message has been edited by Gregory (edited 07 February 2002).]

02-07-2002, 12:39 PM
Must really make you ...feel, uh...... relieved(?) that you now have removable support while your building your raid. Nice of ATTO to do that for you.

Is the trouble solely from the boot off of issue or does the B&W not want the ATTO even hooked up for boot from another drive? I must admit I've never even tried to put a system folder on a software raid volume, all my experiences have been with using the raid for storage only with my boot volumes on either a single disk or a hard raid.

BTW, the Burley should be here in a few days, I'll hook up and see what might happen with the UL3D with split channel on the two AtlasIIIs in the B&W.

Been thinking about how to work around the PCI limitations. Not quite to the point of being obsessed yet, but we'll see. I'll know I'm in trouble if I start talking about it while trying to sell a horse or with my 1 1/2 year old kid. A conversation with the horse would probably be the most productive.

I'll keep you informed if something useful comes up.

02-07-2002, 02:15 PM

I don't boot off of RAID. (I have in the past and even forced a boot off RAID0 in two cases). Nope. Just can't boot off of a single hfs+ internal drive connected to the UL3S.

External is fine. The card can be installed. But I could not see the volume at all. Attach the cable to 2940u2b and all is fine. Move the cable back, trouble.

I have to do one or two more tests:

First: I've downgraded firmware to 1.64. Try booting OS X off that.
Second: format a drive with ExpressStripe, simple hfs+, and see if that works better.

If the board doesn't work with ATTO driver software, firmware, there is a bug. But it is only affecting this system (and ME!).

This is challenging. Throw more money at it? New cable? a drive just for testing? done it.

I would test this on my 7300 - but I can't even install or boot OS X on it, and when I move a disk drive from the B&W to the 7300 - it won't boot either. Zilch. (That is another story.)

ATTO only replied to email when it had "RMA" in the title - guess it got someone's attention.

02-07-2002, 04:55 PM
Your problem is getting to ME. I have seen no problem mounting drives with my ATTO board nor any kind of system instability. I switched the darn thing back and forth from the QS with both my drives on the double bracket many a time with no problem.

Well, one problem, I backed up my OSX drive from the QS on one of the Atlas drives and used Softraid for drivers. That drive is invisible to OS9 now even though I formatted the drive in OS9. The only way I can boot from the Atlas is with a option key startup. It would be impossible from the B&W without the option key ability. Now I wonder if this is the Softraid drivers or the ATTO? It never even occured with me to test, I assumed it was softraid that caused the problem. Hmmm.

I have had virtually identical experiences with ExpressStripe as you in its not quite ready for prime time problems. I sure wish it were convienent to try your board on my B&W.

I thought you had gotten a RGA number to do a return at some point? If not, why don't you work your way up the ladder until you do. This isn't right. You've built a gazzillion scsi buses and shouldn't have this much trouble.

Let me know if there's anything I can do to help. Happy to try most anything.

02-07-2002, 06:19 PM
You are right about SoftRAID. Its driver gets wiped out by installing OS X. Use Apple or FWB HDT 4.5.2 (or ExpressStripe even). If it is the only drive, it will mount. Otherwise, no. Whatever is used to automount is gone. Sorry about that.

You should be able to format, copy and clone OS X to another drive but I had the same thing happen when I tried to use SoftRAID, both a single volume drive and one partitioned - just had to find out.

ATTO said that they would do "x.y.z" to test the board and could end up sending it back to me if it checks out in their "supported system." Well, I knew 1.66 firmware was coming in a week; as a beta tester/programmer/analyst I'd save them the trouble - and me - and zap, flash, reset, and everything else under the sun. I even sent all the dev docs on the B&W and how it differs. Also, how much alike it is to Yikes! and pre-AGP G4s, too.

You have TWO Atlas 10k-3's on a U-bracket in your QS? Works okay?

I bought a 7300 after thinking I could help someone else and test their hard drive. Bad idea. Fried a new Radeon PCI (ATI replaced quickly and promptly). I was afraid it fried my mb or a PCI slot or something worse. Everything seems fine now except "this" ATTO issue (I didn't own the ATTO and was using dual 2940u2b).

The Option key and "X" will boot but I never see the choices some report even though officially the B&W doesn't support that feature. The number of problems with the B&W are sort of scary. And I didn't know better than to trust Apple etc or that there even was "rev 1" and "rev A" on Macs. Play and Pray (or Play) all the way. Boy was I wrong!

I was able to use CarbonCopyCloner (ditto utility) to quickly create a bootable OS X volume on another drive.

A. I think I've done everything but what I want from ATTO is an exchange.
No questions asked.

B. B&W G3 and ATTO - there are limitations like 53MB/s. Some people don't see that as a "problem." or that it was "known" (to the very select few). But never mentioned here on MacGurus where the ATTO boards are pushed as the best choice for Yosemite owners.

C. 9.2.1 is an issue with this card. What did Apple do?

Did you ever run the 1.65a0 firmware Rick? I just noticed it was 568k or so, while the official releases for UL3S/D are all 1.1MB. Half size?

You know where a company settles but you can't say anything about the problem or terms? That penalizes all users out there - maybe not future users if the problem is fixed. ATTO has a wall just like the 53MB/s - it is up to the USER to prove and not the company. Did you realize that the State of Virginia doesn't allow class action lawsuits? home of AOL and Verizon I think.


02-07-2002, 11:30 PM
First, thanks for the Softraid tip. I guessed that I had a issue there but I don't have a complaint in the world seeing as Softraids not supported to X. My fault entirely, wasn't thinking about it at the time.

Next, yes, I have stacked two AtlasIIIs, I also have never owned a drive that's so cool. I only purchased them as a comparison test but they do work well. I thought maybe they were idling down they were so cool so I booted off them and ran everything for several days, cooler than the IBM 60GXPs. We'll see if they hold up.

I think you ought to get that replacement UL3S. Work you way up the chain of command till they raise the white flag. What's happening to you has never happened to me EVER with my ATTO card, yours should work as well, especially as we're both doing the same setups on our B&Ws.

Last, from your 7300 post, that ones toast. You'll never get a hardware manufacturer to care if their new products for OSX don't work in a unsupported computer. Very unsupported. Hard to even ask a developer to look at a computer that takes hacking to run a OS.

All of the above is solely my opinion, worth at least the electrons it's made up with.


02-08-2002, 09:50 AM

Actually, I think there is something (still) wrong with the BW. I tried attaching LCD power to the 2nd outlet on the back. No go. Won't boot etc and it has to be directly on power strip. Something about power supply etc. Scared me to not get a good boot. Weak PS. Brand new LCD power adapter from Apple. but when I pulled the cord from the back, it booted, and plugged directly into outlet works. Why?

I bought Atlas because it is so quiet. the 10k II's were fast - put one in 7300 w/ 68-50 adapter and it feels fast. The most recent 10k Cheetah is quiet - and a fast puppy. Those X15's are also okay. But with different drives, there is a clash of noise and pitch/hum coming from them.

The 7300 is now for spare parts, testing, and when I need a 2nd machine (when the B&W is busy or down) and except for not being able to install or boot X.1 it works well. It's easier for me to understand someone else's computer that I am helping. I put theirs together spending too much money, and learned what will not work. I tried Ryan's and Sonnnet's and even OS X from my B&W won't, yet it has pretty basic stuff. Shame. G3/450 w/ 512MB, 10k drive on ATTO, ATI Rage 128 from my B&W, 19" ViewSonic, USB. I wish it had FireWire. It should run OS X fine.

When I attached an older full height Seagate (17 lbs) to 2930, at one point there was a pop! but no puff of smoke but the Radeon went. And something else it seems. I can't have three Cheetahs inside w/o power issue. I don't know how to replace the PS and if I did would love a much much quieter fan.

If I can hold out, I may just be able to do a QS G4 by end of summer - or maybe have this B&W repaired (there is only ONE shop out in the boonies).

I am no electrician, but I always am breaking things, taking things apart, creating mischief.