View Full Version : Disappointing X15

01-19-2002, 06:42 AM
ATTO UL3S w/ two X15 (2G) Cheetahs using SoftRAID 2.2.2

Sustained Write: 53MB/sec (what a single drive will do!)

Cables and terminator are Granite.
B*W G3 w/ xlr8 G4/500
Reduced extensions

Drives are in external cases (2). Would it change anything if they were internal or in a single case (I liked these cases and more flexible).

One oddity was that with the new Cheetah just acquired when I did a quick initialize it still didn't have the SoftRAID driver. I still had to select "Install Driver." I was under the impression any time you initialized a drive, it also installed the driver, but not so?

Main issue though is I had hoped to see much better performance. Seagate rates the drive as 51-68MB/s and with two stripped volumes this is what I get?

Mirrored: SR: 53 SW: 26
Stripped: SR: 109 SW: 52

Is the B&W PCI bus holding me back? I'm stumped on why.

I can't wait to see updated firmware for ATTO's card which can't use 1.6.4 on B&W and 1.6.5a still has some problems (failure to boot in 9.2.1 on cold boots fully, slower than using 1.6.4).


[This message has been edited by Gregory (edited 19 January 2002).]

01-19-2002, 12:55 PM

After a Quick Initialize I always install the driver but have wondered about that myself since the driver window shows the driver already installed.

So, to test your discovery and my wondering, I wiped a G2 X15 with a Quick Initialize and rebooted, just in case a driver was already in memory. After reboot, I ran HDT and it showed the driver map already installed. Then ran Drive Setup and it just showed "not supported" which is what I normally get with a SoftRAID driver installed. Then I ran SoftRAID, it showed the driver installed so I did not update the driver, instead went directly to create a volume which it did without complaint.

How are you proving to yourself that no driver is installed? That dang UL3S is giving you fits in your B&W. Yes those striped numbers for SR are somewhat low even for 1.65, and the SW way to low. A single case should make a very slight improvement but not what you are looking for.

Two things come to mind other than the UL3S/B&W problem. First, have you checked the Mode Page Parameters in HDT Configure? If you don't have the latest version, version 4.0 still works with OS9.2.1 and 9.2.2. Both drives should be the same. I leave at default. Second, perhaps SoftRAID 2.2.2 is somehow corrupt. I would take your SoftRAID original on CD or whatever you have it on, install it, then update to 2.2.2 off of the SoftRAID site. Then start over completely to create your striped RAID. Quick initialize, install the driver (I use Maximum Concurrent IOs 256 and Memory Pool Size 1369 for between two and eight drives), and create the striped RAID (I use 256SU which equals 128KB stripes). k

[This message has been edited by kaye (edited 19 January 2002).]

01-19-2002, 01:01 PM
BTW, I probably won't be able to check your response until this evening. I have the duty with the grandkids and we are all going to see the Olympic flame pass thru Concord today. k

01-19-2002, 01:17 PM
How do I know the driver is not installed?

The 'icon' on the drive still shows the Apple logo, not SoftRAID.
When I go to create a volume, it will not and says that there is no driver.

Only after the "install driver" could I then create volumes and set the mode pages. But still low numbers - same as single drive.

FWB HDT 4.5.2 - I did the Configure and installed their RAID driver. Same numbers. But it does have a mode page for this model.

I bought SoftRAID electronic but I can reinstall. I think it is 2.2.2. I really thought maybe I had some FireWire junk in my system folder (but then I lost most of my drives yesterday and this is a very very clean system). I even did a low level which NO drive today needs (auto sensing reallocation).

In 4-5 months Seagate has gone from "002" to "004" and I hope that isn't a real problem. I do think the specs are different though, higher Mbps than before. (I just can't afford to buy two at same time).

Too cold for me to enjoy outdoors! I just watch the snow come down!


[This message has been edited by Gregory (edited 19 January 2002).]

01-19-2002, 02:20 PM
Hey gregory,
I installed and tested my UL3D with 2 X AtlasIIIs last week in my Quicksilver. I ran the ATTO raid tools for OSX and scared myself silly with some wierd problem the ATTO utility has recognizing the right drive to initialize. (Thought I'd trashed my ATA drive with all the OS9 stuff on it)

Anyway, I have performance numbers in OSX as well as OS9 in the QS so I am now going to move the raid over to the B&W and see how it matches up. I'll post back here this weekend the Softraid performance comparison for you to see if the PCI bus changes things very much. We'll see, I don't expect there to be a huge difference in numbers between the QS and the B&W.

I'll also test using FWB software.

Talk at you later when I have some figures.

01-19-2002, 03:19 PM

Can't tell you how much all that means!

Would you believe that I started this upgrade path a year ago?

Bought UL3S in Sept along with first X15, trouble w/ 9.2.1 booting, until ATTO confirmed it in their labs. Two weeks until 1.66 firmware probably. Two months for SoftRAID-X.

FWB Configure sets the number of caches to 28 rather than 3, and that it uses "128" in the hits (0-255 with "0" being the default in SoftRAID).

ATTO seems to feel that the UL3S and 3D are near identical and not an issue. Two drives should do fine on one channel but of course that 2nd channel would probably guarantee better numbers (for $150+ more). I expected 75-100MB/s SW if at all possible.

Extensions off helps a couple MB/s. I tried putting one drive inside and one outside, ATTO treats the same channel as two buses, not sure what impact if any or if that is "valid" except as mentioned yesterday, what if you forget to turn one on, the RAID is "broken" but not a big problem.

I removed all extra PCI cards hoping to find if there was a conflict there (FW card and 2940U2B which has performed well even if it tops off at 41.5MB/s).

I got up at 2 AM to try a brainstorm to figure this thing out and get it right http://macgurus.com/infopop/emoticons/icon_frown.gif


01-19-2002, 04:27 PM
I'll do the setup tonight after dark:30. I live in California and we wouldn't know what to do with snowy; panic in the streets, riots and whatnot when the amusement parks shutdown. I have a long list of daylight honeydo's and I'm just closing up the business now at noon.

I bought my UL3D last April, this is the first time I've had the dough for current drives. The AtlasIIIs had a better SR than Kayes X15 Cheetahs and worse writes. I'll have to spend some time figuring that out.

I only have a single Granite 2 device cable right now so I can only do testing on the single channel. Sometime next month I'll rectify that and be able to test on both channels.

Probably won't have results till 10:00 pac time but hopefully we both find the answers to the grail question. I'll email you screen shots if it seems interesting.

For now, post holes! The wife and my 1 1/2 year old demand I build a jungle gym NOW.

See ya,

01-19-2002, 09:21 PM

I see Ricks has the right machine, B&W, to test for you. I will butt out but FWB does confirm what the default Mode Page Parameters for both drives are with firmware 0002 and 0004, 28 cache segments and 128 hits. I leave the cache segments at 28 and set the hits to zero. Forgot about that. My brain is seized watching Blues Clues with the rugrats. k

01-20-2002, 01:53 AM
We have our work cut out for us. Here's the results of my ATTO UL3D with 2 X AtlasIII 18gig drives on a single channel.

SINGLE DRIVE with SoftRaid Drivers (2.2.2)

----Quicksilver 867---------B&W G3500-------

--PR 149.64-----------------148.33
--SR 107.76-----------------110.39
--PW 62.52------------------51.45
--SW 51.68------------------50.63

RAID0 with SoftRaid 2.2.2

----Quicksilver 867---------B&W G3500-------

--PR 147.95-----------------146.17
--SR 147.75-----------------145.93
--PW 106.23-----------------52.55
--SW 98.77------------------52.40

Not exactly a ball of fire on the G3. This is on the same order as your Cheetah results with depressing writes. We need to figure out why. If I hadn't seen the single drive results I would have assumed the writes were switching back and forth from drive to drive. Obvious that's not happening anyway.

I would expect drives with 8MB caches to write very well for at least 8 megabyte! A 2 drive raid0 ought to kick butt writing for at least 16meg. Almost like the cache isn't working during writes.

I also have no idea YET why the writes jump so much better on the QS. The write performance of the single drive would lead you to think the RAID writes would be pitiful, but they almost doubled on the QS, giving reasonably good performance numbers.

Hopefully I'll learn something about mode pages and adjustment thereof. Maybe that will help. The different settings for concurrent I/O and photoshop acceleration in Softraid changed the performance very little. I tried a fairly large range of concurrent I/O settings to no avail.

Kaye will have some thoughts on what we can try I'm sure..........


01-20-2002, 04:34 AM
Rick, I wish I did have some magic. I reviewed several of Breedon's articles and the most relevant was here http://www.xlr8yourmac.com/SCSI/ultra160SCSI/

The article started as an Adaptec card problem but, as you will see, turned out to be something else. A common thread I see was slow write performance, regardless of which card was used (Adaptec or ATTO) in B&W machines and Yikes G4. In the Yikes, the only way to get decent write performance was to pull the video card from the 66MHz PCI slot and put the SCSI card in there, relegating the video card to a 33MHz PCI slot. Looks to me that there is something low level in the mobos of at least B&W and Yikes and even one Sawtooth G4/AGP report. I also see that no one arrived at a fix for the B&W.

I have only tried the two UL3D cards I have in my G4-800DP and PowerTower Pro with xlr8 G3-500 and can't remember at the moment if I tried one in my S900. Neither boxes exhibit the slow write performance with the ATTO card.

Wish I had more to offer. k

01-20-2002, 04:52 AM
Mark James 'alluded' to how the B*W was more like a beta with little exposure for developers to work on and 'challenged' - just how much I never dreamed. I thought maybe something was fried.

So I sort of wasted a lot of money.

And I thought iDE was the only problem!
Then learn about FireWire devices not working with built-in but okay with a PCI FW card or combo usb/fw.
Limited to two SCSI cards.

Okay, I was going to flash back to 1.64 and see if that helps but no need to. And no need to pull out more hair.

Would be nice to see a report update on b*w performance issues.

Thanks rick, kaye and let's hope moving it to 66 mhz slot helps. At least that is PCI. I'd put off a new Mac longer if not for this tidbit.


01-20-2002, 07:01 AM
I CANNOT boot with my RAID connected to ATTO in the 66 mhz slot! This is terrible. I had to try booting with the drives off or it would freeze or no volumes of any drives would show up on desktop. Part of it seems to be Conflict Catcher 9 which must scan bootable volumes for system folders.

I'm going to try 1.64 firmware to see what that does.

What should have been easy is taking hours and having to run Disk Warrior and Norton as well as moving stuff around. Thankfully I have a 2nd 'puter to be using or I couldn't get online etc.

Maybe I should take my two 2940U2B and try to create a pseudo two channel RAID.

Also, I wish that ATTO had taken their board back when I first reported problems. They would not. Deb would in the first 30 days, which is how long it took me (two weeks) to pin down the problem symptoms, then two weeks for ATTO to reproduce and confirm, then get a beta firmware to me which seemed to partially help. I'm too trusting. Also, to say that the UL3S rocks in the Yosemite in any slot is going too far. Maybe it does but not with any OS beyond 9.1 (confict with firmware shows up in 9.2.1 and later).

Of course any new Macs with DDR and whatever are sure to have surprises as well. G4DP has its, every mac has quirks to its personality. It really is enough to wonder about. Just short of going to the dark side.

Wish me luck ;(

[This message has been edited by Gregory (edited 20 January 2002).]

01-20-2002, 07:18 AM
The reason UL3 won't work in 66mhz slot is part of the card hangs over the end of the short slot - needs the longer PCI slot to fit and work it seems. 2940U2B fits but won't boot with drive hanging off that slot.

2 x 2940U2B cards, X15 on each card in 33 mhz slots
SR: 96 SW: 51
So that doesn't break the 53MB/s barrier either.


[This message has been edited by Gregory (edited 20 January 2002).]

01-20-2002, 09:45 AM
The UL3D should work in the 66 mhz slot even though it is too long It is designed to work that way but it will not reach it's max speed in a short slot (or so I have read)

You seem to have determined the issue and I have nothing to add that will help but you mention that a B&W only will take 2 scsi cards......

I had 3 scsi cards in my B&W. Initially I had a pair of JackHammer UW cards and an OrangeMicro 930U ultra narrow card then later I removed one Jackhammer and inserted an Initio Miles 9100UW. No issues in either config.

01-20-2002, 10:52 AM
Someone from SoftRAID told me there is a 4MB ROM limit on the B&W so it may depend on how much memory each card needs - I tried to use two 2940U2B and ATTO UL3S.

Maybe I didn't have the card seated properly first time I tried.

SoftRAID locked up when I tried to open Date & Time before clearing an out of sync (one of two drives mounted). The bug in the firmware is hitting me. I don't trust the open firmware, or why it is so much trouble.

Conflict Catcher was set to try to mount all drives on startup and it sure feels like that was also causing some problem. Shouldn't but then... someone mentioned that they found a hard to identify extension conflict causing freeze when the desktop shows and drives should mount.

My system is sitting here and when drives are on, the system won't boot now. I hate this B&W for all its hardware issues. Seriously. I don't trust ATTO, I don't like the delayed long boots now in 9.2.1. Were/are you running 9.1 or I'd assume by now you have 9.2.2 also.

Comand + Option O + F isn't even dropping into open firmware (but did get a startup screen going

only the clock doesn't show when Finder Desktop creates menu bar and before drives start to show/mount - which is the original problem with this ATTO card.

ATTO says that the UL3S and 3D would not make a difference - BUT, you are using the UL3D and not seeing a problem so I tend to doubt ATTO's answer (and they seemed more interested in getting rid of me than solving an issue - they said I was the first to bring to their attention a problem with 9.2.1 and their card/firmware. They hadn't done any inhouse testing of their board or driver with 9.2.1.

Seven hours w/o any bit of success - and that's just this AM, doesn't include all day Saturday or Friday or previously.

01-20-2002, 11:30 AM
I sort of have to give up. 9.x just is crab and had to boot into OS X CD and destroy the RAID and either use the ExpressStripe (prefer not to) or Apple (probably has bugs still) just to clean things up. My system works best if I just use OS X. Once installed it seems to have 'done' something to OF and more to say the least. As well as to have RAID in one and not the other.

ATTO should work fine. At least I can boot with UL3S in 66 mhz slot, no freeze in 9.2.


[This message has been edited by Gregory (edited 20 January 2002).]

01-20-2002, 11:31 AM

There is that 4MB limit on some machines but I don't know which, only that my PTP and S900 have that limit, and that Darin Ames had that limit in his 9600/350. And I was thinking that it was something other than ROM but I forget. Darin was running three video cards and a RAID and had all six slots filled up. Installing the third video card I believe was where he started having problems. I do remember the ultimate solution in his case. He created a boot partition in HFS (not HFS+). HFS+ puts more into that 4MB which put him over the limit. Booting in HFS got him back under the 4MB limit. I thought it was a vintage Mac issue, but I guess not.

You mention CC, "Conflict Catcher was set to try to mount all drives on startup and it sure feels like that was also causing some problem." That feature I do not use. It is meant to mount removables and way back I spent a week diagnosing a problem I had getting to the desktop successfully, much earlier Mac OS and CC version. I tore my hair out and finally got to troubleshooting CC and discovered that was my problem. Unchecking that "feature" solved it for me. But you say "was set" so I assume you disabled it. k

01-20-2002, 04:54 PM

Not sure if some of those questions were directed at me or not but....

When I had the three scsi cards installed I believe that 8.6 was my OS (pre OS 9) Also I think by the time I went to OS 9 I was using 2 scsi cards and a second video card. I no longer have the B&W though I now have a Digital audio with a UL3D with a pair of x15's 18gigs on one channel (raided 125-135MB a sec) and a single 10k 74gig cheetah on the other channel as a boot drive

01-20-2002, 05:50 PM

Well, yes, some of my comments were indirectly. I ran into trouble using the 66 mhz slot. ExpressStripe didn't work correctly and an Apple Mirror RAID didn't complete successfully but later said it was "okay" but you can't even use Disk First Aid (X) on the volume and in both cases copying files fails.

Seems that the B&W definitely has a threshold wall of 53MB/s for writes.

ExpressStripe did see higher numbers with 2 drive RAID0 and worked in 33 mhz slot. Maybe when they have more features or SoftRAID X is out can revisit.

I opted for two single drive volumes but w/o OS 9 driver. This system is OS X only at this point. I don't need to boot into OS 9 I can use 7300 for 9.1.

I do find differing results perplexing and why different combos work or not. I thought I avoided that getting a late rev 2 B&W model. Maybe the G4 firmware block and patch to remove has something to do. My keyboard (Apple Pro, Apple ADB) neither show a drive list when holding down Option key on boot. When I tried to boot into open firmware (CMD-OPT-O-F) didn't drop in to black screen to reset-defaults.

The more I do, moving around cards, etc. seems to create mischief. I had trouble even booting after a failed boot and only the OS X CD (10.1) seemed to help. If the ATTO 1.66 firmware doesn't improve things, I wish they would take the card and exchange for a new one.


01-20-2002, 10:32 PM
Hi All,
Spent some time today with the B&W configuring the mode pages on the raid drives. Can't say as I accomplished any real increase of significance. Hard to say what actual gain would be had changing them anyway. Most I got was 2 or 3 MB/sec increase in the write.

Also, first time it hit me, the Acard ATA133 Hardraid installed on the B&W is limited to 50 MB writes. That with 70ish reads.

All this leads me to wonder if we could double the write performance by running two 2940U2B cards or Miles2 cards. That should net us close to 100MB/sec writes if indead the PCI bus limits work this way.

Maybe I can get together with Kaye sometime and combine hardware to accomplish this test without spending dollars? I think he has two Miles2 cards and I have the B&W of course. WOuldn't take long to satisfy the questions anyway.

Any other ideas are welcome. I don't think I can raid four ATA drives on two ATA133 hardware raid cards, OR can I. Does Softraid treat the ATA133 hardware raid as a scsi device that I could stripe the stripes? What would you call that RAID0+0?

There has to be some simple work around for the PCI limitations, trying them out is the fun part.


01-21-2002, 03:11 AM
If this http://www.acard.com/eng/product/adapter/mac/ide/aec-6880m.html is any judge, scroll down the page, your writes should also be 70ish with the Acard.

Rick, I can send you the dual Miles2 cards. The 3.06 firmware on both cards now works in OSX but in OS9.2.1 or 9.2.2 sustained writes for a striped RAID sucks because of alternating access instead of simultaneous access of the drives. Don't know how they will perform in a B&W. 3.06 is really for OSX. Even with the old firmware, 1.06b, the cards really work best in vintage Macs.

Email me your address and phone number. I'll ship them to you. k

01-21-2002, 06:34 AM

None of the cards/drives I had in there would even approach that 53MB barrier even in a raid so I never saw these issues

The B&W does not support the Option button boot that results in the Open Firmware Drive selector screen You have to have a Sawtooth G4 to use this feature.

01-21-2002, 08:36 AM
I have two 2940U2B cards and tried that. Got 56MB/s so only slight boost. That also really surprised me to say the least. I thought I had researched and knew what there was on B&W and on www.xlr8yourmac.com (http://www.xlr8yourmac.com) but I never saw that one report (http://www.xlr8yourmac.com/SCSI/ultra160SCSI) mentioned earlier.

I think it'd have to get the UL3S working in the fast 66 mhz slot to get past this 'wall.'

SoftRAID does treat anything on ATA PCI cards as SCSI so that should work. If I even get a QS or better, at least I'll be ready! http://macgurus.com/infopop/emoticons/icon_wink.gif

Damien, there seem to be some B&W models where people are reporting ability to use Option on startup, but like you I never did. And now, I can't even get to OF screen. Maybe OS X installer modified that ability or access. There were hours when I couldn't boot and I always wonder if I'd killed this critter.

At least I'm not imagining all this (sleep deprived, caffeine haze, dreaming this all up). To think that the 10k Cheetah ST318406LW (http://www.seagate.com:80/support/disc/specs/scsi/st318406lw.html) yields 49-63MB/s, enough for any B&W. And for $235, too. Would have been better off with one large drive.

I will say that OS X rocks when it comes to copying gigs of data, seems nearly 2x faster than 9.2.

Ricks, I'd love to hear what UL3D achieves... you nee a 2nd data cable?


01-21-2002, 12:58 PM
I guess that your 2940U2B experiments about covers dual card raids, thanks for the info, I'll spare Kaye shipping the Miles2s.

I'll set up to try the second channel, I would doubt that changes anything. (There, I said it. I've been wrong on everything else so far) I'm running 1.6.4 on the firmware but not booting off of it, I'm booting from the ATA raid.

I ain't gonna give up quite yet. There has to be a work around that doesn't cripple the graphics card.

One thing for sure, Apple missed the boat when they claimed the B&W firmware upgrade 1.1 fixes PCI performance issues.

Do internal GD TPO cables work in GD external cases? The next direction I want to go in is an external 2 drive case to mount 3rd and 4th AtlasIII drives in when those $ become available. If possible, I would prefer to purchase the data cable that would fit in the external case. I don't want to purchase a cable and terminator that would not be used in that setup.

That is unless the external case comes with a cable that I can temporarily use internally to test the 'dualness' of the UL3D? I could then just get the case and use its cable.



01-21-2002, 03:04 PM

The special Granite TPO Enclosure Cables & Hardware are located here http://www.macgurus.com/shoppingcart/obj_show_page.cgi?mgscsienclosures.html about 2/3rds down the page and are the same as what Granite offers on their website. I called Granite last week to ask whether the GD7031 Dual 68-pin Int TPO LVD Ribbon Encl. Cable would fit in an 8-bay Burly since I want to create four channels in it. The answer was no, the 8-bay is too deep from back to front. Needs the GD2682 Quad 68-pin Int TPO LVD Ribbon Encl. Cable or bigger, or a custom built cable which they would be happy to do. Just going to add two more GD2682's. These cables are sized for the Burly you intend to use and are the same as what Granite sells.

The enclosures come with cables, in the form of internal 68-pin PVC cabling for the Burly you would want, not what you want for LVD though. k

01-21-2002, 03:51 PM
I moved the drives back (again) inside B&W. So I have Granite data cable for ATTO or the larger 68-pin. I also have some pre-built cases, they look to have the proper ribbon but they came from hypermicro PDE cases. I could ship so you could use them for a couple weeks.

Current setup:
ATTO UL3S in 66 mhz slot
Atlas 10k III for OS 9 and X.1.2
Will create a RAID volume of the two X15's next.
Pulled 2940U2B. Was a way around any booting issues in 9.2.1 but trying to simplify.

"to improve PCI performance" is sort of like RAM firmware? or was a ruse to block G4 cpu upgrades and trick users into installing it.

I'm sort of scared to even try anything in OS 9 after all the trouble and now that it is working and have OS X as default. Would be nice to do it, just to know. Then scrap it and go back to OS X and not look back.


01-21-2002, 06:17 PM
Thanks Gregory,

I think since I intend to get a burly that it's just as easy to get it now and still wait on the drive purchase. Then I can install the drive externally with parts I will need soon. VERY soon. Not worth alot of trouble to ship enclosures back and forth when I need them next month.

I have never purchased/setup an external. So just to make sure I am getting just the right stuff I'll list the things I read from Gurus.

GD4911 Ext. 68-pin .8mm to 68-pin MicroD 3-ft. Cable
MAP3021 Dual-Bay 3.5-in. Full-Height SCSI Enclosure
GD7031 Dual 68-pin Int TPO LVD Ribbon Encl. Cable
GD2015 68-pin MicroD LVD Dual Mode Terminator

If this is the correct components I will make my order. If not, the Magicians going to have to simplify the Burly page for people like me. http://macgurus.com/infopop/emoticons/icon_smile.gif In his spare time of course.

Am I making a mistake with the 3.5 inch bays and AtlasIII? Hate to find out it's not enough cooling.

Thanks for you guys hep!

01-21-2002, 06:32 PM

I agree that the order setup page is daunting. I read it, printed it out, got a headache, then bought the best I could - from hypermicro! I tried putting Atlas in 3.5, don't, get the 5.25 case, better air flow, easier fit, and they will appreciate it in the long term.

I have spare cables, cases, terminators as I swap and test constantly.

ATTO in 66 mhz slot, internal, using Apple's RAID.
80MB sample, 8MB transfer size.
33 mhz slot and external:
Min: 45MB Average: 51MB Max: 56MB
66 mhz slot internal:
Min: 68MB Ave: 75MB Max: 99MB/s

Those numbers drop 3MB/s with the RAID 1/3 in use.

Once I can put anything in black and white I want to add a note on xlr8yourmac as to B&W etc.


[This message has been edited by Gregory (edited 21 January 2002).]

01-22-2002, 03:54 PM
ATTO says that there is a 66 mhz model, and 33 mhz, and never to put 66 into 33 mhz PCI slot. So I assume it is 33 and doesn't benefit from the video card's slot.

And it is giving me way too much trouble.