PDA

View Full Version : Slow RAID 0 performance



seaav8r
01-13-2002, 01:34 PM
I’m stumped…

I have a dual 10k Cheetah RAID 0 in my beige G3, and I can’t get better than 25 MB/s performance. I’ve probably read every SCSI and RAID post on this site over the past two years and virtually everyone is getting better performance—what am I doing wrong?

Here are the details

Beige G3/266 DT with the following mods:
XLR8 G3/500 running at 533
512MB (J3 256, J4 128, J5 128) Gurus RAM
PCI Slot A1 = Initio Miles 2 (firmware v. 3.06)
PCI Slot B1 = ATI Xclaim VR 128
PCI Slot C1 = RATOC USB/FireWire
Two 9.1 GB Cheetah ST39103LW (rev 2)
SoftRAID 2.2.2 RAID 0
One 28 GB Barracuda ST328040A on OEM IDE bus (Boot Volume)
Granite Digital GD1200 cable and GD2015 terminator
OS 9.2.2 and OS X.1
OEM CD, no Zip (removed to make room for 2nd Cheetah)

Now the problem. I’ve tested performance using ATTO, MB 5, and QuickBench. All show about the same performance. Extensions on or off has little effect.

MB 5 Scores:
Disk 2308
Publishing Disk 2074
SR 1024k 39.6 MB/s
RR 1024k 20.0 MB/s (this is really low)
SW 1024k 37.0 MB/s
RW 1024k 30.7 MB/s

Quick Bench 1.5 Scores:
Extended Read 25.0 MB/s @ 8MB
Extended Write 25.5 MB/s @ 9MB
SR 256KB 43.4 MB/s
SW 512KB 40.1 MB/s
RR 1MB 19.4 MB/s
RW 1MB 20.2 MB/s

All tests run in OS 9.2, on an empty SoftRAID 18GB volume (one partition). Both drives freshly initialized. Also ran tests while booted from 9.1 CD, no effect.

This is not a “mission critical” system. I’ve enjoyed tweeking it, but I’m frustrated that I can’t get any better performance. I’ve tried methodically changing every parameter available in SoftRAID or SmartSCSI, with only minor effect on performance. Any suggestions would be greatly appreciated!

TZ
01-13-2002, 02:17 PM
Maybe the PCI bus is part of the problem. Along with technical limitations of those drives?

INTERNAL TRANSFER RATE (mbits/sec)________193 to 308
INTERNAL FORMATTED TRANSFER RATE (MB/sec)_29.5 avg
EXTERNAL TRANSFER RATE (mbyte/sec) _______40 Sync
Low Voltage Differential(LVD) _______80 Sync
SPINDLE SPEED (RPM) ______________________10,016
AVERAGE LATENCY (mSEC) ___________________2.99
BUFFER (/optional)________________________1024/4096 KByte

A new 10k Cheetahs is rated for 51-63MB/s *each* meaning one drive would outperform many older drives even when stripped. ~$229 on MacGurus page.

Gregory

seaav8r
01-13-2002, 02:40 PM
There is nothing like writing down your thoughts to provide clarity...

After hitting the submit button on my original post, it occurred to me that I was using a beta version of the SmartSCSI firmware (v. 3.06). I re-flashed with v. 1.06, and my write performance jumped up into the 40's. Now QuickBench shows extended read and write speeds of over 49 MB/s. That is 100% increase just due to firmware. I guess v. 3.06 isn't quite ready for prime time. I still think performance is a little slow, I'd like to see speeds in the 60's, but at least my RAID speed is now faster than a single drive!