View Full Version : JackHammer+SoftRAID 2.2.2+ OS 9.1=Probs?

11-21-2001, 02:12 AM
I've been having unexplained/unresolvable system freezes with my PowerTower Pro/PowerLogix PowerForce G3 400 system for some time now, and I'm beginning to think the PCI JackHammer SE I'm running my three disk UW cheetah RAID with is the source of the trouble. I'm using OS 9.1, the latest (last ever, probably) JackHammer control panel 1.4.5, SoftRaid 2.2.2 and booting from the RAID. I finally realized that when I freeze up it's often just as I am hearing the "buzz" noise of the cheetahs being used by the system. Is the JackHammer control panel 1.4.5 compatible with OS 9.1? I know it was good up until OS 9, but I can't find any info about 9.1. Does anyone know? If anyone else is still using their JackHammer with 9.1 succesfully, please let me know.

Thanks - Hap

11-21-2001, 03:31 AM
I had absolutely no problems with my PCI JackHammer SE even with OS 9.1. I switched when I decided I needed OS X and the JackHammer just wouldn't work.

I did find that I would have problems with data errors through the JackHammer if the card was located anywhere other than the top-most PCI slot in my PowerTower Pro though.

11-21-2001, 01:58 PM
Thanks for the info lasvegas. The JackHammer in slot A1 (top slot, nearest the daughtercard). A search of this site (something I should have done before posting maybe) has turned up numerous reports of success with the JackHammer and 9.1. I really believe I'm having a RAID problem though. In addition to the random freezes, the RAID all to frequently crashes, requiring a boot from the Norton Utilities disk and several passes to repair the problem. I've tried all the standard stuff (desktop rebuild, PRAM zap, CUDA reset, testing with several drive test utilities, etc.) I got this JackHammer as an OEM Apple unit so I have no documentation. I'm wondering if I have the control panel configured properly. Here's how it's set up:

Old Driver Support - on
Reset Bus at Startup - on
Very Large I/O support - on

Termination - automatic
Initiator ID - 7-standard

I have two other PCI cards, a Rage Orion in the lowest slot and a Belkin two port USB in tyhe slot just above it. I've also tried new scsi cables, reinitializing the RAID, and checking ID and termination jumpers on the drives. Only the last drive is terminated and set to get termination power from itself (factory default setting).

The SoftRAID drivers are configured like this:

Maximum Concurrent IOs - 512
Memory Pool Size - 1096
Write Acceleration - on
Read Acceleration - on
Photoshop Acceleration - on
Buffer Full Ratio - 0
Buffer Empty Ratio - 0
Write Cache - enabled
Number of Cache Segments - 1

Any info from you Mac masters out there would be appreciated. I'm crashing about once every two weeks and freezing several times a day.

Thanks - Hap

11-21-2001, 02:33 PM
Your setup is fine. I'd turn off "Old Driver Support" though. This is a patch to handle old drivers that had problems with SCSI addresses above 7. Shouldn't be needed with SoftRaid. You might consider updating the drive with SoftRaid also. This would simply re-write the driver data and simultaneously correct any possible partition table problems.

BTW: I would also move the video card up to slot B1. I've found accelerated video works much better on my PTP in the upper slots.

11-21-2001, 11:28 PM
Hey Hap,

You should also try setting the drive(s) to Term Power From Bus. The JackHammer should supply Term Power to the bus and any other sources of power on that line are a setup for unwanted stray voltages. This can cause the problems you are seeing. It sounds like you have up to four sources of term power if each drive is at factory default to supply its own term power. This default was more appropriate for PCs than it was for Macs. The JackHammer control panel 1.4.5 was certified up OS 9.0.2 but many people have had success in OS 9.0.4 and OS 9.1.


11-22-2001, 03:24 PM
lasvegas/MacMikester -

Advice taken. I have moved the Orion to B1 and the USB card to C1 and reset the last drive in the RAID to term. power from bus. I also loaded new SoftRAID drivers into the RAID drives. Of the three drives, only the last one had any termination or power jumpers in place, so at most there were two sources of term. power on the bus. Still enough to cause problems though. The result is that things seem to be working better. The system seems "snappier" overall and is stable (for now, anyway). I still get a freeze when I have Eudora and Netscape open and try to open Word 98, but I found that changing the sequence of program opening usually lets me get all three running at once. I have 576mb of memory so I don't think it's a memory problem. The best news is that the freezes at startup seem to have disappeared. Thanks for the tips, things are better, but not quite right yet, so I'm open to any other suggestions.

- Hap

11-23-2001, 12:13 PM
Hey Hap,

Just to dot the eyes and cross the tees on the term power issue: All your drives (including the ones without a Term Enable jumper) should have Term Power From Bus jumpers set. Having no Term Power jumper at all is an undefined config and I suspect that this does not ground the Term Power circuits on those drives. This might allow stray induced currents to interfere. Term Power From Bus on most all of the Seagates is one horizontal jumper across the bottom pins of the two vertical TP pinsets. I think you should do this just to absolutely rule out Term Power issues if you continue to have problems.

2nd issue: Do you have all the update patches to Word 98 (or Office98 if you have that). The Office Manager window bar control app for Office was fairly problematical until the last update version 9.0 (2809).

[This message has been edited by MacMikester (edited 23 November 2001).]

11-23-2001, 07:57 PM
MacMikester -

I tore down the RAID and added jumpers to the two other drives setting them to term. power from bus. The system booted fine and I ran Disk Doc with no problems reported. I then ran NAV and it hung during the check. After pushing the reset button, I had my old familiar and frustrating crash behavior: reset from keyboard or push reset button, chime, gray screen, SNAP! - screen goes black, return of gray screen with flashing disk/question mark. I restarted from an external drive and ran Disk Doc. It saw the RAID and reported several major probs. and hung twice when I tried to repair them. At this point, I reinitialized the three disks, reloaded drivers and created a new volume with SoftRAID. I restored the disk's info from tape, rebuilt the desktop and zapped the PRAM. I then booted from the RAID and the system checks out fine, but I'm still having occasional freezes. They are less frequent, and I haven't had a freeze during start up yet, but they're still there. When things lock up, I can still move the pointer with the mouse, but nothing else works. As far as the Word problems, I have all the Office 98 patches in a folder. I reran them and the problem seems to have disappeared.

Any other suggestions? - Hap

11-24-2001, 12:30 AM
Hey Hap,

You are narrowing in the problem but I guess we can't quite be sure what it is yet. Two possibilities come to mind: a) the JackHammer software/firmware is showing an incompatibility with OS 9.1 (which was never tested by FWB/Logicstream before they went under) or b) you have a corrupt system which has made it to your backup. You could try a clean system install to see if it clears up the freezes.

Can you boot from a diferent system disk (not on the array) and still read/write from/to the array without feezes?

Reaching farther for answers: Maybe your freezes have nothing to do with the JackHammer. You could try using the XLR8 software for your PowerLogix G3 rather than the PowerLogix control software. The XLR8 software works with all upgrades and is superior, but it now costs money for folks who don't have an XLR8 upgrade CPU. Might be some kind of a conflict with the PowerLogix control software. When did the freezes begin relative to any other major system changes? After the CPU upgrade? After the OS 9.1 upgrade? When was the last time everything was perfect with the RAID?

12-03-2001, 02:16 AM
It's been awhile, so I thought I'd post an update. I've replaced the JackHammer with an ATTO UW Apple OEM card pulled from a G3 and gone over all three scsi busses on my PTP several times. I gave up a few megs per sec by pulling the JackHammer and going to the slightly slower ATTO card, but gained alot of stability, not to mention support for OS X. I found an over termination issue and two sources of term power on the external scsi bus and took care of that. I can't believe how screwed up my scsi busses were. All three had issues at the start of my troubleshooting that are now fixed. All I can say is, don't assume things are set anywhere near right by the manufacturer when it comes to scsi.

I've only been running a few days with the ATTO, but everthing seems far more stable and I have yet to have a crash. Freezes only seem to occur occasionaly with Netscape, but that's unfourtunately common.

One interesting side note about the ATTO card. I used ResEdit to hack the Apple OEM card updater to flash the ROM with retail ATTO ExpressPCI PSC firmware (the info on how to do this is available at several sites). It worked fine, but tests using the ATTO benchmark utility showed a 10 mbps DROP in performance with the retail firmware installed. I hacked the ATTO updater and reinstalled the APPLE OEM firmware The card now is restored to its OEM ROM status and I got my 10 mbps back. Weird. Maybe I had the card configured incorrectly with ExpressPro-Tools 2.7. Has anyone else experienced this? ATTO's site has a manual for ExpressPro-Tools 2.7, but the file is screwed up and I can't seem to get it to open in Acrobat after I download it. Anyone have any advice for tweaking an ATTO ExpressPCI UW PSC card with ExpressPro-Tools 2.7?

Thanks for all the help, you guys are the greatest.

- Hap