PDA

View Full Version : preventing HD spin down?



Ton
07-11-2001, 05:19 AM
Lately, for no apparent reason, the disks in my Gurus built external raid 0 spin down at irregular intervals, often causing application read/write failures and a crash as result.
Setup: 4 x 15k cheetha's / Ultra Atto 3D / Granite cables and active terminators / Softraid 2.22 / PM 533 MP/OS 9.1/ energy saver not installed. What is happening? Is there any way to prevent the Cheetah's from spinning down? This is a serious problem and any help is much appreciated.

kaye
07-11-2001, 05:48 PM
Hi Ton,

Somewhere in either PRAM or NVRAM is Energy Saver info. If you zap the PRAM or PRAM/NVRAM (not sure which) you reset the Energy Saver prefs back to the default 30 minutes, regardless of whether the Energy Saver control panel is installed, disabled, or trashed.

You need to get the Energy Saver back, reset your prefs to Never, then you can disable the control panel, but you will need it again if you zap PRAM or PRAM/NVRAM, again I have forgotten which. I just keep the control panel active. k

Ton
07-12-2001, 06:27 AM
Thanks for the reply Kaye.

No luck zapping pram and vram.
In fact it looks as it's getting worse, sometimes all is well for half an hour and than one or more disk's spin down several times within 10 minutes.
I tried the following:

Reinstalled Softraid drivers
Zapped pram nvram
Installed energy saver and set to "never spin disk's down"
Removed energy saver and zapped pram and nvram again, installed sleeper from St. Clair and set to "never spin disk's down"
Resetted scsi busses with Atto Express tools

The problem is on one of the two channels because only one of the two diagnostics from the granite terminators are blinking when one or maybe two disk's are spinning up again.
(The ACK and SEL leds)

I sure hope it's not a hardware problem

Thanks Ton



[This message has been edited by Ton (edited 12 July 2001).]

dragon_x
07-12-2001, 08:26 AM
I've often suspected that HDs have a spin down/powersaver cycle of their own. I have several RAID-0 drives but they are only connected to a single channel MilesU2W. Occasionally I will only use one raid volume for an extended period of time. So when I access a file/app on another volume I get a HUGE delay as the old drives start spining up. This is annoying but I've never had a crash I could attribute to this.

I would check your SCSI bus. You may need to isolate some of your drives.

GL

------------------
Life in the fast lane leads to:
The Resteraunt At The End Of The Universe

kaye
07-12-2001, 03:29 PM
Ton,

You misunderstood me. After setting your Energy Saver prefs, reboot and don't zap PRAM/NVRAM, because doing so resets the Energy Saver prefs in PRAM/NVRAM back to default 30 minutes. You are putting yourself in a vicious circle by zapping after setting your Energy Saver control panel prefs to Never.

Just use Energy Saver and be done with it. Have I made this clear now? k

Ton
07-16-2001, 10:57 AM
Hi Kaye,
The problem disappeared even mysteriously as it started, however thinking back, I have a clue that it all started after a forced reboot when I mistakenly pressed the power button instead of the reboot button which makes the latest powermacs go to sleep, if you have set that in your Energy saver prefs that is. Anyway, it seems to be working OK again during the last two days. Thank again.

tekcan
08-18-2001, 11:14 PM
Hey Kaye and all...I read this post and had to have a good laugh, I have been having my drives spin down after 30 minutes, sometimes when I least needed it. I assumed it was something to do with XLR8's powersaver in the control panel, did I get a laugh when I realised it was energy saver. I had no idea zapping the PRAM would reset that puppy, I had long before disabled that control panel and never thought it could start up on it's own. Sure enough, reloaded the control panel, selected "never" and restarted. haven't had a spin down since...

Just goes to show you always know terribly less than you think you do....and ALWAYS BROWSE THE GURU FORUM on your days off...you never know what you may find...

[This message has been edited by tekcan (edited 18 August 2001).]

magician
08-23-2001, 03:00 PM
terri!

how the heck are you?

http://macgurus.com/infopop/emoticons/icon_smile.gif