PDA

View Full Version : G4/9.1/Sleep



cliff
04-18-2001, 09:29 AM
I have one of the first AGP G4's with an ATTO UL2D board set up with 2 Cheetahs in a striped setup using SoftRaid 2.2.2.
With 9.04 using Sleeper I could control the drives sleeping or not very easily.
With 9.1 the drives sleep whether I like it or not.
I've tried deleting prefs, installing Energy Saver setting the controls to never then deleting prefs, zapping PRAM and about every combination of settings I can think of.
Am I missing something?
Also, with 9.1 If I have Energy Saver activated, the drives will sleep (no matter what my seting is) and the cpu only wakes with a hard restart.

I've lost control of my sleeping habits.
Thanks for any input.

kaye
04-18-2001, 11:12 AM
cliff,

Just a few comments and what little I found on MacFixIt. Sleeper may not be OS9.1 compatible. Delete the prefs before setting the Energy Saver. Zapping the PRAM will put the Energy Saver prefs back to 30 minutes in PRAM. So, don't ZAP PRAM after setting the prefs in Energy Saver.

From MacFixIt:
Energy Savers settings also not "sticking"? A user reports that enabling the "Mute sounds while computer is asleep" checkbox under the Advanced tab of the Energy Saver Control Panel does not silence the hourly clock chime. We too have had some problems getting other Energy Saver settings to "stick." Not all users have these problems however. Trashing the Energy Saver preferences may be a fix according to Mike Charbonneau.

Bernd Bruegge had a wake-from-sleep crash that he linked to QuicKeys 4.0 and Apple Monitor Plugins 2.04: "Disabling either one fixed the problem. Upgrading to QuicKeys 5.0 also got rid off the problem."

Upcoming Adaptec driver to fix deep sleep problem with new G4s A reader received a new Power Mac G4/533 with an SCSI card installed by vendor. It is an Adaptec 2906 AVA SCSI-2. He writes: "This card - and the faster Ultra SCSI Adaptec 2930U card installed by Apple as BTO - are both not compatible with the version of Energy Saver that comes with OS 9.1 in these G4s. Adaptec is aware of this. They advise not using Sleep until they release v1.3 of their SCSI driver - hopefully soon. I told Apple, who helped me solve this."

Unfortunately, I don't see a silver bullet anywhere. Luck. k

cliff
04-18-2001, 11:34 AM
Thanks for the reply.
Sleeper doesn't state whether it's 9.1 compliant or not. The newest version makes a point of stating various fixes for G4's though.
The thing is if I just use Energy Saver, the drives always sleep (even when I say never) and they won't wake (hard restart).
I know there must be some combination that I haven't tried yet. Last night I thought I finally had it figured out, then after two hours the drives clicked off. Why 2 hours when I say Never? Then inexplicably they powered right up again.
Gremlins?
Also-would there be any reason at all to re-intializing my RAID setup now that I'm using 9.1? I know it shouldn't matter, but I'll explore all possibilities.

Thanks.

MacMikester
04-18-2001, 01:55 PM
Hey cliff,

I remember reading at MacFixit a while ago about the the issues with Energy Saver Panel preferences not "sticking" and so forth. I'm pretty sure that this problem and some other related weirdness was tracked down to deletion or disabling of the Multiple User and or security software system components. If you have disabled or deleted these OS 9.1 components, re-enabling or reinstalling should fix your sleep problem. I don't recall all the problems and all the software that was involved, but I do remember that some of the problems caused by removing the system components were not very intuitively related to the the function of the components. I run OS 9.1 and I simply re-enabled everything I disabled without necessarily using it (the Multiple Users stuff for example). All is well now.

Regards

cliff
04-18-2001, 02:13 PM
Your point about Sysystem file deletion is a good one.
I found that to retain the General Control Pref of showing or not showing the desktop in the background the Multiple User Extension has to be loaded. That was one of the first things I deactivated. I also deleted Keychain, etc. so I'll look into reloading those if I want to explore further.

My latest procedure was to:
-Zap PRAM
-set Energy Saver hard disk to "Never"
-restart with energy Saver deactivated
-delete the Energy Saver pref
-set Sleeper to not Sleep or spin the disks down

For a couple of hours while I was out the drives didn't sleep!
Now of course I'm leery to try anything to make the drives sleep thinking I might mess things up.

Thanks for the input.

magician
04-19-2001, 05:22 PM
Cliff, gotta say, we don't ever have these sorts of problems here....I'm thinking you probably just need to enable most MacOS stuff, set Energy Saver appropriately, and then just leave it alone.

you should certainly ensure that you are running the latest version of the ATTO firmware on your board....unless it has Apple firmware on it? In that case, using Software Update to keep everything up to date should take care of that. I would also update drivers using SoftRAID 2.2.2. Just update the drivers. No need to reinitialize, generally.

cliff
04-19-2001, 09:08 PM
Interestingly enough the very last firmware upgrade from ATTO was in their words "optional" and said that if it didn't work, I could revert to the previous version. Lucky for me I could because the upgrade disabled my external channel.

Another question I have is that even though I use SoftRaid (2.2.2) as my formatting software I notice that in ATTO Express Tools you can change the Page Mode settings for the drives. Is this something to avoid or play with?

Thanks

MacMikester
04-19-2001, 10:44 PM
Hey cliff,

It's really your call, some changes are safe but I can tell you that I have made mode page changes with ETP in the past on my SoftRaid driven drives which prevented the drives from being mounted. The drives could not be mounted and fixed with ETP and I had to resort to a FWB Configure to change back to defaults. Took a while to figure that out.

dkemme
05-23-2001, 11:05 PM
I think I have had a similar problems with OS 9.1. I have just now had five locks on Filemaker Pro server, similar to what I have seen when the drives go to sleep. I'm going back to 9.0 till it is resolved though.