PDA

View Full Version : Is it possible to run osX ona PTP??



tm311
07-23-2001, 09:37 PM
I am thinking of attempting this and i am curious before spending $120 bucks on the disk whether any of you guys have done it yet. I have a basic PTP200 with a Xlr8 G3450 card and miles2 with dual cheetah raid, and 320MB of ram, Xlr8 usb card and Ati video card....i would be willing to lose the raid if needed and up to a point replace some of my hardware....let me know what i am in for, and is this something worthwhile.

ChrisYip
07-23-2001, 11:14 PM
Hi...

Should be doable - check here: http://eshop.macsales.com/OSXCenter/

lasvegas
07-25-2001, 02:07 AM
You bet it's do-able! And it looks like you've got about a perfect setup for it other than the RAID. I don't expect OS X will support that yet.

Follow Chris' link to Ryan's Unsupported UtilityX and use it to boot the OS X CD. Since you have only 3 cards, put them all into the top three slots. Make sure the Miles2 is in the top slot for best performance.

[This message has been edited by lasvegas (edited 25 July 2001).]

tm311
09-27-2001, 09:51 PM
LasVegas:

In anticiaption of the OS 10.1 launch this weekend i think i am going to take the plunge and try...i just wish however i didn't need to spend the 129 bucks to find out http://macgurus.com/infopop/emoticons/icon_wink.gif....but i wil...and if it craps out on me i think i can sell the full install cd on ebay or something? Anyway i am breaking down the raid tonight and am going to do a complete re-install of 9.1 on both drives...i am reading up on OS10 and its built in raid capabilities.but i think i will play it safe and keep the 2 drives seperate for the time being...softraid i am guessing is not compatable at this time....so i will use apple drive-set-up....i am guessing it will not be a slam dunk install and i will need to do some things to get it to work. i have already changed my compters gestault id (sp?)to 510 so the cd will think i have a native G3....any other suggestions to make it easier? I am off to read chris's link....thanks for the encouraging post!!!!!

ricks
09-27-2001, 11:44 PM
tm311,
I don't think your going to need to do any hacking to get 10.1 to run on your G3 PTP. If you download the new XLR8 Control Panel ver. 2.5 it will enable your G3 in 9.1 and OSX...YEAH. Way COOOL

I think you should be able to just install 10.1 without the work around that 10.0.4 required. I could be wrong, but that's the word I have been getting.

If you want to keep your RAID, you can always add another drive for OSX.

Rick

lasvegas
09-28-2001, 02:39 AM
WOAH! Hold on a sec! As far as I ca tell at this point, OS 10.1 will not work with the MilesU2W card. 10 through 10.0.4 work fine with the OS X beta driver. OS 10.1, so far, gets a kernel panic with the Miles2 plugged into my PTP. I'm hoping for a fix from Initio soon.

10.1 still does not support direct installs into non-G3 computers. XLR8's 2.5 and 2.6 drivers include a utility to support the backside cache in OS X, but you still need to use Unsupported UtilityX to install it. Fortunately, Ryan's 1.1 version was fixed to support the 10.1 installer changes.

[This message has been edited by lasvegas (edited 28 September 2001).]

lasvegas
09-30-2001, 04:19 AM
***** NEWS FLASH! *****

Initio (http://www.initio.com/) has released new firmware upgrades to support Mac OS X version 10.1! This is supposed to fix a digital audio bug in the Miles2 as well. I haven't tested it on my PTP yet, but I will in the morning (After I get up after going to bed now, anyway.). http://macgurus.com/infopop/emoticons/icon_smile.gif

This is the archive containing the flashroms for the BlueNote,Miles 9100uw and MilesU2W (http://www.initio.com/drivers/OX%20X.1%20SIMS.sit.hqx). Note that the version number hasn't changed for the Miles2, but it is a different driver. Also, the wrong SmartSCSI application is included. You will need to use this Miles 2 SmartSCSI (http://www.initio.com/drivers/Miles2%20SS%201.03.sit) application.

[This message has been edited by lasvegas (edited 30 September 2001).]

tm311
09-30-2001, 07:35 AM
HUGE Caveat.....once you flash your miles2 card you will not be able to use 9.0 unless you re-flash with the older firmware. I flashed my miles2 card this morning with this and upon restart was greeted with the grey screen...figuring it was a miles thing to suometimes wait a few minutes to boot i went and made coffee. Came back to the same grey screen....figuring i flashed it wrong i booted of my emergency boot disk and reflashed the card with the original 1.06 firmware....it booted fine and THEN i found the following "read me" warning in the updated firmware.....

This is BETA version 1.51 of the Miles (INI-9100UW-MAC) firmware for OS X.

26 Apr 2001 We fixed an issue when booting to a UFS SCSI volume.

This firmware update must be flashed from OS 9 it will not work from OS X.

Once you have flashed your Miles with this firmware you will not be able to
use OS 9 until you reflash it with firmware 1.13, so you may want to download
a copy and keep it on your system.

Your SCSI drives WILL be bootable with this firmware hard
drives, and most CD-Roms are supported with this firmware.

To flash the firmware you run the SmartXSCSI application and select Setup/
1st card configuration. Then in the next screen you click on the Update
Firmware button. When it is finished you close all screens and reboot the
machine.


Now i may have the wrong file....but i downlaoded it once from the link here .....and then direct from the initio download page. I realize the numbers don't match up.but i am assuming this is because the originally put the wrong smart scsi program in it.....*sigh*....( as great as this card is.the software people MUST be PC people and not Mac people... http://macgurus.com/infopop/emoticons/icon_smile.gif)


[This message has been edited by tm311 (edited 30 September 2001).]

lasvegas
09-30-2001, 02:22 PM
I had no problem flashing my Miles2 card. For the Miles2, you need to flash the SIM file from the A100 U2W folder. The 9100uw is for the regular Miles card.

OS 9 boots fine for me. I ran into problems with the 10.1 CD though. My ADB mice (A trackpad and Orbit trackball) weren't recognized in the installer. Hard to do anything of you can't click "Continue" to get to the next window!

lasvegas
10-01-2001, 04:42 PM
Ryan Rempel (http://eshop.macsales.com/OSXCenter/) has released a new version of Unsupported UtilityX (2.0b1) (ftp://ftp.macgurus.com/ftp/osx_stuff/UnsupportedUtilityX2.0b1.img). This version cures the frozen mouse problem when booting the OS X.1 install or update CDs. There is one caveat tough. This version is much pickier about the CD drive and quality of the CD itself. It would not boot my burned copy of the Update CD in my Apple 24X drive but would boot the same disk in my Sony CDRW. Go figure!

lasvegas
10-01-2001, 11:01 PM
It works! It works! It works! Waaaa-ha-ha-ha-ha-ha-ha-haaa!

Okay¨÷ I've settled down a bit¨÷ What I mean to say, is that using Ryan's UUX 2.0b1 and updating my Miles2 card's firmware, I finally succeeded in installing Mac OS X 10.1 on my PTP w/XLR8 436MHz G3.

This new version is fast enough even on my computer to be considered for daily use as my OS of choice.

I'm very happy now! http://macgurus.com/infopop/emoticons/icon_smile.gif

[This message has been edited by lasvegas (edited 01 October 2001).]

tm311
10-01-2001, 11:43 PM
VERY COOL!!...I still have yet to order my copy of 10.1....my last thing that is holding me up is that am i reading things correctly in that I will not be able to use my cd-burner? I have toast 5 and a scsi burner.....i thought i read that someplace. But i am pumped to see that you got it to install....i should know by the weekend.

lasvegas
10-02-2001, 03:08 AM
You're right. Your CD Burner will not work yet. There is a beta OS X version of Toast 5 but it currently only works with Apple's burner drives (probably because it uses Apple's Burner drivers.) The burner will work as a regular CD drive until someone gives us a SCSI Burner driver.

BTW: I'm using Apple's CD Burner software in Mac OS 9.1 and it works with my SCSI Sony CDRW. It's a bit tricky to install though. You need to temporarily fool the installer into thinking you've got an iMac or B/W.

lasvegas
10-02-2001, 11:28 PM
Ryan Rempel (http://eshop.macsales.com/OSXCenter/) has released Unsupported Utility X, version 2.0b3 (ftp://ftp.macgurus.com/ftp/osx_stuff/UnsupportedUtilityX2.0b3.img). This version solves the problem with the CD Drives (Finally!). It also has a cool new feature that allows you to set OpenFirmware to work like a boot menu! To do this from the OpenFirmware menu, select the keyboard for input-device, your primary video card for output-device and turn off auto-boot?.

When you restart (Until you boot into OS 9), you will be presented with the OpenFirware white screen. Type in boot and hit return to boot OS X or type bye and hit return to boot OS 9.

[This message has been edited by lasvegas (edited 02 October 2001).]

tm311
10-07-2001, 10:25 AM
I was able to boot into the OS10.1 installer disk finally last night and install OX10...it was not easy...but then again it is an unsupported mac right?? If anyone wants the details of my struggles please feel free to email me.

lasvegas
10-07-2001, 03:35 PM
Ah! But isn't it worth the trouble! http://macgurus.com/infopop/emoticons/icon_smile.gif

Be sure to now install 9.1 on the OS X drive and proceed to install the 9.2.1 update from within 10.1. Use this as your Classic rather than your primary OS 9. This avoids the boot problems when switching back. If you use Unsupported UtilityX exclusively to boot OS X, you can use the Option key when booting to switch back to your 9.1 previously set in the Startup Disk control panel.

tm311
10-07-2001, 04:14 PM
Totally worth the trouble!!!! http://macgurus.com/infopop/emoticons/icon_smile.gif

So right now i have only 2 HD's in my computer....both LVD cheetahs on the Milse2 card....both are set up to single partitions and i am using the total space as a volume. I have 9.1 installed on one of them and 10.1 installed on the other. I have been botting back and forth using UUX and the option key like you say. But you are suggesting i install 9.1 on the OSX drive as well? They would be on the same partition correct? I do have the 9.2.1 Install disk....but you are saying to install 9.1(from the 9.0 disk i assume) and then while booted into OSX i upgrade to 9.2.1 from the cd? I had planned on keeping 9.1 on one drive and 10.1 on the other to minimize problems....but i am open to what you are telling me.

TZ
10-07-2001, 06:22 PM
Keeping one system (9.2.1) for OS X Classic compatibility and then have whatever you need on the other drive. classic doesn't require many extensions so a trimmed down extension set is in order. Reduces complexity. If you have full 9.2.1 install, I'd go with that rather than the upgrade path which had some problems - usually a clean install of 9.1 worked best. And if you only have 9.0.... too much work. Why I bought the full install 10.1 and 9.2.1 so I never have to worry about upgrade installs.

congrats! and on being able to option select to boot!

Gregory

lasvegas
10-08-2001, 04:44 PM
Unfortunately, the 9.2.1 installer won't work on oldworld machines unless you fool the system into thinking it's a Beige G3. The technique of installing 9.1 and then running the 9.2.1 update from within Classic mode in OS 10.1 avoids this hack.

Yes. Install your Classic OS 9 folder on the same drive with OS X. This System Folder would be used exclusively as Classic in OS X and avoid trashing your regular OS 9.x System Folder. OS X still has a tendency of de-blessing a System Folder rendering it unbootable. I added the hack to my OS 9.2.1 so that I can boot into it. This makes it easier to make certain adjustments such as Appearance and such that will be used within OS X. My Classic windows look similar to the OS X windows! http://macgurus.com/infopop/emoticons/icon_smile.gif

tm311
10-09-2001, 07:39 AM
3 days later and i am amazed at how stable this new OS is. I have not had a single crash. As far as i can tell everything works the way it is supposed to . i do not have my cd burner in OSX...but both drives work and i can print to my epson 740 even though i am told it is not supported. Contextual menus seems a little hit and miss using my xlr8 right click button, but the mouse is fine.The one annoying thing i have found and i can't find a way to change it is that when i click on the mail button in IE i get a new mail msg popping up instead of my "inbox". But all in all i am very happy and can't see a reason to go back to OS9.

sm777
05-19-2002, 05:16 PM
I've followed the instructions pretty clearly so far installing OS 10.1.3 from your latest 2.2b7 util, and have updated ROMs and extensions as best I can, and yanked other PCI cards out...

I have autoboot off & verbose mode on. I made 2 partitions, the 2nd one having clean 9.1 install, the first partition has 10 Gb with no spaces in the name.

The error(s) I'm getting are:

Can't find superclass for _20PatchedIOSCSICDDrive : _13IOSCSICDDrive
map_and_patch(): Extension "oldworld.support.PatchedIOSCSICDDrive" Error binding OSObjects.
load_kmod: map_and_patch() failed for kmod "oldworld.support.PatchedIOSCSICDDrive

blah blah... the CD drive isn't being read obviously... so it can't continue with the install...

SO... should I try a different CD ROM? Yank out the Zip and Jazz? Buy a cheap IDE CD ROM and install it off the ATA card?

My specs for the PTP 225 :
XLR8 G3 450 upgrade card
non interleaved RAM 384 Mb
ATA 40 Gb Maxtor HD running on Sonnet 66 Tempo card (1st slot)
ATI Nexus Card (updated ROM extensions)
2 SCSI CD ROMs... toshiba SD-M1401 DVD-ROM, and tired NEC 2x CD ROM; (installed on internal SCSI-2 bus with internal zip and jazz)

tm311
05-20-2002, 10:04 PM
Is the internal cd-rom drive on the slow 5mb bus or the standard 10mb bus? You will see it mentioned in other places and a diagram is in the owners manual. I could not boot into the osX install disk UNTIL i switched to the 5mb slot. Also are you using a cd-rom that has the apple rom? and using apples cd driver?

sm777
05-21-2002, 07:18 PM
The DVD ROM only mounts using CD Speedtools... obviously a warning sign right there. The NEC I tried because it was pulled from a friends old apple, so I'm assuming it has the Apple ROM. Yes to the Apple CD Drivers, but clearly, the Speedtools is masking what could be the basic problem.

As for the different buses... I haven't tried the slower bus... that could work! Thanks. I'm determined to get this badboy running OS X... thanks for the help.

tm311
05-21-2002, 09:54 PM
I needed to dump speedtools, softraid AND the faster bus before i was able to install osX.I DO have speedtools running on my classic HD, but softraid MUST not be controlling anything associated with osX or Classic.