PDA

View Full Version : Keychain is FUBAR!



dragon_x
02-21-2002, 08:59 PM
I do not really know what this is and I do not WANT to know what it is and further more I should not have to know what it is, but it seems I have no choice.

I am attempting to use the MAIL.app and it insists that I provide a password or term to alter or access the keychain. I have attempted to delete the passwords out of MAIL.app and it looks like I have succeeded - yet the Keychain persists. MY password does NOT work. http://www.macgurus.com/ubb/mad.gif I never setup a keychain password. Keychain is stupid, retarted and a bunch of krap. How can I get rid of it? Modify it? Fix it?

Any ideas?



------------------
The Cost Of Freedom:
Every bit of energy.
Every ounce of courage.
Every drop of blood.

Sic Semper Tyranus!

ricks
02-21-2002, 09:42 PM
Hey dx,

I am cussing the same thing right now. The weird part is, it just started doing that and I've been running the mail app for a couple months.

Aweful piece of junk program that I will find out how to get turned off or die tryin. Might drive me to Eudora yet.

Rick

dragon_x
02-22-2002, 01:54 PM
Everything was working fine for me too. My DSL went down for SIX days and now that its backup - KEYCHAIN has freaq'd my MAIL.app. I did occasionally have issues - 'FETCH ERROR' but it always seemed to work - I think this was usually caused when the computer went to 'sleep' and MAIL.app tried to get the mail anyway.

I am trying to use Netscape mail from 6.2.1 - It looks like I can setup mutliple POP accounts, but the smtp is all messed up. It wants to use my Apple userid for my RCN.COM smtp server. Since I need to authenticate this does not work... and the settings seem very screwy.. I did get my mail, but it looks like I am unable to send - so far. Looks like http://www.mail2web.com is my short term fix http://macgurus.com/infopop/emoticons/icon_frown.gif

So is Eudora out for X now? Is it any good?

rwm
02-22-2002, 02:43 PM
No clue about Eudora and X. Another upgrade for me??? I have been a Eudora user for 6-7-8 years. Hey stop the laughing before you post.

Hope you both get it figured out.
Randy

dragon_x
02-24-2002, 02:50 PM
Success - I think -

I found that damn keychain folder. In it is a file (28KB) with my username on it, "dragonx". I took this file and folder and put it in the trash. I was unable to delete the file out of the trash, but I did separate the folder, "Keychain" from the file "dragonx" and I renamed the items, "old.Keychain" and "old.dragonx". I was able to ditch the folder but the file is stil there. I renamed "old.dragonx" to "old.d" and the system now seems to think its a graphic converter file - even though it will still not let me delete the damn thing.

Good news though - I went back into MAIL.app and I can get mail! http://macgurus.com/infopop/emoticons/icon_biggrin.gif I seem to have lost all (most?) of my inbox from my MAC.COM dragon_x account.... but my main account appears fine. I have set the app to NOT remember my passwords. This is a big issue that Apple NEEDS to fix now -
Keychain SUCKS on Windows and it SUCKS on Mac OS X. What really bothers me is that I did not setup keychain up and I have ZERO access to this. I might just trash the whole damn system keychain folder (instead of just my user folder like I did). At worst -Keychain should use MY password or the ADMIN password for access - it does nothing like this. Maybe I am missing something, but then Apple is SUPPOSED to make this UNIX OS 'easy' to use and TROUBLE FREE! I know they are concerned about security (unlike MicroSoft) but WHEN I can not access the info - whats the point?

http://www.macgurus.com/ubb/confused.gif

------------------
The Cost Of Freedom:
Every bit of energy.
Every ounce of courage.
Every drop of blood.

Sic Semper Tyranus!

ricks
02-24-2002, 11:01 PM
Hey d_x,

I spent some time with one of the software guys from Apple today and we went thru the Keychain thing with him. You can consider a report made. We'll see if we can get some sort of response from the OSX team.

Hope so, 'cause I agree, the thing self started and is hard to get to stop, even when you remove the configuration from the control panel it wants to make you log in at mail startup.


Rick

dragon_x
03-01-2002, 10:23 AM
I have been hanging around http://www.macosxhints.com
Nice site... its still fairly new to me, but guess what I found?

The 'OFFICIAL' solution to the KEYCHAIN debackle!
<BLOCKQUOTE class="ip-ubbcode-quote"><font size="-1">quote:</font><HR>Thanks to Rob for submitting the solution, and my apologies for the delays in getting it published!
This solution was provided by 'cricket', a member of Apple's Mail.app team:

"Here's how to fix it. Go to the Finder, click on the Home button. Open your Library folder and look for a folder called 'Keychains' -- move it to your Desktop. Go back to the Library folder and open Preferences. Look for a file called com.apple.security.plist. Also move that to the Desktop.

Now launch Keychain Access (it's in the Utilities folder in the Applications folder). When prompted to create a new Keychain, create a keychain whose name exactly matches your login name. When prompted to set up a password, set a password that matches your login password.

Then you'll be in Keychain Access with an empty window showing the Keychain you just created. Go to the Keychains menu and make sure there is a diamond icon next to the Keychain name you just created (that means it's the default). Finally, go to the Settings option in the Edit menu. Uncheck both checkboxes. Quit Keychain Access.

The next time you launch Mail, you may be prompted by a dialog that asks whether Mail can have access to your keychain. Click Allow Always. You'll also get prompted for any email passwords you have set up. Enter the passwords and click the save checkbox.

Now they will all be stored properly in the Keychain. This is how it's supposed to work automatically (i.e. you're never supposed to have to care about this)."

[Editor: I assume you can then throw away the two files sitting on your desktop, since they will have been re-created]<HR></BLOCKQUOTE>