PDA

View Full Version : S900 MilesU2W+ Cheetah X15 vs. MacOS X.1



Miles
01-06-2002, 10:34 PM
I'm trying to install 10.1 onto my S900 and I can't seem to get past the MilesU2W card at boot. Originally, I was able to get into the installer (when the SCSI card was at firmware v.1.01) but none of my volumes would show. I updated the SCSI card firmware to 3.06 and now I get no video at all. Booting in verbose mode gives the error "can't OPEN: _"

I have heard rumors of people being able to install X.1 on a machine with a Miles U2W, but I couldn't find the procedure - wasn't that lasvegas who got it going? In any case, if anyone has a procedure, I'm interested.

FYI:

Umax S900 w/ PowerLogix G3/500/250
Miles U2W + Cheetah X15 (granite cable and term)
528 MB RAM (512 + 16 onboard)
ATI Xclaim VR (Rage Pro)
TT128
ADS PCI FireWire
ADS PCI USB

lasvegas
01-07-2002, 04:13 AM
For some reason, Initio keeps changing the beta without changing the version number. I just downloaded the current version 3.20 (Same versions as mine reports), and ran the version of SmartSCSI supplied with it. It reports that my firmware is version 1.1 and that it's a PC Firmware. Needless to say, I didn't trust it enough to proceed with the flash.

The version of SmartSCSI I last used and the OS X.1 firmware can be downloaded from:

ftp://ftp.macgurus.com/ftp/initio_stuff/OS X Firmware/

This version not only works well with OS X.1, but allows booting from a drive on the MilesU2W card.

Sorry about the lack of a direct link, but I couldn't get the UBB Coding to work with it in this message.

[This message has been edited by lasvegas (edited 07 January 2002).]

Miles
01-07-2002, 12:30 PM
Thanks for the link. I suspected the firmware was the problem considering I could previously boot into the installer. It may be just a reporting problem in SmartSCSI - I was pretty sure I had flashed my card to 1.06b after I first got it (that was a long time ago though...)

I'll give the other firmware a go tonight and keep you posted.

Miles

Miles
01-09-2002, 12:22 AM
That firmware did the trick - I'm now running X.1 on my machine. I had to swap the CD drive back to the 8x cluncker that originaly came with the S900, but other than that small snag, things are good. I still have to tweak a bunch of stuff, but that will come.

FYI: The SmartSCSI program that is on the gurus FTP site (v.1.03) shows firmware 3.20, but the one from Initio (v.1.04) shows 3.04. I had to revert to firmware 1.04 and then reapply the OS X firmware for it to work.

In any case things are hunky dory now and I must once again thank the gurus for their wisdom!

lasvegas
01-12-2002, 04:47 AM
I just had to try the new firmware today on my PTP and see what's going on. It's pretty bad when the computer cant get passed Open Firmware when trying to boot OS X! Switching back to the previous sim solved everything

It looks like that 1.04 flash could be handy for flashing PC Miles2 cards to work on Macs!

polygon
02-07-2002, 06:40 PM
i'm dyin here...
i'm trying to install OSX on my Miles U2W + Cheetah and the installer won't recognize the card/drive...i have tried following the tips described in the posts here but they don't work for me...i've dowloaded and flashed virtually every SmartSCSI and .sim avaialble and i am having no success...i keep getting the PCBios error, i run the sim on initio's site that it says to fix this, reboot, try to run the OSX smartscsi and it says it is still a PC card...i've run every version of smartscsi and sim in every possible combination with no success...i tried the suggestions that Miles say worked for him but i can't get it to work...help? it would be great if someone there could make a page or help file that detailed step by step which version to run in which order to get this to work properly...there are so many files that it is confusing...TIA.

Dan Sanders
02-08-2002, 01:00 PM
Okay let's take this step by step.

First you MUST have an Apple approved machine to use our OS X firmware with success. If you have any other machine you are most likely just wasting your time. In most cases flashing our cards with the OS X firmware in a clone (Umax) or 9600, 9500, 8500 etc will render the machine none bootable until the card is taken out.

Now you need to download and unStuff the OS X firmware to your desktop.
Boot into OS 9.xx and go into the Archive folder and then into the folder for your adapter card.

Run the SmartSCSI 9.xx version and select Setup/1st card configuration, then click on the Update Firmware Button. If you are asked for the SIM file just browse back to that folder and select the sim file. When the update is done you just close all the screens and reboot the system.

Upon reboot if you encounter any difficulties such as a blank grey screen and nothing else, try booting into Open Firmware.

To boot into Open Firmware you start by pressing and holding the Command, Option, O and F keys during startup. At the Open Firmware prompt you enter the command "Reset-All" this will reboot the machine and all should work correctly.

Something else to keep in mind is that you must be installing OS X.1 or higher in order for the cards to work correctly, versions lower than X.1 did not have complete SCSI support.

Bottom line for those trying to get the Initio cards to work in a Umax is you are wasting your time. It will not work and it is not supported by Apple nor by Initio, so you are doing so at your risk.

Miles
02-10-2002, 04:32 AM
I have had much more success with the UMAX machine that I currently use than with the several PowerComputing machines that I have contact with in my work and through friends. I followed the instructions given with XPostFacto at http://eshop.macsales.com/OSXCenter/ and aside from the issues with the Initio card (the correct sim fixing the problem), things went relatively smoothly and my computer is now more stable under X than 9. I wouldn't lay blame on UMAX - I think Initio is to blame - use the earlier firmware and all is well with the card.

G'luck,
Miles

[This message has been edited by Miles (edited 10 February 2002).]

polygon
02-10-2002, 09:58 PM
thanks, dan...

actually, my scenario is a bit different than the one you describe...i am on an Apple G4 running 9.2.2...the drive i am trying to install OSX on is an additional internal drive (seagate cheetah) on a separate Miles U2W bus...the OSX installer won't recognize the card/drive...

when i run the smartscsi/sim for OSX i get that the error: card is PConly

when i run the smartscsi/sim combo that is supposed to fix this issue, reboot, and then try to run the OSX smartscsi/sim i still get the freakin PC Bios error message...

i don't know what i have to do to get the card flashed so that it will be recognized...

Dan Sanders
02-11-2002, 05:57 PM
Hi There,

The PC Only error was fixed with SmartSCSI v1.06, so using it you should not see that error message.

What you should do is copy the OS X SIM file and the SmartSCSI v1.06 to the same folder and then run that SmartSCSI from OS 9. Select Setup/1st card configuration and then click on Update Firmware.

Please let me know if this does not correct it.
Dan