PDA

View Full Version : Installing X.0 on a 9500



tbelcher
01-29-2002, 09:27 PM
I'm having kernel panic problems when trying to install OS X.0 on a 9500. I don't have anything connected except the stock video card, stock 1 gig hard drive, and stock cd-rom. Of the 10 or so times I've tried installing, only once did it make it to the actual "install" stage - where it proceeded to tell me that it couldn't set the file attributes and to try again. the rest of the time, it gets a kernel panic somewhere during the installation process. Any ideas?

Thanks in advance.

Cyrille
01-30-2002, 02:24 PM
the 9500 is not supported, you will need the free software from www.macsales.com (http://www.macsales.com)
go to osx center

cyrille

tbelcher
01-30-2002, 02:46 PM
Sorry, I forgot to mention that I am using XPostFacto to install.

ICCAFSN
01-30-2002, 11:35 PM
Hmmm, sounds peculiar - I can't offer you any advice, since I'd have thought that your configuration would have worked. Maybe you should send Ryan Rempel (XPostFacto author) a line and see if he's got any ideas.

ricercar
01-31-2002, 12:44 AM
My 9500 is nearly as reluctant to run MacOSX. I've installed OSX on a 9500 successfully only twice in the last six months (out of perhaps 12-15 separate attempts. OSX installed successfully only with UnsupportedUtility 1.3+OS10.0.3 and never with UnsupportedUtility 2+OS10.1.

Additionally, 10.0.4 on the 9500 was unable to properly recognize an add-in USB PCI card (installed after OSX) except to freeze the machine when a USB peripheral was plugged into the card. I formatted the HD and tried to re-install UnsuppUtil2.x+10.1 while the USB card was present to no avail. The installation always terminated ungracefully into a command line until I removed the USB card.

lasvegas
02-04-2002, 05:30 PM
What model of video card are you using? What slot is it in? Try putting the card is both the first and the last slots and see how things work. I've found the the UltaRes card (Stock on some 9500s), needed to be in the lower 3 slots for my first install, but then worked betting in the upper 3 slots after OS X was installed. I've since abandoned that card since it's not accelerated in OS X.

tbelcher
02-04-2002, 06:33 PM
The video card is an ATI Mach64 (?). Its in the 3rd slot from the bottom. I'm also looking into termination issues with the drives.

tbelcher
02-05-2002, 02:45 PM
I may have found the problem.... It looks like the CD-ROM (Apple 600i) had the termination jumper on. I removed it and using Post Facto started installing. It was going without a hitch when I had to leave for work. Can anyone confirm that the CD-ROM shouldn't be terminated if its on the same SCSI chain as the internal HD?

Thanks,

Tim

mactheripper
02-06-2002, 12:16 AM
it depends on the CD-ROM's position in the SCSI chain.

You absolutely have to terminate it if it is physically on the "end" of the ribbon cable. That would mean

Mac motherboard ----- hard drive ------ CD-ROM

If the layout is

mobo -------- CD-ROM ----- hard drive,

you must terminate the hard drive and NOT the CD drive.

Note: this has nothing to do with SCSI id number.

In the 9500, the stock config as shipped with one internal drive has the SCSI ribbon cable running from the motherboard connector under the speaker, connecting to the CDROM, then ending with the hard drive in the lower bay. In this configuration, (second config above), it is the hard drive that must be terminated. The CD drive must NOT be terminated.

In summary: if the CD drive is in the middle of the physical chain, you are correct in removing the terminator jumper from the CD-ROM.

tbelcher
02-06-2002, 07:34 PM
The CD-ROM is the first device connected in the chain, however I still got a kernel panic with the termination jumper removed. So, I removed the HD and it looks like it is NOT terminated. I'll try that tonight. On a side note, the SCSI cable looks to have (4) connectors on it. I'm assuming that the other two are for the external (5MB) chain? Is this correct? Is there a way to tell which is which?

Thanks

Tim

mactheripper
02-06-2002, 10:38 PM
First, terminate the hard drive. It is the last device on the chain and Must Be Terminated. This is all according to the Gods of SCSI. (My reference is The Book of SCSI, 2nd edition, by Gary Field, Peter Ridge, et al)

In answer to the side note: all four connectors on the SCSI ribbon cable running around inside the Mac are on the internal bus. A bus actually just means an electrical connection between multiple devices, whether you're talking hard drives or electrical power on an F-16. So your ribbon cable, connected to your SCSI controller on your motherboard, actually forms the internal bus when connected.

If you take an external cable and run it from the external SCSI port to an external hard drive, you are forming another bus. Adding devices to the external chain extends the external bus.

If you had a PCI SCSI card, like a JackHammer, Miles2, or Atto, you would be forming a third bus by starting with the SCSI controller on the card and connecting a drive.

But wait! you say. You have seen PCI SCSI cards, and they can run drives externally AND internally! Some PCI cards even have two external jacks and two internal! What gives?!

The answer is that there are multiple controller chips on the card. Each controller chip can handle one bus. The aforementioned 2 outside/2 inside cards (the ATTO ExpressPCI Dual-Channel boards (http://www.macgurus.com/shoppingcart/showrampage.cgi?attoboards.html)) let you connect two channels externally OR two internally OR one of each. Not four.

And, yes, people have taken 9500s and run internal drives off the mobo, external drives off the mobo, AND whopping RAID arrays off of one or more SCSI cards, all at the same time.

Finally, the internal SCSI Narrow bus on your 9500 is twice as fast as the external bus.

That is all. http://www.macgurus.com/ubb/cool.gif

[This message has been edited by mactheripper (edited 06 February 2002).]

tbelcher
02-07-2002, 01:07 PM
Well, it turns out that the hard drive was terminated - I just couldn't see the jumper until I removed the drive from its sled. Since I now know that the drives are terminated properly, is there anything else that could be causing my kernel panics? I tried moving the video card up one slot and rather than getting a panic with a "Array access error" I got a "memory access error". Any ideas? BTW, there are no other devices or PCI cards attached.

Thanks in advance.

billbo
02-07-2002, 09:09 PM
you might try looking over at Breedens' http://xlr8yourmac.com/ site. There's been several news items about this. You might find something you might have missed.

Good Luck.

As I'm probably gonna try the same thing soon myself.

------------------
Bill

"I made a conscience decision in a semi-conscious state"