PDA

View Full Version : OSX on Beige MT no more boot



Cyrille
01-31-2002, 03:18 PM
I installed OSX with all upgrades successfully on a beige G3
I switched back to 9.2. and it is impossible to switch again to OSX

G3 Beige MT
G4 Newer Tech processor
ATTO UL2D SCSI
and Atlas 10K drives

kernel panic at boot (white screen with tiny letters saying: cannot open multifunction PCI device UL2D and after a while switches back to 9)

I tried with an ATTO UL3D, same problem
only the old beige ATTO SCSI SE card flashed for OSX works
but it is a single channel single ended

I thought ATTO cards are OSX compliant

any ideas

ricks
01-31-2002, 06:28 PM
Cyrille,
First thing you might do is goto Attotech.com and find out if you need to flash your card rom to make it OSX compatable. You can get your current rom version off the Apple System Profiler.
Rick

BTW, I am running a UL3D with 2 X AtlasIIIs on my B&W with no problem in OSX with rom version 1.6.4

[This message has been edited by ricks (edited 31 January 2002).]

dragon_x
01-31-2002, 06:48 PM
Support for the beigeG3s in X is definately more dicey. I installed a slave drive in a REVB G3 - all stock except
ix3D 8MB PCI
4GB Quantum HD (slave - from another beigeG3)
320MB RAM (256MB upgrade)

I think I installed X fine, but it would not boot.. I forget where it got hungup. I do not remember any kernal panics. My YoseG3/500 runs X fairly well, but I am not about to try it with my V5. It works OK with a V3 - but you gotta be careful or it WILL crash hard. http://www.macgurus.com/ubb/eek.gif


------------------
I'm back!

Cyrille
01-31-2002, 08:13 PM
I have 1.6.4 on the UL3D and on the atto site they say that OSX will automatically recognize the card
If I look at the kernel extentions there is noting about this card

Cyrille
02-03-2002, 11:50 AM
here is the solution by Ryan Rempel (genius) which worked for me:

It's possible that System Disk (and Startup Disk) are constructing the
wrong boot-device setting for your card. That would explain why you can
boot from the card the first time, but not after you return to OS 9.

If you want to check this out, you would do this. Reinstall OS X from
the CD. I take it that this worked the first time, and the installer was
able to successfully reboot into OS X when it was done. If it works
again, launch the Terminal application. Type this command:

nvram boot-device

and write down the results. This is the boot-device setting that works.
Then, reboot into Mac OS 9 and run System Disk 3.3.1. Choose your Mac OS
X volume, and then option-click (or double-click, I forget which) on the
icon for it (within System Disk, that is). This should open a window
that will show the boot-device setting that System Disk intends to use.
If my theory is correct, it will be different than the setting you wrote
down earlier. The setting is editable in this window, so just type in
the correct setting, and close the window. This should give you a custom
setting that ought to work.