PDA

View Full Version : Has anyone tried this? Scsi Helper



tm311
11-14-2001, 11:26 PM
http://www.elgato.com/SCSIHelper/index.html

This is supposed to give us back our cd burners under osX. I tried installing it on my PTP but no luck. I have read that i need to remove a patched scsiCD file from my extension folder but when i do that and restart it returns.....if anyone has any luck i could use any advice. I found this on xlr8 your mac.

lasvegas
11-15-2001, 05:12 AM
Thanks tm! I'll give it a try with my PTP and SONY burner and post my results. This will not fix Toast OSX yet since they only support IDE right now. Perhaps it will allow Toast Classic to work or Apple's Burner software...

tm311
11-15-2001, 08:05 AM
It is supposed to allow toast to now burn with scsi cd burners .

Byron
11-15-2001, 03:42 PM
This utility shouldn't be necessary if you update to OS X, 10.1.1. Soon as I did, my external Yamaha 2100S (on an Apple Adaptec 2930 card) was a) recognized as an "Apple supported CD burner" by Apple System Profiler (it never showed up before), b) recognized by iTunes, and c) recognized by Toast Titanium 5.1b2. Burned a CD, too!

Needless to say, I'm happy : )

tm311
11-15-2001, 07:08 PM
I now have the 10.1.1 upgrade but when i try installing it it tells me my computer does not meet the requirements.I wonder if it has to do with the fact that it is a PTP.

[This message has been edited by tm311 (edited 15 November 2001).]

lasvegas
11-16-2001, 04:28 AM
tm: Use the Software Update in System Preferences. It will first update the Updater. Then quit and run it again. This will install the 10.1.1 update within 10.1.

I tried the SCSI Helper in 10.1 and 10.1.1 and it aparently doesn't work with the built-in SCSI of our machines. I expect it's due to the added drivers by Ryan Rempel. I'm going to send Ryan and email and ask him about it.

tm311
11-16-2001, 09:39 PM
LV
I read on xyoumac that yes indeed it is nessasary to remove that patchedscsi file from your sys/lib/ext folder in order to make it work, but i have not found a way to permanently remove it because the only way i can remove it is when booted from os9....but when i restart from USU it gets put back in. I do not know how to boot into ROOT....maybe that is the way to remove it...let me know if you get a response from ryan ...i emailed him a thank-you letter back when his utility let me get into OSX, but never heard back.i bet he is a busy guy...i wonder if it makes sense to buy Iniito scsi card to allow scsi burning....would be cheaper than the firewire root.

BTW...no luck with 10.1.1 still. I have not seen an update for the actual software updater yet...and 10.1.1 still does not show in the window. And using the download from VT does not work.

[This message has been edited by tm311 (edited 16 November 2001).]

tm311
11-16-2001, 11:56 PM
i recieved the following email from Adam Steinberg at el gato who wrote the scsi cd helper software...in order to remove the hacked file and akkow the scsi cd helper file to load....and when i did this it now works....which saves me the cost of buying a new burner i hope. Anyway he saidto pen a terminal window and ttype the following..( i hit "enter at each line break in the terminal window to make it work.:

cd /System/Library/Extensions

sudo cp -R PatchedIOSCSICDDrive.kext /Applications (note this will make a backup copy of the PatchedIOSCSICDDrive.kext file in your apps folder)

sudo rm -R PatchedIOSCSICDDrive.kext

cd /Library/Extensions

sudo rm -R PatchedIOSCSICDDrive.kext


Now reboot and your player should be seen.....

tm311
11-17-2001, 12:29 AM
there may be a catch....and i sent another email request to adam. While i am able to burn cd's with this app, i seem to have lost my internal Plextor. CD's will no longer mount...I can mount cd's with the Yamaha but not the Plextor....i'll post more as i find out if this is fixable. Both drives are on the same bus...which happens to be the internal slow bus which i needed to do in order to boot off the osx install disk...and i cannot move it back to the other bus without booting into a kernal panic.

lasvegas
11-17-2001, 06:11 AM
After removing the PatchedIOSCSICDDrive.kext per tm's suggestion, I no longer have access to my Apple CD drive, but¨÷ I can burn!!!!

Not only does my burner now work with Toast, but it works in both iTunes and Disk Burner! Why? It's a Sony Supresa CRX140S. Since the list includes CRX140 (without the S), it picks up my drive as supported! I'm sure, if someone were to go through the data forks of the various files of iTunes and Burner and made a minor change to include their own drive, it would work. I don't have a different burner to try this out on yet though...

Now, I'm thinking if I put back the PatchedIOSCSICDDrive.kext and rename El_Gato_SCSICDR_Support.kext somehow to get it to load first. Perhaps I have to modify a list somewhere. But I want my whole system working! Maybe if I just leave it out of the Library/Extensions folder¨÷ I haven't tried that yet...

tm311
11-17-2001, 08:13 AM
Tell me this isn't more fun than buying a QS733 and just plugging it in*L*I am sure you are onto something trying to get both files in the folder but making sure the scsi helper file loads first...i was thiking along those lines last night . I was thinking about booting from os9 and then just adding a blank space ..but i wasn't sure that would work.....or even if os10 worked that way.

chrismenke
11-17-2001, 07:21 PM
lv,

I've got the same burner as you do, am running X.1.1 on a 9600, and keep getting errors when trying to do a burn (from the finder), or mount/copy an .img (from Toast 5.1 PR2).

Errors include:
MacOS Error [35, 37, 38] (in Toast while trying to copy an .img for burning)
Operation could not be completed because an error 50 occured (trying to copy to CDR in Finder)

Also, 700mb cdr media are being 'prepared' as 540mb...?

Any thoughts,
Chris

lasvegas
11-18-2001, 07:06 AM
Chris, I'll look into it tomorow (this?) morning after I get up.

I determined it isn't sufficient to rename the 'kext' file in OS X. These files are actually packages and the actual driver and such are within the package. Again, this is going to take a bit of experimentation...

tm311
11-18-2001, 08:59 AM
i tried renaming the file inside the package with a "~" in order to make it try and load last,,,,and booted with both packages insidethe extension folder...i still have burner but am still missing plextor.....makes no sense to me that i can stick an audio cd in my yamaha burner and it reads, but in the plextor it spins up and even causes the computer to pause for a second.but no mount. it shows in the system profiler.....and i have not heard back from adam yet.

lasvegas
11-18-2001, 08:58 PM
Well, I tried burning CDs with all three; Burner, iTunes and Toast.

Burner and iTunes failed miserably. They were unable to determine the size of the disk with any accuracy, presenting sizes anywhere for 25 to 125 under the correct size. When they attempted to burn they failed immediately before sending anything to the drive. Perhaps it's because they both think they're working with an ATAPI drive.

Toast worked flawlessly! I was able to constuct and burn a CD and even verify without problems. One drawback to my drive though, is that I cannot insert the blank CD into the drive until it's ready to burn. If I insert the disk early, I get Burner's dialog asking if I wish to prepare the CD or eject it.

lasvegas
11-18-2001, 09:00 PM
tm: I don't think it's sufficient to just rename the driver within the package. There are a number of support files that would need modifications in order to direct the renamed file appropriately. I plan to fool around with this aspect next.

tm311
11-18-2001, 09:30 PM
I have no clue as to what is involved with rewriting the files you speak of....if and when you get something let me know and i'll give it a try. I have been playing with iTunes today.what a COOL piece of software.

lasvegas
11-19-2001, 03:26 AM
I went through and changed all the appropriate files within each package to try to get them to load in different orders. Nothing worked. The results were always the same. Ryan's patch always took precidence. All I can conclude is that both extensions patch the same code and Ryan's software takes precidence in that SCSI Helper apparently doesn't patch over Ryan's code.

Guess we'll have to wait for Ryan to reply to my email.

lasvegas
11-19-2001, 05:50 PM
I just got a reply from Ryan. He said that ElGato has kindly shared his source code with him and that this feature should be available in a revision of Unsupported UtilityX in the near future.

tm311
11-19-2001, 06:58 PM
Mac people ROCK!!!!! i'll be on the look out for it. Thanks!!!!!