PDA

View Full Version : Booting into os 9 from X



Rem
10-01-2001, 08:17 PM
Ok this is the second time this has happend since installing osx. I have a b&w g3 the only thing i have added is a miles2 card and a scsi hd to go with it.
The problem is, after awhile I can no longer select my os 9 as the startup disk. The biggest pain is that I cannot print to my epson printer unless I boot from os 9. Apple really should have thought about that inconvienence. Anyway I go to my preferences and i have a folder of osx and os9 both are grayed out and the lock at the bottom is grayed out, so I cant select os 9 as the startup disk. I have tried disk first aid that came with osx and to no avail. I can start from my os9 cd however and select my os9 system and it will boot. The problem with that is then I have to reboot 2 times just to print. anyone have a better solution, than reintalling everything from scratch, wich is what I did the last time this happend?

lasvegas
10-01-2001, 11:07 PM
Try holding the Option key when you reboot. This bypasses the OpenFirmware patch and attempts to boot Standard Mac OS (IE: Your OS 9 folder).

TZ
10-02-2001, 08:06 AM
Option selecting was not introduced until later. Make sure you have the 9.2.1 or 9.2.2 startup disk cp for use in OS 9 and don't use earlier versions. Also, are you using 10.1?

lasvegas
10-02-2001, 11:19 PM
The Option selection has been present since the very first beta release of OS X. It doesn't always work with non-Apple USB keyboards or ADB->USB adapters since the may not initialize quickly enough for the OpenFirmware to catch it.

TZ
10-03-2001, 09:34 AM
With rev 2 b&w and Apple ADB and USB - Option selection has never worked. Not on OS X, not on PB, not under 9.1/9.2.1....

Gregory

Rem
10-03-2001, 04:53 PM
Gregory is right option-booting is worthless on the b&w g3. I'm on os10.0.4 and my startup disk cp is 9.2.1. Any other guesses?

[This message has been edited by Rem (edited 03 October 2001).]

lasvegas
10-03-2001, 09:18 PM
It's possible that your OS 9 System Folder has become unblessed especially if you've shutdown or restarted without shutting down classic. If this is the case, you can boot a Mac OS CD, remove the System suitcase from the System folder (To the desktop is fine) and then put it back into the System Folder again. This should restore the Mac icon to the folder indicating that is is again blessed.

I avoid this problem by using a different System Folder for Classic than the one I use for OS 9 booting.

Rem
10-04-2001, 04:56 PM
Thanks....I have most of my stuff packed for the moment . I'm in the middle of a move, and was hoping that there was a quick fix to last me a week or two till I can order 10.1. I'll try that fix if I find my cd by then http://macgurus.com/infopop/emoticons/icon_smile.gif

TZ
10-05-2001, 07:51 AM
Option to boot, or "blessing" a system folder was added to the G4 Open Firmware code.

The bootstrap loader that is used to "pick you up by your bootstraps" and loads the initial code that then loads the rest. There is a boot partition on the drive, and a file tbxi that does the loading.

I like to use the SETENV BOOT-DEVICE ULTRA0:,\\,tbxi

More on Open Firmware:
Open Firmware (http://developer.apple.com/techpubs/hardware/Developer_Notes/Macintosh_CPUs-G4/PowerMac_G4_16Feb00/G4Rev3-84.html)

Open Firmware is a boot environment developed using the Forth programming language. The purpose of Open Firmware is to provide a machine-independent mechanism for loading operating systems from a variety of boot devices. Open Firmware probes the PCI bus looking for devices and possible Open Firmware drivers for those devices. These drivers can either be built into the Open Firmware module or located in the external device, thus providing plug-and-play capabilities for new boot devices. Open Firmware is capable of using these drivers to load an operating system from the device.

Functions of the Open Firmware code include

* configuration of the Uni-N and KeyLargo ICs
* construction of the device tree
* probing of the devices and inclusion of some device drivers
* selection of the boot device

On the Power Mac G4 computer, the Open Firmware code has been extended so that the device tree describes the new hardware features of the computer. The Open Firmware code also includes FCode drivers for the new hardware channels: UltraDMA66, FireWire, and USB.

Open Firmware normally starts up using the default device and operating system. The user can interrupt Open Firmware's boot device selection by holding down the Option key while booting. This invokes the OS Picker, an Open Firmware application that lets the user select an alternate operating system or boot device. The default operating system is the Mac OS ROM image, loaded from the current startup device.

Alternatively, the user can interrupt Open Firmware by holding down the Command, Option, O, and F keys. Open Firmware responds by providing a command-line interface using the keyboard and built-in display. Using this interface, users can change the stored parameters used by Open Firmware.

Yosemite G3 (http://developer.apple.com/techpubs/hardware/Developer_Notes/Macintosh_CPUs-G3/PowerMacintosh_G3/frameset.html) - look for the section on System Software which goes into OF, boot process and is very informative.

Gregory

[This message has been edited by Gregory (edited 06 October 2001).]

Rem
10-24-2001, 12:19 AM
Ok ...here is what I found....
If you happen to run into this problem just delete all the system preferences...somewhere in that group something gets out of whack....you can also do a clean install ... but make sure you do not copy your prefs for system stuff over. At least as far as I can tell thats what the problem was.

ricks
10-24-2001, 12:44 AM
Hi Rem,
I have no problem Option Booting on my rev2. I am running 10.1 and 9.2 with a USB ApplePro keyboard. The option brings up a select system disk menu.

Apple has recently come out with drivers for most epson printers. I think you can go to Apple downloads and add that to OSX to use your Epson. I am using an 860 in 10.1 with no problems. These are NOT available from Epson.

Thanks for the tip LV on hiding the Classic folders, I had the same problem. Not critical for me as I had another 9.2 sys folder in another hard drive.

Rick