PDA

View Full Version : OF Hack? for booting X with upgraded CDRW in Beige G3?



Kenners0107
10-18-2001, 05:45 PM
OK, I just put a Toshiba SD-R1102 CD-RW/DVD-ROM drive into my Beige G3, & love it, except for ONE THING: It will NOT boot the OS X 10.1 CD. When I try, I get a "Default Catch!" message that leaves me in open firmware. I know this drive is bootable with OS X CD in New World Macs... It's a drive that Apple supports.. Anybody know how I might alter open firmware settings to allow this drive to boot the OS X CD??

Thanks

lasvegas
10-18-2001, 11:27 PM
You might try the XLR8 Startup Disk Maker which is part of the XLR8 MACh Speed Control (ftp://ftp.macgurus.com/ftp/xlr8_stuff/speedcontrol_folder/XLR8%20MACh%20Speed%20Control%202.6.1/) Classic install. The utility is intended specifically to modify the Startup Disk control panel for booting OS X on a Beige G3.

Kenners0107
10-19-2001, 08:43 PM
Thanks for the reply, lasvegas--

I gave it a try & got the same result. Let me offer some more information.

Beige G3 MT with A/V personality card, Sonnet G3 500, Radeon PCI video card, 2 monitors (on the onboard video and the Radeon), 2 45gig Deskstar 75GXP hard drives on the onboard IDE bus (one device 0 on bus 0 and one device 1 on bus 1), Toshiba SD-R1102 CDRW/DVD on bus 1 device 0 (which replaced stock 24X CD-ROM drive), stock ZIP drive, bus 0 device 1, 768MB RAM, Ratoc PCIFU1P combo usb/firewire card. The drive on bus 0 device 0 is partitioned 7.9gig first with OS X 10.1 installed, 2 gig second with OS 9.2.1 installed, and the rest for backup etc. The other drive is one partition & is for my everyday OS 9.2.1 use.

The ONLY thing I had to change to get OS X 10.1 installed was to plug the stock CD-ROM drive back in. After, I put the SD-R1102 back in and it works flawlessly, for burning CD's from the finder & iTunes in 9 and X, for watching DVDs with hacked Apple DVD players both in 9.2 and X, etc. If I stick the OS X install CD into it, though, I get the following:

DEFAULT CATCH!, code=fff00700 at %SRR0: 01c005b4 %SRR1: 00083070

The open firmware version on my machine is 2.4

I guess I wondered if anybody knows how to alter open firmware settings to work around this.

Whew.

I'll be waiting & holding my breath!

TIA,

Andy

lasvegas
10-20-2001, 12:19 AM
You might try booting directly through OpenFirmware using Boot Variables (http://www.lvcm.com/lna/files/bootvars1.3b.sit) without the patching. Or in OpenFirmware directly.

Enter Open-Firmware and enter the following:

setdefaults¬?¬?¬?¬?¬?¬?¬?¬?¬?¬?¬?¬?¬?¬?¬?¬?¬?¬?¬?¬ ?¬?¬?¬?¬?¬?¬?resets everything removing all patches
setenv boot-device ide1/@0:9¬?¬?¬?¬?¬?¬?¬?¬?¬?sets CD drive, partition 9 as device
setenv boot-command 0 bootr¬?¬?¬?¬?¬?¬?¬?¬?¬?¬?executes the bootX code.
boot

If using Boot Variables, just adjust the boot-device and boot-command accordingly.

I've found that during boot, Darwin will automatically install the correct patches into OpenFirmware during the first boot. This technique works on my 9500 (with my patched CD and correct boot device for my system.). I can't guarantee it will work flawlessly on yours. Some of the G3 systems identify the ide1 above as ata1 instead (I suspect only the powerbooks.). I don't know what the rules for new-world systems are.

[This message has been edited by lasvegas (edited 20 October 2001).]

Kenners0107
10-20-2001, 08:45 PM
Thanks again.. I appreciate your input.

I booted into OF and typed the three commands you suggested (except "set-defaults" instead of "setdefaults") and it didn't change the outcome.

I also downloaded bootvars 1.3b & tried using that to save settings to NVRAM & that didn't change the outcome either.

I have no background in this sort of thing; the Apple tech docs on OF were incomprehensible to me :-{

Oh, well... Any other ideas?

TIA, andy

lasvegas
10-21-2001, 07:23 PM
Some CD-ROM drives just can't handle booting directly from a partition. This is usually due to poorly calibrated azimuth on the drive. Do you have another CD drive? Perhaps installed externally?

[This message has been edited by lasvegas (edited 21 October 2001).]

Kenners0107
10-21-2001, 08:31 PM
The only other drive I have is the stock CD-ROM drive, which I put back in to install X.

The other experiment I tried was I put this drive in a rev.1 B&W G3 that belongs to a friend and it booted and installed X fine on that machine (the same CD which I used to install X on my machine; at least I know that isn't a variable).

Maybe I'm asking too much of this drive in this machine.. but I've never been afraid to hack... :-)