PDA

View Full Version : Problems booting after upgrading Miles2 firmware for OSX



tm311
10-04-2001, 08:51 PM
I have been working with LV trying to flash my miles2 card with the latest firmware for OSX. I have tried everything to make it work....i am (as well as LV) wondering if this could be a scsi termination thing rather than a firmware issue....

lasvegas
10-04-2001, 11:45 PM
You have two drives attached to that card? Are they LVD drives? If so, do you have a terminator all by itself on the end of the cable? You could also use an in-line (female connector on one side & male on the other.) terminator between the last connector on the cable and the last drive.

tm311
10-05-2001, 12:00 AM
i do have two identical Cheetah 10k LVD HD's on that bus. They were raided together for a couple years with great success. I recently split them apart and now have OS9.2.1 installed on both of them. Softraid 2.2.2 is managing my main HD and i have Drive setup managing the other drive as i am getting ready to install 10.1 on the apple drive. i can boot from either drive no problem. I have 1 of them at ID#1 and the other at ID#2. No termination jumpers on the hard drives themselves because the LVD cable comes with a terminator direct from initio. I only run into the boot problem after installing the new firmware, and as soon as i switch back i am golden.

lasvegas
10-05-2001, 03:04 AM
I'd recommend at this point to contact Inutio Tech Support. The phone number is listed on their web site. They were a great help for me!

tm311
10-05-2001, 06:51 AM
I did send them an email yesterday and i will give them a call today from work....yes they do have a great tech support line. Thanks for the help!!!

tm311
10-05-2001, 06:45 PM
This is my answer from Miles.......pretty much what i expected....but i will make this work.

If you have an approved machine then flash the firmware and it should
boot, if it does not then boot into Open Firmware by holding down the
Command, Option, O, F keys during the bootup. Then at the Open Firmware
prompt type in "reset-all" and press enter. This will force the machine
to reset all hardware configurations and will all the machine to boot
up. Please note that this must be done with the MilesU2W installed and
connected.

tm311
10-05-2001, 08:15 PM
Problem almost solved....aftert alking to Dan at Initio on the phone he suggested i try zapping the pram and resttingthe cuda...(can't believe that never crossed my mind...DOH!!!!) I xan now boot with one of the drives attached but not both. I need to search out and find out some rules for assigning ID #'s and whether i need to get softraid off the comuter. I have one drive with SR and the other with Drive SU. Miles2 in slot 1 going to the apple drive at id#1 and then to the SR drive at id #0..i can boot with the single drive hooked up and during booti can connect the second drive and all is well.......but if they are both connnected i get grey screen as if it were a scsi id issue.



[This message has been edited by tm311 (edited 05 October 2001).]

lasvegas
10-06-2001, 03:46 AM
I like their suggestion for using OpenFirmware, but I'd take it one step furthur. At the OpenFirmware prompt enter:

> set-defaults
> reset-all

The first line resets all of the Environment settings to the default settings, then the second line resets the system.

Note that on many oldworld Macs (9500 and older PCI Macs), Command-Option-O-F will not display OpenFirmware on the display unless parameters are set ahead of time. Instead, those machines will send OF to the Modem port! You can access it by plugging a standard Mac printer cable between the modem ports of that and another Mac. On the other Mac, run a communications program like Z-Term set to Local and at 38.4K baud. When you boot the problem machine into Open-Firmware, it will display in the Terminal window.

tm311
10-06-2001, 10:10 AM
Ok.....12 hours and many cups of coffee....i have at least solved most of the problems.....by getting rid of the softraid driver on my main boot disk and putting drive-setup on both drives i am now able to boot with both drives attached. It may or may not have been the problem all along..but i am up and running again. For good measure did a complete re-initialization of both drives and a complete re-install of 9.0 and then an immediate upgrade to 9.1 on both drives.....i have blown out all traces of anything except 9.1 and apple drive setup. all sems very stable and bootable....today i will ad things backto my main drive and if all is good tonight i will try installing 10.1 on my other drive......this is fun right????

PS LV....i was not able to boot into open firmware on this PTP but Dan from Initio assured me that for the most part zapping pram and hitting the cuda was basically the same thing......cross your fingers and hopre for the best..this is fun right??? http://macgurus.com/infopop/emoticons/icon_smile.gif

[This message has been edited by tm311 (edited 06 October 2001).]

tm311
10-06-2001, 11:45 AM
Strike 1

Tried installing OS10.1 and did not sense that i got a kernel panic but i did get a "memory exception and i could not get past it....rebooting did not work and continue did not work...it ended up reading......hanging here.....


Something about waiting for a debugger. back to the readng pages.

lasvegas
10-06-2001, 10:47 PM
Okay tm,

You've got a PTP. OpenFirmware has to be setup to get to it. The newest version of Unsupported UtilityX 2.0b3 (ftp://ftp.macgurus.com//ftp/osx_stuff/UnsupportedUtilityX2.0b3.img) will allow you to tell OpenFirmware to use your Keyboard and Video card instead of the Modem port. This may also cure your problem booting the 10.1 CD.

tm311
10-07-2001, 12:38 AM
Strike two..but it wasa long foul ball that BARELY went foul before drifting into the seats.

Ok....i did a couple things based on ryans OWC page...flashed my ATI vr128 card with the latest firmware and moved my plextor internal scsi cable to the external scsi port. I then booted into my OSX volume(2 partitions..one empy one with a fresh install of 9.1)...I opened the latest Uunsorted mac utitlity and went for it.......i was jumping up and down ...i got to the installer and clicked all the way through and watched as it finshed doing the clean up....it then did its auto restart and i was pumped!!!! BRING IT ON!!!...........

but i booted into a kernal panic......remebering what i read on ryans page...i went back to my old volume and re-opened the unsuported mad utitity and rechose the target volume andhit restart hoping for the best...but no luck.i am still in kernal panic hell.......and back to the drwaing board....But i do have a fresh install of 10.1 on my volume....i just can't seem to boot into it.......i am going to throw a small jpg onto the ftp site to let you OSX'rs look at what i see....and let me know if it looks valid......itwill be a screen capture of my desktop from os9

hubba bubba
10-07-2001, 01:04 AM
Did you put the ATI ROM extender file from your OS 9 extensions folder into the OS X folder specified in ATI's updater instructions? Maybe it's the ATI card causing the kernel panic.

tm311
10-07-2001, 01:33 AM
i DID it!!!!!!!!

I am too tired to play around with it. right now, but i made it to OS10. I went back and tried ryans fix again only this time i made sure "update extensions" was selected. And i booted into it without a hitch.....i only wish i could figure out how to get online......maybe my GV modem is not supported or i have to figure out where to "connect"......but right now i'm tired and i am going to boot back into 10 so i can wake up in the morning to a beautiful aqua sunrise....

thanks for all the support LV!!!!!

tm311
10-07-2001, 12:17 PM
I fugured out the modem thing....there was something checked in the ppp preference that needed to be unchecked.

[This message has been edited by tm311 (edited 07 October 2001).]

lasvegas
10-07-2001, 03:50 PM
Darn! Forgot to mention that the 10.1 installer breaks the oldworld extensions. The update doesn't, so I didn't run into that problem.

Do follow hubba bubba's advice and install your ATI extension into 10.1 per the instructions in the ReadMe file. I did it using my Root account even though I installed using HFS+. I figured it was easier than booting back and forth to accomplish the task.

Next step is to install the XLR8 SpeedControl 2.6 (ftp://ftp.macgurus.com//ftp/xlr8_stuff/XLR8%20MACh%20Speed%20Control%202.6.0/XMSC_2.6.0_OS_X.sit) required for 10.1.

If you're using a Kensington mouse or trackball, get the most recent OS X driver for it from Kensington (http://www.kensington.com) themselves. The version on the iDisk is obsolete.

All I need now for my setup is support for my TV/Capture card! Hopefully soon, but I expect a needed patch to the Kernel.

[This message has been edited by lasvegas (edited 07 October 2001).]

tm311
10-07-2001, 04:21 PM
I did install the xlr8 2.g onto the OSX disk....i have yet to deal with the ATI extension but that is next. For a mouse i am using the xlr8 scroll mouse and i am not running into any issues with it yet......i have not tried my cd burner yet but i did download the toast osx beta. I am just playing around trying to get familiar with things....it is so COOL!!!!! well worth the trouble and the agravation. I love both OS's but the whole "apple says no you can't run it on OW machines buy new ones ..........its nice to not have to shell out 1500 bucks for a new one!!!!"